Sign in to follow this  
Guest

New G4 : FlyII out ?

Recommended Posts

I bought a new G4 with Jaguar 10.2 (and downloaded all the security updates since) from Apple Store. I installed FlyII from the CDs, and applied the patch to have the 218 version. On launching FlyII for the first time, it quits immediately without any message.I have the Geforce 4 (with 32 megs) installed by Apple and 512 megs of RAM. All is fine except FlyII. I tentatively made a launch under Classic : no way. So what ?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There's an OSX patch for Fly II on the MacSoft website www.wizworks.com/macsoft. Go to the Support section. I used it and installed Fly II temporarily on my daughter's new eMac and Fly ran, albeit lack-luster, under 10.2 but really rocked if I rebooted into 9. Try restarting in 9 instead of running under Classic. It's worth the trouble. Fly recognized the nVidea card under either system.Note the posts here about Fly not recgnizing controllers under X--another reason to boot into 9.

Share this post


Link to post
Share on other sites

Thank you. I will try and let you know the result. (Note : I tried under MacOS 9 but for the same result, except a black alert window without any message !).

Share this post


Link to post
Share on other sites

Alas ! I tried but in Classic, I only have the message "Unable to open podfile system/startup.pod". And in MacOSX I have the first picture and it hangs...

Share this post


Link to post
Share on other sites

Jean,Apart from the controller problem noted by Allan, Fly! II still works fine for me under 10.2.1, so I'm not sure what's causing the problem. I wonder if trying to launch it under Classic could have screwed something up? Maybe you should try reinstalling Fly! II. BTW, Fly! II will not run under Classic - best boot directly into OS 9.-Franklin------------------------------Franklin TesslerDP 800Fly! for Mac Co-moderator

Share this post


Link to post
Share on other sites

I will try. Thank you. The difficulty is that MacOs9 was not given with the new G4. So I bought it separately and installed it on an external disk (scsi) for another difficulty was that Apple is shipping G4 without any partition on the hard drive !And FlyII hanged also.Finally I am repartitioning and reinstalling all. I hope that this will be efficient !

Share this post


Link to post
Share on other sites

Ain't these new G4's pretty! I got mine about two weeks ago and it is great!I too had difficulty with getting Fly! II to run. I had the same symptoms. It would run the publisher quicktime, another splash screen or two and then quit. Dead. I did get a message that the program had quit. That was kindly provided by the Apple OS (Jaguar in my case), not from the Fly! II program.I did some _more_ searching on the net, going through quite a few pages of "finds". Again, it isn't something I found on Terminal Reality's site. It was on infogames. First, some caveats. I've got the dual 1 GHz, 1-1/4 GB RAM, 64 MB ATI card. I don't have a bunch of alternate input devices. I ran the patch and the program ran, although at only one resolution--the 640x480--if you can believe that. Nevertheless, it ran.I'm came here (first post) to see if there were some other alternatives. I _have_not_ tried booting into OS 9 and running it from there. I will. So, after all that verbiage, follow some links on the site, or a direct download link is . Personally, I wouldn't directly download a file from a posted link unless I _really_ knew the person. Follow the links from the above infocom site. It is just a simple file replacement. Nothing major.>I bought a new G4 with Jaguar 10.2 (and downloaded all the>security updates since) from Apple Store. I installed FlyII>from the CDs, and applied the patch to have the 218 version.>On launching FlyII for the first time, it quits immediately>without any message.>I have the Geforce 4 (with 32 megs) installed by Apple and>512 megs of RAM. All is fine except FlyII. I tentatively>made a launch under Classic : no way. So what ?BuckyJuniorIkimashoo.

Share this post


Link to post
Share on other sites

Jean,Do you mean that OS 9 wasn't installed on your G4 or that it didn't come with installer disks? The dual 1GHz Mac I just set up in my office came with OS 9 installed, but without installer disks.Good luck, and let us know how you do.-Franklin ------------------------------Franklin TesslerDP 800Fly! for Mac Co-moderator

Share this post


Link to post
Share on other sites

Yes. On the new G4 there is only Classic. The disks have no Mac OS 9 version, except Classic. It was said by Jobs last month, so I hurried to buy Mac OSX 10.1 with the Mac OS 9 disk, and waited the arrival of the new G4.

Share this post


Link to post
Share on other sites

Here is what I have noticed about Fly! II...A) Witihout the OS X patch in place, running Fly! II under Jaguar. Fly! II plays its intro movie from Macplay and then quits.A) With the OS X patch in place (it replaces the HID Manager Support Package) Fly! II does run under Jaguar, but it does NOT recognize any of my joysticks.:( Fly! II will NOT run under classic mode in OS X (any version)C) Fly! II will run if I boot into OS 9.2.2 with one exception: You must install Fly! II from within OS 9 NOT OS X or Fly! II will have all sorts of lockups and Python errors in 9.Hope this makes sense.By the way, my OS X and OS 9 are on the same partition and have no problems... just install X first and then install 9.---John R. SippyChicago, IL, USAPowerMacG4 -Dual 5001024MB RAMnVidiaGF2 - 32MB

Share this post


Link to post
Share on other sites

John,One possible solution I haven't had time to play with is a shareware product that's supposed to provide support for various joysticks under OS X. I did try it very briefly, and it did recognize my yoke, but it still didn't work in Fly! II. That was a few weeks ago, however. (I don't remember the name off the top of my head, but my post should still be around.)-Franklin------------------------------Franklin TesslerDP 800Fly! for Mac Co-moderator

Share this post


Link to post
Share on other sites

I believe that utility was a MacOS X control panel called "GamePadCompanion".I looked into it briefly, but I didnt think it would work for me. It appears to be a "Mouse Emulator" allowing the user to map joystick (or gamepad) axes to OS X mouse axes. Since I use the USB FlightSim Yoke (5 axis controller) and ProPedals (three axis controller), I figured that mouse emulation would only allow for mapping of any 2 axes from either controller.I am hoping that since Jaguar appears to have improved the graphics card problems people were experiencing, Rich Harvey may now have less coding work to do in order to get us a patch.---John R. SippyChicago, IL, USAPowerMacG4 -Dual 5001024MB RAMnVidiaGF2 - 32MB

Share this post


Link to post
Share on other sites

Hi, John.I have the same yoke as you, and I couldn't get it to work. For me, the yoke not functioning in Fly! II under OS X is the main issue that's keeping me from using Fly! more often. I know that Fly! II works great under OS 9 now, but I hate re-booting. (I'm not that lazy - it's just that something gets screwed up every time I switch. :))I don't know if Rich is still working on a Mac patch, but input device support and support for all the systems in the latest PC version would top my wish list.-Franklin------------------------------Franklin TesslerDP 800Fly! for Mac Co-moderator

Share this post


Link to post
Share on other sites

I don't know if FlyII is running on old G3 or G4 but on my NEW G4, I am very limited. I worked hard to reconfigure all (the G4 coming from the Apple plant had not ALL the systems and applications). Now, only with Jaguar 10.2.2, FlyII launches. The plane functions, the fluidity is great, the sceneries highly detailed, the sound good BUT, BUT... no way to configure the keyboard commands with the menu, no way to use my USB gamepad (same thing with Gamepad Companion). No way to make the plane obey to the four arrows, etc. I have badly crashed many planes !Some commands are usable, but partially. So the TAB give me usual indications, but not the FPS, and on one screen only. (I am searching if any file is bad configured for the new extended keyboard).No way also for FlyII with Mac OS 9.2.2 on an external drive. It crashes instantly. And Mac 9.1 is not compatible with this G4.I hope there will be soon others users of the new G4 to permit us all to solve this annoying situation..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this