Sign in to follow this  
Vulcan

Anaglyph help

Recommended Posts

Inspired by the recent discussions about the inexpensive way to get FS in 3D I got the glasses today and installed the Nvidia stereo drivers but have problems.Originally the stereo drivers gave an error msg when I clicked on desktop properties ->advanced, that was with 23.11 drivers now with 28.32 drivers the stereo drivers laod and I am able to view the stereo settings page.As soon as I go to full screen mode in FS I get a black screen and a complete lock-up, no response to key presses including CTRL+ALT+DEL, only a hard reset will bring the PC back.Graphics card GF3Ti200Drivers 28.32Stereo drivers from file 'StereoE.exe'OS Win98SEThere is another stereo driver on Nvidia's site 'Win98_ME_Stereo.exe', should I be using that instead of the 'StereoE' driver?TIA

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If anyone can offer advice on this problem, I too would be interested.I encountered a similar problem using StereoE on Windows ME with 28.32 driver and GeForce 2MX: on entering FS2002 got a complete hang on a black screen - hard power reset being the only way out. I wasn't aware of the other stereo drivers - just took the one presented following the menus on the web site - so haven't tried it.After much thrashing around I managed to get 3D to work but only in lowest resolution (640 x 480 x 16 bit) provided I set FS2002 to the same setting *before* turning on 3D with the hot key. It seems to be the mismatch between FS and 3D driver settings that causes the hang. I normally run FS at 1024 x 768 x 32 but I have not been able to get the 3D driver to save this setting - the demo appears to work at that setting but I can't get it to save. Perhaps it is a limitation of the 3D driver with my card?Cheers, John.4m NW of EGHI (Southampton UK)FS2002 on Intel PIII 733 MHz, 256MB with 32M GeForce2MX graphics and Windows ME.

Share this post


Link to post
Share on other sites

Hi Vulcan,Setup the stereo to be enabled/disabled by hotkey instead of always on. Once you startup FS and actually enter the engine (after the menu screens and you are on the preferred runway), then hit the hotkey to enable stereo mode. This is a lot more stable way to run apps than the default of always on. Also remember to disable the stereo mode with the hotkey before you leave the 3D engine. Saves from some possible lockups with some games.As an unrelated note: if you bought red/blue glasses instead of red/cyan, you might want to change the preferences in the stereo driver to blue. It defaults to cyan. Some prefer that even with blue, but some don't. If you do change the color for the right eye, make sure you select 0,0,255 as the color (RGB).Good luck, http://members.rogers.com/eelvish/elrondlogo.gifhttp://members.rogers.com/eelvish/flyurl.gif

Share this post


Link to post
Share on other sites

This is a good thread... I've seen some posts about the red/blue anaglyph glasses before.. and I have dug out some from an old box of cr*p here... so does this mean I can use them with my nVidia GeForce2 MX400 ?? I am using drivers later than 23.32. I didn't notice any stereo capabilities on the setup menus!Do I have to install seperate 3D drivers for the GPU? If so, can anyone tell me where I can get the correct drivers for GF2 MX400 64mb running on Windows XP ?Thanks,Simon.

Share this post


Link to post
Share on other sites

Hi John,I now have stereo working :-)Looking at my GF properties it looks like I am using 23.11 stereo drivers (which I guess are from the 'stereoE.exe' file - can't remember now)and 28.32 'standard' drivers.I ended up resetting desktop and FS to 800x600 and the stereo was OK, from there I just increased the res in steps upto my normal 1280x960 and everything stayed stable.I am running a GFTi200 64MB card so maybe your card will limit the max stereo res avalable. Try what I did, move up in steps and see what it will take, and take Elrond's advice, set up a hot key for stereo and start in normal mode first.The 2 drivers are both on the Nvidia site, it just depends where you look for them :-)If you go to the Win9x/ME drivers d/load page the stereo 3D driver is at the bottom of the page and is the 'StereoE.exe' file.However if you do search from the Win9x/ME drivers page it brings up another page with the 12.40 drivers on and a number of stereo related document files.Best of luck.

Share this post


Link to post
Share on other sites

Hi Elrond,Thanks for your help.Now have stereo working (see reply to John above), still need some experimenting though.>if you bought red/blue glasses instead of red/cyan, you might want to change the preferences in the stereo driver to blue.

Share this post


Link to post
Share on other sites

Thanks Vulcan - I will try your suggestions this evening.Cheers, John.4m NW of EGHI (Southampton UK)FS2002 on Intel PIII 733 MHz, 256MB with 32M GeForce2MX graphics and Windows ME.

Share this post


Link to post
Share on other sites

Hi Vulcan,Thank you for the very nice sentiment. It is getting better and I'll hopefully be back on my feet in just a few more days.I'm suprised to hear that addon scenery isn't working well for you. As long as it's modeled in 3D (which all buildings, trees, etc are in FS2K2) the driver can automatically convert it to true 3D. I'll have to download Gary's scenery and check it out. To date, I haven't had any problems with any of the addon scenery I've used (unfortunately because of time, thats not very much).One thing to keep in mind: you can change the amount of seperation using the hotkeys built in to the driver. There are a lot of different hotkey assignments and some of those may conflict with FS's built in key assignments, so you'll probably have to remap the drivers hotkeys. The four sets listed below are the most useful in my opinion, so make sure you at least map these:Additional Properties Button:Less Stereo SeperationMore Stereo SeperationGame Configurations - Configure Hotkeys:Increase ConvergenceDecrease ConvergenceThe other Game Configuration hotkeys can be useful in certain situations as well, of course, but the four above have to be adjusted to your preferences in almost all games (thats been my experience at least).If you haven't downloaded the users guide for the Stereo drivers, I highly recommend you do. The "online help" within the drivers is very poor, but the users guide gives great detail on all the different settings:http://www.nvidia.com/docs/lo/1403/SUPP/NV...StereoUG_20.pdfBest of luck,http://members.rogers.com/eelvish/elrondlogo.gifhttp://members.rogers.com/eelvish/flyurl.gif

Share this post


Link to post
Share on other sites

I made only limited progress last evening - takes a long while when you keep going through hardware reset then scandisk...I have confirmed that I have stereo 23.11 driver level which I believe is correct and I can provoke the hang even when toggling stereo on only when the FS2002 3D engine is in action.I cannot get it to remember my game-specific hot key configuration: when I'm in FS2002 it still responds to only the default stereo hot keys like ctrl-T to toggle on/off. I think I'm doing what the user guide says but perhaps I've misunderstood. I create a new key under FS2000 by pointing to fs2002.exe, enable in-game config, then remap and save the hot keys. The driver manager seems to remember this but it doesn't seem to take effect in FS. The only thing which seems suspicious to me is that I can put in the key and press 'change' only for the demo version of FS2000 and not the 'full game' for which the entry field and button are greyed-out on the GUI panel. Anyone know what I might be doing wrong? Thanks, John.4m NW of EGHI (Southampton UK)FS2002 on Intel PIII 733 MHz, 256MB with 32M GeForce2MX graphics and Windows ME.

Share this post


Link to post
Share on other sites

>I mentioned in another thread to you that it looks as if add-on scenery in FS does not take the off-set image.

Share this post


Link to post
Share on other sites

Last night I uninstalled the drivers and reinstalled with the new NVIDIA 29.42 version then reinstalled the stereo drivers. I can now get the Sim to recognise my hot key configuration and, following Vulcan's advice, stepped up desktop and sim resolutions. I got 1024 x 768 x 16 to work OK in 3D but attempting 32 bit resulted in the hard system freeze. My guess is that the hang results from trying to push beyond the limits of the card.Cheers, John.4m NW of EGHI (Southampton UK)FS2002 on Intel PIII 733 MHz, 256MB with 32M GeForce2MX graphics and Windows ME.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this