Sign in to follow this  
Guest

Framerate Lock Question

Recommended Posts

After I installed FS2002 on my home computer (see specs at the bottom), the Framerate Lock automatically defaulted to 30 FPS, I have never tried changing that to any other value. I did change all my "Realism" and all my "Option" settings all the way to the maximum though.The problem I'm having is that my FPS are slow sometimes, specially when flying through dark clouds. Normally, I get 10-18 FPS, but when I fly through clouds, it goes down to 1-4. On a overcast day, landing with a framerate of 3-4 is almost very hard.* What would be the effect of changing my Framerate Lock from 30 to, say, 20?* Are there any setting changes that will boost my FPS without sacrificing too much realism or display features?Thank you,Kerke (KTMB)SYSTEM SPECS:--------------------------Windows XP ProfessionalAsus CUSL2-C Intel PIII 1000MHZ512MB Crucial SDRAM PC133 CAS2Elsa Gladiac 32MB GeForce2 GTS DDR NV15Western Digital WS1200JB 120GB 8MB cache 7200RPM EIDE drivePlextor 12/10/32A EIDE CD-RWSB Live! Value OEMNetGear FA310TX 10/100 PCI NICViewSonic GS790 19'monitor--------------------------

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Kerke,You have a reasonable computer, but the frame rates your encountering are in keeping with your system. You can get some improvement by locking the frame rate lower. I'm not interested in starting a :-newburn war, but for myself, I find that locking the FR at 25 gives very good performance. But even on my systems, the FRs will drop to the teens in scenery intensive areas, or using CPU hungry panels. In your case, you might benefit from locking at 15-20, the lower the better. Any time your system is not churning away creating what I will call "excess frames", it can divert those resources to other operations, which should give you an improvement in performance. In the end though, you will just need to turn down some of your settings to improve the performance on your system. Some easy tricks are to turn off all shadows, disable the ATC (if you can live in a lonely world all by yourself ;)), don't use clouds, use just detail level for water effects, don't turn autogen all the way up, and run in lower screen resolutions (1024 x 768 tops). Of course the list just goes on and on, but this should get you started. Good luck :-wave

Share this post


Link to post
Share on other sites

Thank you David, I decreased my framerate lock from the default 30 to 20 and it feels more fluid now. I'll keep tweaking the framerate lock between 15 and 20 to see which one is best.Best regards,Kerke (KTMB)---

Share this post


Link to post
Share on other sites

Kerke,You might also want to try the default hardware settings (eg "Best Graphics" - in the hardware settings box) and set your Framerate Slider to about 29FPS....Also increase your screen resolution settings a little (852x1164)!These work well for me!

Share this post


Link to post
Share on other sites

>The problem I'm having is that my FPS are slow sometimes, >specially when flying through dark clouds. Normally, I get >10-18 FPS, but when I fly through clouds, it goes down to >1-4. On a overcast day, landing with a framerate of 3-4 is >almost very hard. There is a dark cloud bug which sometimes occurs, depending on turbulence. Peter Dowson's FSUIPC.zip the library) allows the turbulence to be turned off, and fixes the problem. See the fsuipc readme for details.

Share this post


Link to post
Share on other sites

HiI have a pentiumII 400, it's almost an antiquity eh? :-eekNo problems flying FS2k2 in general, only in populated airfields.Sliders are on the max side (not all off them all the way :-) )FPS are limited at 16 FPS, since the eye cant see the difference when more fps are shown. It gives the CPU more time to calculate everything else nessecary, like nice scenery and AC add-ons.BTW, the best thing I added in my FS2002.cfg file is the next line under the {main} part:HideInfoText=1 FPS are not shown, nor any other red text, they don't bug me, and the sim looks smooth to me.It's all in the eye of the beholder.No DC3 without a DC2;-)Cheers, RobVisit http://www.avsim.com/hangar/flight/dc2uiver/index.htm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this