• Douglas DC-9 Military versions


    Chuck_Jodry-VJPL

    SKY SIMULATIONS proudly presents McDonnell Douglas DC-9 Military versions

    THIS PACK IS FREE FOR ALL OF OUR CUSTOMERS AND IS AVAILABLE FOR PREPAR3D, FLIGHT SIMULATOR X and FLIGHT SIMULATOR X Steam Edition.

    The package covers the most important military variations of the DC-9:

    -C-9A Nightingale. Aeromedical and evacuation aircraft, Used by the USAF. 

    -C-9B Skytrain II. Passengers and cargo transport. Used by US NAVY and MARINE CORPS 

    -VC-9 Vip Transport, used by the USAF (Air mobility command) to transport very important government persons. Even it managed to be the AIRFORCE 2.

    These are some of the characteristics of this package: 

    Advanced and custom animations, fully functional virtual cockpit, Enhancements over DC-9 V2. and countless details.

    Visit the SKY SIMULATIONS Homepage for further information.

     

    0




    User Feedback


    Well it looks nice, difficult to find on the website though. And it requires that you have DC9 already installed but sine you cannot install the old version into P3D4 how will the installer know.

     

    0

    Share this comment


    Link to comment
    Share on other sites

    Sadly, I can't even install the older SS DC-9, it asks me to activate it and then that never works, I emailed them about it and they said they were looking into it and never got back to me, so it never got sorted, so I'm certainly not going to be buying an expansion for it lol.

    0

    Share this comment


    Link to comment
    Share on other sites
    On 6/16/2017 at 4:40 PM, vgbaron said:

    Well it looks nice, difficult to find on the website though. And it requires that you have DC9 already installed but sine you cannot install the old version into P3D4 how will the installer know.

     

    I don't believe that it says anywhere that it is for P3Dv.4.  You have to be careful because these developers are still making software for P3Dv.3 and it is easy to assume that it is also for v.4 when they just say it's for P3D. Unless a developer specifically says it is designed for P3Dv.4, don't try to install it.  You could mess up your v.4 install by "shoehorning" addons in that have not been designed for the 64bit simulator.

    0

    Share this comment


    Link to comment
    Share on other sites

    Boy, I must really be getting old - I could swear it said V4. Wouldn't install it anyway - not the greatest model. Vic

    0

    Share this comment


    Link to comment
    Share on other sites

    I wrote them about P3D v4; hope they will answer; but I remember long times before getting a reply, in the past. And it was the very same issue posted by Chock. it's a pity, the plane IMHO was quite good.

    0

    Share this comment


    Link to comment
    Share on other sites
    19 hours ago, amanlulo said:

    I wrote them about P3D v4; hope they will answer; but I remember long times before getting a reply, in the past. And it was the very same issue posted by Chock. it's a pity, the plane IMHO was quite good.

    I'm sure that it is not ready for P3Dv,4 yet.  I just installed it in P3Dv.3.4 and it works perfectly.

    I'll definitely be putting it in P3Dv.4 once they modify it to work in it the way that it supposed to.

    The VC is visually just a little below today's standards (hopefully someone will re-work it soon), but it is a really nice DC-9.  What I like is that it forces you to use VOR navigation, plus a lot of systems are working on it.

    It also trims out and hand flies really nice.

    It'll gives me a good DC-9 and I don't really think that Coolskys will ever get theirs working in P3D.

    0

    Share this comment


    Link to comment
    Share on other sites


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!


    Register a new account

    Sign in

    Already have an account? Sign in here.


    Sign In Now