Fulani.Filot

Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

-3 Poor

Flight Sim Profile

  • Commercial Member
    No
  • Online Flight Organization Membership
    none
  • Virtual Airlines
    No

Profile Information

  • Gender
    Male
  1. Fulani.Filot

    Eaglesoft Citation X: Bizarre Occurrence

    Wow, you are lucky to even get the Cit-X flying. On ALL of my flights, VNAV never works; speed hold won't keep my chosen speed and vertical profile (altitude selected) just doesn't obey what I put into FMS. Also, while I am always able to start Engine-2 following the normal APU-bleed-assisted process, I have never been able to start Engine-1 using APU-bleed or Engine-2 cross-bleed, I always have to use FSX's shortcut "Ctrl+E" to get the engines going. I practically have to handfly the damned thing from origin to destination...leaving me to pick very short routes of 30min. This is for the Wilco FeelThere's Citation-X. As for Eaglesoft's Citation-X v2, I have absolutely NEVER been able to start the engines, only the APU starts and after some minutes of running, it stops and all electrical power (APU, batteries) cease...the aircraft is plunged into a cold-&-dark state and remains so until I REBOOT the FSX app.
  2. Fulani.Filot

    Eaglesoft citation X V2.0: MFD freeze

    Wow, you are lucky to even get the Cit-X flying. On ALL of my flights, VNAV never works; speed hold won't keep my chosen speed and vertical profile (altitude selected) just doesn't obey what I put into FMS. Also, while I am always able to start Engine-2 following the normal APU-bleed-assisted process, I have never been able to start Engine-1 using APU-bleed or Engine-2 cross-bleed, I always have to use FSX's shortcut "Ctrl+E" to get the engines going. I practically have to handfly the damned thing from origin to destination...leaving me to pick very short routes of 30min. This is for the Wilco FeelThere's Citation-X. As for Eaglesoft's Citation-X v2, I have absolutely NEVER been able to start the engines, only the APU starts and after some minutes of running, it stops and all electrical power (APU, batteries) cease...the aircraft is plunged into a cold-&-dark state and remains so until I REBOOT the FSX app.