Sign in to follow this  
Guest lawyerpilot

Phoenix Airbus----I can't buy on their site!!!! Please

Recommended Posts

I know this isn't the Phoenix forum, but my thread was deleted over there. As a soon to be paying customer, I am a little puzzled. I have attempted to "sign up" on their site over 20 times this weekend, and get a variety of "page cannot be displayed" as well as the red x by the email field once I try to login. I know their forum said they were back up and running on Friday, so did I miss something? I want to download this thing via cable.P4 1.8768 ram 80 gig hardriveVisiontek Ti4 4600CH yoke/pedals19" inch monitor-Soundblaster PCI 512Win XPPrivate PilotAOPALawyerPilots Bar Association"Men without dreams are never free, twas thus this way and thus will ever be."

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had the same problem this weekend when I tried to make a purchase, thought my credit card company screwed up my account (I knew I paid my bill). Anyway I think there is still some unresolved issues with their site, I would try back sometime next week as I sure will.Les--

Share this post


Link to post
Share on other sites

Thanks. It sounds like you even made it further than I did. I couldn't even get to the purchase screen. "Buy it" would take me to the login screen and then it wouldn't recognize me. Oh well.P4 1.8768 ram 80 gig hardriveVisiontek Ti4 4600CH yoke/pedals19" inch monitor-Soundblaster PCI 512Win XPPrivate PilotAOPALawyerPilots Bar Association"Men without dreams are never free, twas thus this way and thus will ever be."

Share this post


Link to post
Share on other sites

Did it work for you before? Do you have cookies enabled? Do you have any filtering software (NIS, ZA)? I disable all my firewalls and enable cookies every time I go there, otherwise it doesn't work.

Share this post


Link to post
Share on other sites

No, never did. But, my configs have worked for every other site I have ever been to. My cookies are on and firewalls down. >Did it work for you before? Do you have cookies enabled? Do >you have any filtering software (NIS, ZA)? I disable all my >firewalls and enable cookies every time I go there, >otherwise it doesn't work. P4 1.8768 ram 80 gig hardriveVisiontek Ti4 4600CH yoke/pedals19" inch monitor-Soundblaster PCI 512Win XPPrivate PilotAOPALawyerPilots Bar Association"Men without dreams are never free, twas thus this way and thus will ever be."

Share this post


Link to post
Share on other sites

Thanks guys. I did miss your reply. I am looking forward to using it! Have flown about 14 Seminole instrument hours in the last week or so in the real world, and am looking forward to getting into the cokcpit in your bird----we will be lightin the fires and kickin the tires. P4 1.8768 ram 80 gig hardriveVisiontek Ti4 4600CH yoke/pedals19" inch monitor-Soundblaster PCI 512Win XPPrivate PilotAOPALawyerPilots Bar Association"Men without dreams are never free, twas thus this way and thus will ever be."

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this