Sign in to follow this  
Guest bobsk8

Ground power no longer available

Recommended Posts

This morning, I noticed that my Ground Power Light never Llights anymore and I tried several large airports, gate combinations and switched planes. Battery shows drain when switched on, and of course without ground power, will continue to drain until APU is started. . Anyone have this happen. Flying mostly the 800 with the update.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Check you have your parking brake set! And of course engines not running. ;-)Hope it helps,

Share this post


Link to post

>Check you have your parking brake set! And of course engines>not running. ;-)>>Hope it helps,What!!! You mean you can't have ground power hooked up with the brakes off. They afraid you are going to taxi away with their extension cord :) Thanks, I would have never figured that one out.....

Share this post


Link to post

Hi Bob,(edit:) In addition to the parking brakes, this may also be a cause:Have your checked your standby power switch? If its cover is off when you switch on the battery, and the 'stby pwr off' light above it is on, what you describe is what happens...Best,Martijn

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this