Sign in to follow this  
StarBlue

Photoshop & Textures

Recommended Posts

Hey All,I know this might fit better in a re-painters forum, but it is with the PMDG paint kit and I know there are several re-painters in this group. :) Also I am new to re-paints and some of those re-painting forums are brutal to newbies.I own Photoshop CS, I am very adept at it and its tools. I don't own PSP and I don't think my wife wants me to buy any more expensive paint programs. Anyway this is my consternation, BTW thanks to the PMDG team for actually using multi-layer PSDs!!!; they make repainting a snap. I bring in the PMDG PSD and make my changes, then I save them out to a Targa format or BMP Alpha Channel Checked box is checked, Windows/32Bit radio buttons selected. I start up Martin Wright's DXTBmp program. This is where I am having my problems, I can import the BMP or Targa file in and save it out as as a DXT 3 file. I then use FS Repaint as a quick viewer and I do see alpha channels no problem.I notice that when I bring in my BMP or Targa file, I don't see the Alpha channel details in the Alpha Channel box in the upper right corner that I see when I bring in one of the textures of the default PMDG. I see them for everyone elses textures as well.Is there anyone else that uses Photoshop to do re-paints, if you have what am I doing wrong. I really would appreciate any help, I have been trying to figure this out for weeks and it has consumed me. HeheheThanks,Jhan Jensen

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hey Jhan,I use Photoshop for all my editing/repainting. The thing to do is save the texture as a targa file making sure that you have an Alpha channel embedded in the file (In the Save Copy dialouge box make sure the 'Exclude Alpha Layers' is de selected).Once you have done that there are two ways to go:1. Bypass DXTBmp if you are going to be using in 32 bit form and use Imagetool to convert it from a .tga to .bmp2. If you want to use them in compressed form you can either: a. Again bypass DXTBmp and use imagetool to convert them (sometimes doesn't convert aswell as DXTBmp but saves the trouble of application switching to remove mips) b. In DXTBmp load using 'File|Load Targa' with Alpha and go from there.If you choose to load the targa via any of the other load commands in DXTBmp the alpha won't show.Hope it helps, any questions on my sometimes mad ways to repainting just ask.Cheers,David

Share this post


Link to post

Thanks for the help, I tried it and it worked great. :) Now all I need to do is get patient enough paint a 737. I will definately ask if I get stuck, again thank you for helping. My brain was wanting to implode and that would not have been a pretty sight. Also if there are more ideas, I am willing to learn.

Share this post


Link to post

Hey Jhan,Glad I could help :DAs for other ideas, none really but if you give a specific question/problem I'll try and help :)All the best,David

Share this post


Link to post

No problem from there Jhan just choose in DXTBmp the menue option alpha and send alpha to editor (your editor of choice can be set via prefs menue and select editor option, browse to the *.exe file of your program)Edit your alpha channel and close the editor in DXTBmp make sure to refresh the alpha channel then save the texture as extended 32 bit 888-8 *.bmp file...Load the texture in image tool choose remove mip maps and leave the texture *_0.bmp open close all others...Save as *.tga file, load the tga file and save as *.bmp (alpha channel will be preserved in the texture ;-) )Have fun *:-*Andr

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this