Sign in to follow this  
Guest

"the stutter bug"

Recommended Posts

I have been tring to avoid doing this but I have no choice.The stutter bug of fs2k2 is now with me.It's not really stutters more like a 1/2 second pause.It's enough that I notice.I even have the timing down and rhythem of the "small" pause.Iam getting 20 FPS so i know it's not a FPS issue but this is just driving me insane.I see a frame jump every 2-3 seconds.When I go to the outside view I can actually see the frame jump brief then re sync.I thought maybe my refresh rate was to low but I have not done anything at tweak was wise in quite sometime and the tweaks i do do are nothing out of the norm.I just wanted to see if anyone has experinced this or not.I looked through previous post but did not find exactly what i was looking for.I have done everything I can think of.I have tried clean installing different 4n1 drivers,GF drivers,clean install of fs2002 and still have the problem.My bios is patched up to 3.60 which is the lastest.The only tweaks i have are 2x FSAA level 2 antisotropic texturing.I run fs2k2 with everything maxed except visablity (60) clouds (40) AI 50 resolutions is 1152.864@32.I have no clue what or how this happened which to me is pretty sad sence working in networking and troubleshooting :). thanks in advance and sorry to have to post that's proboly been beaten to death :) Richard Dillon KATLSr First Officer www.jetstarairlines.com"Bill Grabowski's"ERJ-145 panel Beta TeamMD-11 panel Beta TeamProject AI beta tester____________________________"Lets Roll" 9/11 Specs AMD 1600 XP 512MB DDR GF3 ti 200 64MB SBliveCh Products Yoke and Pedals(usb)Windows 2000 SP2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Richard,I would try a three step approach to get rid of the problem.1. Make sure your drivers are not mixed up.To do this try a somewhat different driver installation procedure:Unzip the drivers you ususally use to a known folder that I create.Then simply go to C:Windowsinf. In that folder I locate the nv3.inf and the nv4.inf and rename them nv3.i_f and nv4.i_f. I then go to Add/Remmove programs and uninstall the XP Nvidia drivers including the remove registry entries when asked.Reboot, letting XP discover new hardware. When the wizard comes up, lead it to the new drivers folder. The rest is a snap following instructions. Reboot, and use your favorite "tweak" utility to re-tweak your new drivers.Then return the nv4.i_f and nv3.i_f to their original names incase of a problem windows will still install the default XP drivers. Check if the stutters have gone better.2. Disable your AGP ind dxdiag.Click the start button and select Run. Type DXDiag. After it starts go to the Display tab. Click on the button to Disable AGP Texturing and press Exit.If the stutters are gone, or better, you can try to enable AGP again and play with low aperture size settings in your BIOS (8-32MB) and see what works best for you.3. Correct shared IRQs with your graphics adaptor.In some cases a shared IRQ with your graphics adaptor can be the reason for stutters. The procedure is different depending on OS and before I start elaborating over it here I suggest you try the other stuff.Alex

Share this post


Link to post
Share on other sites

gasebah, maybe you or someone else could tell me what the nv3.inf and the nv.4 inf files actually do. I have removed them, and the nv3.pnf and nv4.pnf, from windows/inf. In fact there are no nv.. named files in that folder at all. Yet everything works and runs as well as ever, absolutely no difference.Thanks, dek

Share this post


Link to post
Share on other sites

Ouch, you got me here. I am no techie I am just givin advice that helped me in a lot of situations. As far as I know these are the Windows default/backup drivers that Windows uses if anything goes wrong with the driver installation of new drivers, or Windows assumes something went wrong. By deleting these you prevent that windows is loading any old dlls that might still be in the driver cache. If nothing goes wrong you are fine of course if they are not there as Windows should only look for them in case something went wrong (automatic rollback e.g.). However if these files can be seen by windows on many occasions and for a variety of reasons windows pleases to load them or part of them while you actually want to install a new driver cleanly. Thats where stuff gets mixed up. It can end up in a situation like overinstalling drivers over and over again.Real techies!!! Correct me if I talked a lot of BS here.Alex

Share this post


Link to post
Share on other sites

If you disable FSAA, what happens ?Which video drivers are you using ?Pierre

Share this post


Link to post
Share on other sites

When this has happened to me it's always been because some other program was running in background or some logging feature was enabled. Can you reboot your computer, then use Ctrl+Alt+Del to see if anything unknown or forgotten is running? Then look at FSUIPC logging facilities and see if the stutters stop when you stop logging. R-

Share this post


Link to post
Share on other sites

.inf files are information files and basically tell windows which files are contained in that particular package, which ones to install for the OS and where they go, also contains registry entries so that the drivers are correctly registered.Once the drivers are installed AFAIK the .inf files are redundant, until you want to reinstall the drivers, hence Alex's suggestion to rename them and not delete them.You can read the .inf files with something like Notepad, but don't edit the contents.

Share this post


Link to post
Share on other sites

well i have tried everything and even did another clean install of fs2k2 and it is still doing it.I can see the screen actually pause for a brief second.it's stuttering at all.So iam totally lost no matter what i do it continues to jerk around every 3 or 4th frame but yet my fps read 25 .it makes no sence to me at all.There are no programs running in the background.I turn off any service i never use .*shrug* .i guess i will have to spend a day reformating because i have no clue what else to do Richard Dillon KATLSr First Officer www.jetstarairlines.com"Bill Grabowski's"ERJ-145 panel Beta TeamMD-11 panel Beta Team____________________________"Lets Roll" 9/11 Specs AMD 1600 XP 512MB DDR GF3 ti 200 64MB SBliveCh Products Yoke and Pedals(usb)Windows 2000 SP2

Share this post


Link to post
Share on other sites

Richard,I recently had the same problem. I could not find any ancillary program running in the background that was hogging cpu time, but cpu utilization would go from 1-2% to 100% and I would get a pause.I started turning off all of the obvious programs that were running, but just could not find it. Finally, I uninstalled and reinstalled my audio driver (believe it or not) and THAT solved my problem. I cannot tell you why the audio driver was periodically taking 100% of the cpu time, but it was.So, you might try that idea before starting over from scratch.Wilson

Share this post


Link to post
Share on other sites

Richard...I have the exact same problem....Last time, I reinstalled the VIA 4in1 drivers and that cleared it up. I tried that again and it did not work. I'm going to try and delete the fs2002.inf file to see if that helps...i'll report backAMD XP1800+Win XP Home

Share this post


Link to post
Share on other sites

wilson, that is not such a bad idea considering i did just upgrade my drivers a few days ago and it is a SB live which is know for it's problems.It proboly will not help knowing my luck but we will see Richard Dillon KATLSr First Officer www.jetstarairlines.com"Bill Grabowski's"ERJ-145 panel Beta TeamMD-11 panel Beta Team____________________________"Lets Roll" 9/11 Specs AMD 1600 XP 512MB DDR GF3 ti 200 64MB SBliveCh Products Yoke and Pedals(usb)Windows 2000 SP2

Share this post


Link to post
Share on other sites

OK...redid the fs2002.cfg...that did not help.Reinstalled 4in1...that seemed to improve the pulse severity, but it did not go away.Here are some screen shots...my LAN pulses every 20-30 seconds, but the sim pulse is more like every 4 or 5 seconds...The othe image shows the processes running on my machine. PSP is Paint Shop Pro which I used to save the images...but whar are all the rest ???

Share this post


Link to post
Share on other sites

Same problem, but I've got 46 of the little buggers! See it jumpp to 100% when I toggle in and out of FS2002! It's not like this ALL the time, but sometimes, as with others, above.http://www.swiremariners.com/system.jpgNote, though ,that you have no CPU hit on your processes, Dave. Don't think they're too much to worry about. They are not the problem.It's boiling down to a sound card or driver issue for me ... more soon.Mark "Dark Moment" Beaumonthttp://www.swiremariners.com/cxkaitak.htmlhttp://www.swiremariners.com/reds.htmlhttp://www.swiremariners.com/cxkaitakv3.jpg

Share this post


Link to post
Share on other sites

wow 46 process are you sure you are not running services you do not need like DNS server DHCP server etc.by default in winxp pro and win2k all the stuff that you normally would not need in workstation config is on !DOH I uninstalled the lastest win2k sblive update and reinstalled the orginals from the SB cd and i think and HOPE it worked.I also removed any reg entries pointing to my SB card before hand.PS there is a fix on guru 3d that fixes some problems when upgrading from the 30.xx to the 41.xx betas :)Richard Dillon KATLSr First Officer www.jetstarairlines.com"Bill Grabowski's"ERJ-145 panel Beta TeamMD-11 panel Beta Team____________________________"Lets Roll" 9/11 Specs AMD 1600 XP 512MB DDR GF3 ti 200 64MB SBliveCh Products Yoke and Pedals(usb)Windows 2000 SP2

Share this post


Link to post
Share on other sites

>PS there is a fix on guru 3d that fixes some problems when upgrading >from the 30.xx to the 41.xx betas.Which is not needed in the first place if you follow my suggestion for driver installation.Hope you get that thing worked out.Cheers,Alex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this