Sign in to follow this  
Guest

Windows XP defrag = Stuttttttttersssss!!!!!!!!

Recommended Posts

Hello all,Finally got my new machine running the way I want it (very sweet). Then I made a huge mistake and ran the defrag process (first time running defrag on this box). Now Frame rates are where they have always been, which is good, but there is a noticable "pause" when panning around scenery and on final approach to "moderate to high traffic" airports. Also, the ATC sound is now very choppy. As you can see by my specs I have plenty of horsepower. Frame rates before this tragedy where locked at 25 with a dip into the low teens at high traffic areas. The defrag really screwed things up.I am assuming that I am going to have to delete and re-install FS2002 and possibly drivers to straighten this out. Has anybody ran accross this before?Thanks very much for any help.JeffWindow XP home editionP4 2.26G 533Mh FSB512 RAM40G MaxtorTI 4600 Card VidTurtle beach sound cardFS2002 Only (No Internet, Doc processing, ect...)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi, Jeff. I use Norton SystemWorks 2002 for defragging. It has never caused me this problem on my setup. On the contrary, it always tends to improve things for FS2002 and FU3. I've made it a habit to run it about once a week.All the best.

Share this post


Link to post
Share on other sites

After defraging in XP Home, I had a VERY SERIOUS corrupted file(s) issue. Some files (a few) were currupted. And they were just ".jpg's". And those files crashed everything (and I do mean everything). I was dead in the water, if they got addressed in any way !!!They crashed the CD burner, Windows Explorer, My Computer (if addressed in a window), Defrag itself, the XP Error Checker (the old scandisk - which is now... Right click, properties, tools, Error Checker). They could not even be highlighted in any window without locking up the machine. And they could not be deleted either !!! The machine locked if they got addressed in any way. All you could do was create a new folder and move everything else around them that was good, to a new folder. And then rename that folder which contained them as "corrupted-xx". I even thought the hard drive had gone bad, but I decided I could live with the "corrupted" folder spots that contained these files.But I could never error check again, as the machine would crash.Then I decided to download Service Pack 1 (SP1) and install. To my surprise, the new error checker (the old scandisk - Right click, properties, tools, Error Check), worked without crashing (locking). It even corrected and restored these files.I went in and deleted the files just for good measure (since I had a big scare), as I had back-up replacements that had never been currupted.All this is just for whatever it is worth. I think it had something to do with problems in the new NTFS file system (which is supposed to be alot better).Bob (Lecanto, Fl)AMD, Athlon XP, 1800+MSI, K7T266 XP ProPC 2100 DDR, 1024 MBXP, Home Edition Elsa GLadiac 920, GF3/64Mb andPNY, Verto nVidia TNT 2-M64/32WD, 100 MB, 7200, Ultra 100Sound Blaster, Audigy MP3+CH Prod, VPP Yoke - Sound CardCH Prod, Pedals - Sound Card

Share this post


Link to post
Share on other sites

Hmmm... I use Windows XP Professional, defrag my hard disk quite frequently with Windows' Disk Defragmenter, and never had problems, so I think it's just a matter of how the machine is set up! I use the NTFS file system.Kitty MercuryCathay Pacific Virtual Pilot (CX252)

Share this post


Link to post
Share on other sites

Thanks for your help Bob!I am going to try Service pack 1 and see if that helps, If not, "re-install city".Thnaks once again,Jeff

Share this post


Link to post
Share on other sites

Hi Kitty,Yes this is most bizzare. It was definitly the defrag that caused my problem. I had been running fine since I bought the machine in July. Had not ran a defrag until yesterday and then stutters galore. The box came set up on NTFS.I am going to try Windows XP service pack 1 and see if that helps. If not, re-install.Jeff

Share this post


Link to post
Share on other sites

After some testing this morning I have discovered that the paging on my hard drive is noticably more active than it was before I defraged, hence the stutters when panning as so forth. I have tried Windows XP SP1 and a re-install of FS2002 to no avail.Dose anyone know how to force the XP OS to use RAM and no paging? I know the system.ini tweak for Win98, that one worked. I have tried the registry tweak "DisablePagingExecutive" but XP still pages. Is there another tweak that goes along with this to make it work? Do I not have enough RAM (512) to allow it to work? I think that if I could get the paging to stop it would clear up my problem.Thanks for any help!Jeff

Share this post


Link to post
Share on other sites

Thanks Bob,I have tried the following:- New sound card drivers- Set DirectX sound to different settings for Hardware acceleration- Win XP SP1- Cacheman (all possible configurations)- Paging file: 1. Let Windows set it 2. Set it to a hard value (768M) 3. Set it to use NO paging file - This was strange because after I set it to "no page file" FS2002 still paged to my hard drive! I had plenty of RAM (197M after FS2002 started).I still have terrible stutters when panning in heavy scenery and the ATC sound is choppy. Hard drive still pages when panning and ATC chatter even though I have NO paging file! The last thing that I know to check is the prefetch folder. It almost seems like the defrag compressed the files and the uncompress takes time when accessing scenery files, sound files ect.. Can't figure out the paging with no paging file.If anyone has any ideas I would be most greatful!

Share this post


Link to post
Share on other sites

Finally solved this problem!The "Prefetch" folder was missing from the "Windows" folder, it was no where to be found on the system. XP uses prefetch for cacheing. Why it was gone is a mystery. All I know is FS2002 was running smoothly, I defragged for the first time on this box, and FS2002 began to stutter in a bad way.I only found this out from a tweak stating the I should clean out my "Prefetch" folder every so often. When I went to look for it (c:WindowsPrefetch) it was gone, did a search of the whole box, no "Prefetch" folder anywhere. The regestry entires were still in place for prefetch parameters and the system ran with no errors, just very badly.Creating a "Prefetch" folder in the correct location did not solve the issue either, I had to re-install XP. After the re-install, the prefetch folder was back and FS2002 was back to working smoothly.Thanks to all for advice and tips!Jeff

Share this post


Link to post
Share on other sites

Jeff,I have the same problem and have been searching for weeks to find a solution. I am now certain that my problems began AFTER I defragged using XP. I will check the "prefetch" file issue when I get home. Assuming that mine is also missing, can I re-install XP without losing my entire FS set up?? I would hate to start from scratch again. Any help would be GREATLY appreciated!Regards,Todd

Share this post


Link to post
Share on other sites

Bob,Thanks for the help! I will give it a try tonight. Hopefully this will stop my hard drive from running perpetually during FS.Thanks,Todd

Share this post


Link to post
Share on other sites

Get PerfectDisk defragger (payware). It does a PHENOMINAL job of truly defragging each file individually as well as system files during boot (system files and NTFS tables which will become very defragged over time, etc.). Very fast (after the first run) and very thorough. I like it a lot better than Norton defragger. Just an idea!Regards,GC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this