Jump to content

Recommended Posts

Hi everyone,There is one last visibility issue that I am hoping to iron out before releasing the new beta. This is the issue where visibility can drop to "0" either in flight or on the ground. In either case, clearing all wx and refreshing AS will reset the condition, but it may appear again. 4 users have reported such problems.Although I have enhanced the code a bit to prevent possible vis dropping, I am still unable to duplicate the error situation as reported (with B142) so that I can confirm that my fixes are working appropriately and that all issues are indeed solved.With B142, I am hoping those who have experienced such problems can help me duplicate. We need to identify a specific weather file (saved .dat), .ini, flight plan, and procedure which can duplicate the problem. If you are able to do this, please drop me an e-mail with such information, and I will attempt to get the same on my end with B142. I can also supply you with a test build to confirm/deny that your original issues have been solved. Thanks!!

Share this post


Link to post
Share on other sites

Hello Damian.I am not sure what you are refering to, but here are my two problems with visibility.#1Metars reporting vis. in meters and below around 2000m will give only 160m or so(reported by WeatherSet2).#2Disable Haze Layer will give same vis. all the way to 100k feet.If it is either of those I can duplicate them easy if I find the correct condition.JT

Share this post


Link to post
Share on other sites

Hi JT,Thanks for that..#1, I believe is solved but cannot confirm as I was never able to duplicate. Please e-mail me @ damianc@hifisim.com I will send you a test build to check.#2, How are you noting the same vis? Via WS2? Note that WS2 will no longer show correct vis or wind as it is now controlled directly by AS2004 via direct FSUIPC vis and wind control. With disable haze layer above 12kagl you will have complete maxed vis. You can change the max via AS2004 options. Try 80 miles. Please also see my last response in the "Darkness and Blindness again" thread.Thanks!

Share this post


Link to post
Share on other sites

Hi again Damian.Updating to b145 did not cure the vis. problem with metars giving less than 1800m. See picture to see what I mean.JTUpdate:Something odd happend while fixing the screenshot and posting. The vis. has now changed to what the metar is reporting. Im guessing it took almost 5 minutes for this to happen.

Share this post


Link to post
Share on other sites

After some more testing I think the change in visibility during my post was a lucky one. I have now been at several locations and waited for over 10 minutes to make sure AS would update weather again.So my problem is still there. I havent found the exact point where the vis. will be 0.1sm(161m), but it's around 1800m for sure.JT

Share this post


Link to post
Share on other sites

Hi JT,Thanks for the report. Sorry this was not fixed properly. I will have another look at it, please e-mail me directly at damianc@hifisim.com and I'll send you a test build when it is ready...

Share this post


Link to post
Share on other sites

Hi again Damian.After some testing it looks like you fixed it 99%.It now works almost correct, but below 400m the vis. will be 161m.I'm guessing AS is converting to statute miles? This would explane why the vis. is not always correct.The rest is nitpicking and I dont think you need to spend more time on this as Im sure you got other issues to resolve.Thanks a lot for your quick response on this matter. I am impressed!JT

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...