Jump to content

Sign in to follow this  
Guest speight

severe frame rate hits during weather update

Recommended Posts

Guest speight

I am getting severe frame rate hits during weather update! I am using a medium/high end system and AS defaults. The fps are dropping from the high thirties to 3 or less. Do any others experience this? Does anyone have a fix?This copied from FAQ:"Does AS2004.5 effect performance?AS2004.5 by itself does not generally cause a noticeable performance hit. Certain unavoidable hits, such as doing actual FS weather writes, are intelligently handled via efficient write processes and update suppression to keep stutters away during critical phases of your flight".//AS2004.5 configuration file B175[General]WindowPosX = 45WindowPosY = 825DefaultWeatherFolder = C:Program FilesMicrosoft GamesFlight Simulator 9ModulesActiveSky2004SuppressionCeiling = 4000SurfaceWindLimit = 10CloudLayerLimit = 5LocalSuppressionRange = 100MinimumVisibility = 0MaximumVisibility = 40IncreasedWake = FalseDisableWindsAloft = FalseForceTstormsWithCB = FalseAutoConvertPlanFiles = TrueDisableVisGraduation = FalseForceDestinationWeatherZone = FalsePreventIcing = TrueOnlineUpdates = TrueExtendedDestinationWindsForce = FalseDisableAllGroundUpdates = FalseGlobalWrites = FalseDepictFS9HazeLayer = TrueExtendTstormLayers = FalseDisableDirectWindControl = FalseVoicePlayback = TrueLocalSuppression = TrueStartupSound = TrueDisableGroundUpdates = FalseUseProxyServer = FalseFogLayerGeneration = TrueUpdateSuppression = TrueOvercastEnhancement = TrueIgnoreFSReadyStatus = FalseFSUIPCWindSmoothing = TrueLimitSurfaceWinds = FalseLimitCloudLayers = TrueAutoGlobalWriteToggle = TrueRainWithTS = TrueDisableUpperLayerGeneration = FalseVisibilitySmoothing = TrueDisableMessages = FalseAutoTimeZoneDetection = TrueUpdateInterval = 10VATSIMData = FalseZuluConversion = 0AloftPredictability = 100WindDriftRate = 0TAFProcessing = FalseEnforceVisibilityLimits = TrueWakeTurb = TrueStartPaused = FalseUseSystemTime = TrueDisableCAVOKClouds = FalseProxyAddress = NONELastPlanFolder = C:Documents and SettingsHowieMy DocumentsFlight Simulator Files

Share this post


Link to post
Share on other sites
Guest speight

Thanks Jim, will give it a go, except....with avirus off, how vulnerable is a system?

Share this post


Link to post
Share on other sites

>Thanks Jim, will give it a go, except....with avirus off, how>vulnerable is a system?It is like asking how safe you are driving without car insurance for 2 hours. Some would never do it, some drive like this for a year or two.Even if you get infected you can catch the virus later, at least this is how my antivirus software works.Michael J.WinXP-Home SP2,AMD64 3500+,Abit AV8,Radeon X800Pro,36GB Raptor,1GB PC3200,Audigy 2


Michael J.

Share this post


Link to post
Share on other sites

Jim,This too has been a problem for me, When AS is d/l'ing,the framerates drop from 15-19 to 2-3, although it is for just a few seconds. I am using FS Autostart to shut everything down....browser, AV, etc. This seems to be more a "pain in the a_s" then a problem. Even cruising at a high flight level in the middle of the desert, when AS d/l's you know it when you see the big hesitation!Rick

Share this post


Link to post
Share on other sites
Guest speight

Jim, I tried it with the antivirus disabled. It helped a bit, but not enough to be worthwhile. I turned the avirus back on and did a full C-scan, I had picked up 4 viruses and 2 spywares in just 10 minutes. I am not turning it off ever again, sorry.The Microsoft real world wx does not interfere, so why does Active Sky? Could it be something to do with the server?

Share this post


Link to post
Share on other sites
Guest DNelson

This is getting a little off-topic (sorry), but many anti-virus programs are not much good at blocking spyware. A good firewall, either hardware or software, is just as important as anti-virus.

Share this post


Link to post
Share on other sites

>I had picked up 4 viruses and 2>spywares in just 10 minutes. I never picked up even a single virus on my XP-SP2 since the installation of the SP2 even with anitivirus off for a prolonged time. Something is fishy ..Michael J.WinXP-Home SP2,AMD64 3500+,Abit AV8,Radeon X800Pro,36GB Raptor,1GB PC3200,Audigy 2


Michael J.

Share this post


Link to post
Share on other sites
Guest speight

I had turned off the firewall at the same time, which I probably shouldn't have done!

Share this post


Link to post
Share on other sites
Guest aca_dia

If all you did was kill ant virus and then go to Fs9 (with nothing but AS download), it is extremely unlikely that you got the viruses you found in those 10 minutes. Viruses normally don

Share this post


Link to post
Share on other sites

Hi All,Enough has been posted about the anit-virus/virus situation so I don't have anything to add about that. If anyone has a specific question, then of course I'll respond!!The task at hand is to solve this performance hit problem that some are having here.Lets try to narrow it down some more: Is the hit during the actual download or while the data is being processed to FS? I know it may be hard to determine, but running FS in a smaller window while watching AS may help. If you do this please have FS as the active window.Hope this helps,JimActiveSky Sales and Supporthttp://www.hifisim.com/images/as2004proudsupporter.jpg

Share this post


Link to post
Share on other sites
Guest speight

It looks very much to me like it happens most during the processing, I will keep checking that.

Share this post


Link to post
Share on other sites

For me, I think it is happening during d/l. It is pretty regular, doing with the time you have set in your setup ( 5 min or 10 min). It happens just for a few seconds. While it is writing station data, the frames go back to what they were at normally.One thing I noticed though ( and maybe it has a bearing on the force destination wx also). When AS writes the station data when you start AS up, it writes the data very quickly. If I am in the western US, it usually takes about 30 seconds to write data. In the eastern US, it could take up to 1 1/2 to 2 minutes. ( I'm assuming because there are a lot more reporting stations. But when AS updates during a flight, the writing takes place very slowly, and might be still writing whan the next update is due. I will also assume that if AS is still busy writing when the update is due, it will skip that update! If this is the case, perhaps that is why the weather doesn't change until after you have landed at your destination! I know maybe this should have started a new thread, but they may be related!Rick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    50%
    $12,595.00 of $25,000.00 Donate Now
×
×
  • Create New...