Sign in to follow this  
veldthui

XEngine using Heaps of CPU Time

Recommended Posts

I have noticed an issue recently that is really slowing my PC down. I run ASX on a remote PC to save my main machine extra CPU time. I have noticed that if FSX is running (even on the menu screen and not actually the flight screen) then ASX is extremely slow and the CPU is running nearly maxed out. This continues even after the weather has finally loaded and things should settle down. Turning off centre on location drops the CPU to nothing but turning it back on quickly results in max usage again.If FSX is not running when loading up and getting the weather and setting the graphics then things work normally with very little CPU usage and takes very little time.http://www.virtualpilots.org/signatures/vpa475.png

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,Hard to say for sure but from the sounds of it, Simconnect client (used by XEngine) is slowing things down. When FSX loaded and simconnect connected, things are slowing. The cause of this may be some networking issues. Might want to very everything is ok here including network cable, windows network configuration, simconnect configuration, etc.Best,

Share this post


Link to post
Share on other sites

>Hi,>>Are you running B1083? Do you have High Priority Processes>on?Sorry for the delay in getting back.B1083? Not sure what you mean by that.Yes High Priority Processes is on. Get the same on or off but with on it slows down the machine as a whole. Today it took about 15 minutes to get the weather. Everything goes fine until I import the flight plane and then things appear to lock up and start to bog down. Today FSX was not running and I got the same. Finally started FSX while it was still grinding away and then after I took off started to get a message that ASX was sending the weather. Went to the other PC and it then asked if I wanted to install the XGraphics and I said yes and it threw up a few errors with that. Had a look at the map and after ages it came up but no weather of it.As for Simconnect while I did have 2 other programs running they were not yet connected to FSX so would not be using SimConnect. Also I have had these programs running with ASX before with no issues.This as I said does not happen all the time so is hard to reproduce but is frustrating when it does. Shutting ASX and restarting it does not seem to help and it will do exactly the same.http://www.virtualpilots.org/signatures/vpa475.png

Share this post


Link to post
Share on other sites

Yep SP1 is installed. Dont have any antivirus programs running on either machine. The remote PC on which ASX runs is an XP machine which does not even have a firewall enabled as it is behind a NAT router and not used for internet at all. The Vista machine on which FSX runs only has the Vista firewalll which I have allowed the Simconnect port I am using (500) but I have tried it disabled and same result.There is nothing wrong with the networking itself because I can still transfer files at full speed across the 100Mb connection at all times.Simconnect is fine as well as I can run another program and it is communicating and keeping up properly.As I said it happened yesterday without FSX even loaded up. When I did another flight 4-6 hours later it was fine again and neither machine had been rebooted or had anything done to it.http://www.virtualpilots.org/signatures/vpa475.png

Share this post


Link to post
Share on other sites

Did a bit more investigation and think it may have something to do with WideFS. I loaded up ASX today and then while it was loading I started WideFS client ready for FSC and then ASX ground to a halt while on the splash screen with the progress bar. I saw this and stopped WideFS client and no change. Killed off XEngine.exe in the task manager and restarted it and it loaded perfectly and after it loaded started up WideFS client. At no point was FSX running on the remote machine during this.http://www.virtualpilots.org/signatures/vpa475.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this