Sign in to follow this  
Guest DaveC3

Trouble with Simconnect Client connection

Recommended Posts

I have been pulling my hair out for the last two days trying to get Simconnect to establish a connection from a remote computer. I have searched the internet and have tried several configurations. I have 2 machines running WinXP Pro. I have de-installed Mcafee on both machines. I have opened the port range on my router.Running FSX Acceleration.I also installed Simconnect.msi on the client. Simconnect runs fine as a local application. FSUIPC and WideFS work great from client.Here is the Simconnect.xml on the server machine.<?xml version="1.0" encoding="Windows-1252"?>SimConnectSimConnect.xmlFalseFalseAutolocal

644096FalseFalseIPv4global
192.168.1.104
6481004096FalseHere is my CFG file on the client machine.[simconnect]Protocol=IPv4Address=192.168.1.104Port=8100MaxReceiveSize=4096DisableNagle=0I ran netstat.exe on the server machine. I can see port 8100 listening. So I think the server machine is OK.When I run netstat.exe on the client machine I can not see any network activity from port 8100. I can see WideFS on port 8002.Anyone have any ideas?ThanksDave

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It appears it is not a simconnect problem after all. I tried a couple examples from the SDK and it talks across the network. My problem seems to be with the VB6 FSCSCalpha.ocx. It runs fine on the server but not across the network.ThanksDave

Share this post


Link to post
Share on other sites

Couple of questions, first the .cfg file does have a SimConnect in square brackets before the lines you listed above (square brackets don't show up in the forums, so just checking that they are in your file :-> ).Second, where do you have the SimConnect.cfg file? There might be an issue with locating the .cfg file from an .OCX file as it might have a different idea of where the "current" directory is than the app does. Try placing the .cfg file in your My Documents folder and see if it works then.

Share this post


Link to post
Share on other sites

TimYes, Simconnect is in brackets in the actual cfg file.I have tried putting the cfg file in MyDocuments also in the same folder as the program. I have also put the program in MyDocuments. I have tried setting a path to the Simconnect.dll. I have also put the Simconnect.dll in the applications folder.I have read that others have had this problem with this VB6 OCX.Thanks for the tipsDave

Share this post


Link to post
Share on other sites

>I have tried setting a path to the>Simconnect.dll. I have also put the Simconnect.dll in the>applications folder.Don't do either of those things. SimConnect.DLL is loaded via the Windows side-by-side library system, and having copies in other places can defeat this and cause mis-matched versioning problems (related to manifests).I doubt if that accounts for your original problems, which I cannot solve for you, but it could create more problems for you, if not now then in the future.RegardsPete

Share this post


Link to post
Share on other sites

PeteThanks for the advice. I was trying everything I could think of to try to solve the problem. I did get it fixed. It was a registry entry that was not set. It was in HKEY_LOCAL_MACHINESOFTWAREFSDTFSCSimconnect0.0. There were two entries I believe thay are Simconnect Versions. The entries were 10.0.60905.0 Reg_DWORD 0X00000001 (1) and10.0.61242.0 REG_DWORD 0X00000000 (0) I changed the dword to (1) and it started working.Thanks again for your help.Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this