Sign in to follow this  
HoratioWondersocks

Anti Aliasing (what does it do)

Recommended Posts

Hello AllI was wondering what AA does.Am i right in saying that it makes the higgly jiggly of the scenery as you fly over it slightly less pronounced? (Thats what i feel it does).There is one thing it definitely does do..it makes FSNav a bugger to use.Cheers Andy

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Its primarily used to make lines appear smooth instead of the jagged saw-tooth look. The higher the setting, the smoother the lines, the more the performance hit. You have to balance that out based on your system specs. Not sure exactly what you're describing. That could be a number of things in FS. If you are talking about a shimmering look, that is caused by the mip setting in FS being too high. Should be on 4.

Share this post


Link to post
Share on other sites

>Its primarily used to make lines appear smooth instead of the>jagged saw-tooth look. The higher the setting, the smoother>the lines, the more the performance hit. You have to balance>that out based on your system specs. Not sure exactly what>you're describing. That could be a number of things in FS. If>you are talking about a shimmering look, that is caused by the>mip setting in FS being too high. Should be on 4.Hello thereWhat I'm talking about is the scenery as you fly over it...It doesn't remain static it moves and jiggles slightly presumably as it is redrawn.Cheers Andy

Share this post


Link to post
Share on other sites

>Hello there>What I'm talking about is the scenery as you fly over it...It>doesn't remain static it moves and jiggles slightly presumably>as it is redrawn.>Cheers AndyThat's texture aliasing, something different. Turn up your anisotropic filtering setting in the video card driver and see if that fixes it...

Share this post


Link to post
Share on other sites

Sorry to jump in halfway through the thread, I have a small question on AA too. If I turn this on using the video card driver I loose the image of the aircraft in the selection screen. Is this usual? Is there anyway I can turn this on without loosing the image of aircraft when selecting flights?Regards

Share this post


Link to post
Share on other sites

>>>Hello there>>What I'm talking about is the scenery as you fly over>it...It>>doesn't remain static it moves and jiggles slightly>presumably>>as it is redrawn.>>Cheers Andy>>That's texture aliasing, something different. Turn up your>anisotropic filtering setting in the video card driver and see>if that fixes it...>Thanks Ryan I havent tried changing the anisotropic filtering yet.I feel a tweaking session coming on.cheers Andy

Share this post


Link to post
Share on other sites

>Sorry to jump in halfway through the thread, I have a small>question on AA too. If I turn this on using the video card>driver I loose the image of the aircraft in the selection>screen. Is this usual? Is there anyway I can turn this on>without loosing the image of aircraft when selecting flights?>>RegardsRobDoes your card have just one setting or is it like mine ie you can select 2x 4x and even 8x AA but i believe on the high setting you can have problems like yours.No plane in a flightsim.... not good.cheers Andy

Share this post


Link to post
Share on other sites

My card allows seperate settings as you have mentioned. Even going from "off" to 2x makes the image disappear in the selection screen.BTW it's the latest NVidia driver thats installedRegards

Share this post


Link to post
Share on other sites

>My card allows seperate settings as you have mentioned. Even>going from "off" to 2x makes the image disappear in the>selection screen.>>BTW it's the latest NVidia driver thats installed>>RegardsRobMy cards Nvidea also (6600 +256mg)i have no problems myself but havent tried the 8x times setting.I didnt realise you ment the selction screen.The only problem i have is with FSNav if i select AA then the map part of FSNav takes ages to draw.Cheers Andy

Share this post


Link to post
Share on other sites

>>Its primarily used to make lines appear smooth instead of>the>>jagged saw-tooth look. The higher the setting, the smoother>>the lines, the more the performance hit. You have to balance>>that out based on your system specs. Not sure exactly what>>you're describing. That could be a number of things in FS. >If>>you are talking about a shimmering look, that is caused by>the>>mip setting in FS being too high. Should be on 4.>>>What I'm talking about is the scenery as you fly over it...It>doesn't remain static it moves and jiggles slightly presumably>as it is redrawn.That form of aliasing happens inside textures and cannot be cured by FSAA. FSAA only works on polygon boundaries (e.g. it can remove the jaggies from the hills on the horizon line, from the aircraft model when using outside view, from your virtual cockpit etc.).The "shimmering" inside textures can be cured by either lowering mipmap quality level (which will also make textures in the distance more blurry, something many people dislike) and by increasing the level of anisotropic filtering. In general, the higher the mip map quality you use is, the more anisotropic filtering you will need to counter the shimmering. Also, the texture quality settings on your video card will affect the quality of the generated mipmaps and therefore can help with the texture flickering.There is no "general rule" how to set all these options as it depends on your video card and driver. The best settings have to be discovered by experimenting. In some cases, it is also some kind of "trade off" between quality and performance. Usually, better image quality means less performance, although a modern video card should be fast enough to handle FS9 with highest possible image quality.

Share this post


Link to post
Share on other sites

Rob, make sure when you open FS9 you are in windowed mode. I had the same problem with the nvidia card. Just go to any airport and switch to windowed mode and then shut down FS9. The next time you open, it will be in windowed mode and you should see the aircraft in the selection screen., Bob

Share this post


Link to post
Share on other sites

Here ya go Rob, once your in FS9 go to the menu bar and under "View" make sure there is NO CHECK MARK next to "Full Screen". Then close FS9. When you start back up it will be in windowed mode. Now if want want to fly in full screen just click "Full Screen" you will see a check mark next to it.Just remember when you close down FS9 you switch it back to windowed mode. Let us know if this works for you! Bob

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this