Sign in to follow this  
mcbellette

Iris Flight Simulation Software

Recommended Posts

Hi allI am writing this post out of sheer frustration at trying and trying and trying to get some kind of response from Iris Flight Simulation Software. I have tried numerous times to join their forum, without success. I get a message saying the first step has been successful and to wait for an e-mail - but it never comes, despite numerous attempts over the previous few weeks.I have also tried numerous times to e-mail them using their support e-mail listed on the website homepage, again without any success whatsoever.I refuse to purchase any products from this site (even though I like the look of the F-15) due to the problems I am having just getting into the forum! There's no way on Earth that I'll give my credit card details if I can't even join the forum, let alone purchase an add-on.So if someone from Iris Flight Simulation Software reads this post, PLEASE reply to me ASAP as I am fast losing patience and will shortly give up all together and never buy a product from this site.Regards,

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi thereYes it can be very frustrating - but are you quite sure the problem is not in your end? I'm thinking about spam filters and such. Are you sure your ISP or a filter in your own PC is not blocking the mail you are waiting for?I can't know if that is the case - but it might be worth checking!BRGDSSven Sorensen, EKCH

Share this post


Link to post
Share on other sites

Nope, I know it's not my computer or ISP because I am receiving and sending other e-mails, etc without problems. Just got an e-mail from Iris (funny that after posting here) saying my account wasn't activated previously but has been now by the administrator. Here's hoping all goes well form here on in.

Share this post


Link to post
Share on other sites

Mat,Don't be too sure about that. I had a similar experience at the beginning of this year. Mails I made could be sent without a problem and some of the mails I was expecting came through.The problem saw the light when I was waiting for a mail of Flight1 to reactivate a key. I never saw the the mail until I checked the unwanted mails in my webmail. Seemed that my provider apllied some new spamrules overnight and guess what...So, if possible, try to register once more and check your webmail (unwanted mail). Chances are that the reply was sent there...After all, some of us think that Iris isn't the most reliable firm in the first place and if some has labelled it as 'Spam' a lot of providers will try to block that mail.I found it to be true for quite a number of softwarevendors.succesLuc BrussemansBelgium

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this