Sign in to follow this  
Guest dan_272

Unexpected, C2D

Recommended Posts

Hey, I just reinstalled FS9 in order to have fun for old times sake (now a student pilot, real life).As soon as i get all done with the setup etc., it loads fine. I can even take off and do a good landing (using slew to be quick to get on final), but always within 3-5 minutes it Crashes to Desktop, no warnings or messages.This is a fresh install, I also updated video Drivers and removed all my addons etc.Any ideas?thanks in advance!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

" . . . reinstalled FS9 in order to have fun for old times sake."I fly FS9 because, IMO, it's the superior simulator.Having said that, the best way to prevent FS9 from C2D is:1.) Do not use the FS9 logbook2.) Install the FS9.1 patchThe latter addresses some scenery-texture issues which can cause C2DP.S. Once FS9 has crashed, the fs9.cfg will -- in all probability -- be corrupted; thus, ensuring that any subsequence use of the program will end (or start) with a C2D. The easiest method (and recommended), is to delete the (supposedly) corrupted fs9.cfg file and allow the program to automatically build a new one the next time it is started. Some settings will have to be reset but it only takes less-than-five-minutes.FS9.CFG is a hidden file and located here: C:Documents and SettingsUsernameApplication DataMicrosoftFS9FS9.CFGHave fun . . .

Share this post


Link to post
Share on other sites

Thanks for that (Yeah, I use FS9 because it so much better than FSX IMO.. well, for now, i'm yet to try FSX with a extremely hardcore PC.I have FSX, I might have to settle for using that in the end.I did what you said and it didn't stop the C2D's.Any Other Ideas?( deleted fs9.cfg and let it rebuild itsself, and didn't select 'use the logbook' when i restarted and messed with some settings, and i already had the patch installed)(I also tried reinstalling FS9 from scratch, so its just the bare simulator atm. I thought it was an addon causing the issue, so that wasted a few hours of my time)(Updated Video Card drivers too)

Share this post


Link to post
Share on other sites

Update:since my computer is one that runs 24/7 i decided to turn it off for 10 mins to see if completely erasing the RAM would help.. (seen in another topic).Now it crashes even faster (about the second i get to the "create a flight" screen).Doesn't even let me fly for a short time (I must say i smashed the wright brothers record in the time it took to crash beforehand).That really didn't help...

Share this post


Link to post
Share on other sites

do you have the "Render to Texture" option checked? If so (or not so), turn it on/off and see what happens. A sudden crash to desktop usually indicates a missing texture. But since you only have FS9.1 installed, then that can't be it. (unless you installed some addon sceneries?).try to above suggestion first.-feng

Share this post


Link to post
Share on other sites

Along with your video drivers, you should update your sound drivers, drivers for any joystick or input device that needs them, and DirectX as well. New drivers with a very old version of DirectX can cause problems.Also, you might try running FSAutoStart or manually kill off unneeded processes before starting the sim.If you haven't installed the FS 9.1 patch, remember that the original FS9 had a seasonal CTD related to winter textures...the 9.1 patch fixed that. You might also try moving your startup situation to another airport. Best is to start up at the default Seattle with the default C172.CheersBob ScottATP IMEL Gulfstream II-III-IV-VSantiago de Chile

Share this post


Link to post
Share on other sites

Ill try updating Drivers... After i restarted FS9(.1) crashes just after the splash screen now.Ill give FSAutoStart if the driver updates don't help.It was working 2 days ago. I might try a system restore if nothing works.

Share this post


Link to post
Share on other sites

I updated FSUIPC to the latest version from the makers website..and driver updates for video/joystick/sound didn't work.I checked for Traffic.dll and TrafficInfo.dll..Trafficinfo.dll wasn't there... so i looked on the FS CD's Modules folder in one of the cabinets and it wasn't even on the FlightSim CD's.I put it in with the SDK however..I'm running a barebone version of FS9.1 FYI.

Share this post


Link to post
Share on other sites

HOLY F'ING S**T!I fixed it, it was none of that.. all that reinstalling etc..I think the thing that fixed it was by killing the SoundMax Control Panel before starting FS9.I must have accidentally run the SoundMax CP just before FS started crashing, time to start installing my addons etc.Thanks alot guys! :)

Share this post


Link to post
Share on other sites

Thanks for letting us in on the good news. A little Christmas present for ya. Your solution makes me harken back to the days of MSDOS 2.1 and clearing TSR (Terminal Stay Resident) programs. Life's sure become complicated with the introduction of balloonware. Merry Christmas.

Share this post


Link to post
Share on other sites

Yep, I'm Extremely Glad!and i've installed all my addons etc now. so its all good!someone should make a list of C2D possible fixes, but to be honest, it could be anything.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this