Archived

This topic is now archived and is closed to further replies.

wulfgar

DX10 preview et crash driver nvidia nvlddmkm.sys

Recommended Posts

Bonjour à tous,Je viens de tester DX10 preview sous FSX avec ma nouvelle bécane mais j' ai des problèmes.J'utilise les drivers Nvidia 169.25 et j' ai de manière aléatoire un crash du driver avec le message suivant:Driver nvlddmkm.sys has stopped responding and has successfully recovered (mouais mon oeil successfully recovered)J' ai essayé les 169.44-> même choseles 174.70 j' ai un écran noir dès le chargement avec reset physique en bout de course.Pas moyen d'avoir fsx en dx10Bref tous ceux sur ce forum qui utilisent dx10 ont-ils le même phénomène?Moi je teste en faisant des circuits autour de KSEA en switchant vers la vue extérieure et intérieure (ça tient max 1h).Avant que le phénomène se produise, je constate que les textures sont floues et qu'il a de plus en plus dur à les charger.Ca sent le memory leak quelque part.Je précise que je n' ai aucun problème avec FSX en DX9.Il fonctionne bien ç'est déjà super.Le mode DX10,franchement je vois pas trop pourquoi MS a décider de l' ajouter.Il apporte rien,il est plein de bugs graphiques,pas de nav lights etc....J' aimerais quand même bien qu'il fonctionne car dans ce mode on peut activer le 'light bloom' sans perte de performance.Si quelqu'un a une idée je suis preneur.CordialementYves LefèvreVista Ultimate SP1 64-bitsGeforce 8800GTX 768Mo4Gb de RAM Intel Core2Duo 3.16Ghz

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Bonjour Yves,J'ai exactement le meme probleme...Tout est OK en Dx9......et dès que je passe en Dx10,j'ai le meme crash avec le meme message....(En français le mien !!!!)J'ai tout essayé,en vain!!!!J'avai placé quelques espoirs dans vista SP1...Vite déçus!!!!Mon Vista ultimate est 32 bitsGeforce 8800GTX 768Mo (Asus)4Gb de RAM Intel Core 2 Duo E6850Asus StrikerSèè( NF6801-SLI ATX Chipset NVidiaAlors,je tourne en DX9 !!!!!!

Share this post


Link to post
Share on other sites

Bonjour Yves et Gilbert,Votre problème peut avoir différentes origines, même si le résultat est signalé comme une erreur de driver graphique.Il s'agit d'une incompatibilité connue entre les drivers Nvidia et soit votre carte mère, soit Vista, soit FSX soit les deux ou les trois réunis!Voici ce que je vous propose, faites le par étape, puis testez pour voir si le problème a disparu.Si ce n'est pas le cas, passez à l'étape suivante après avoir remis les choses comme elles etaient avant l'étape infructueuse.PREMIERE ETAPE1) Allez dans:C:UsersVOTRE NOMAppDataLocalMicrosoftFSXShaders10ShadersHLSLTerrain2) Faites une copie de ce dossier et mettez la bien au chaud qq part.3) Effacez le contenu du dossier TERRAIN qui se recréera tout seul (je dis bien le contenu et non le dossier!)4) Faites pareil pour:C:UsersDavidAppDataLocalMicrosoftFSXShadersTerrain.Testez. Si votre problème persiste, servez vous de votre sauvegarde pour remettre les fichiers dans leurs dossiers respectifs.DEUXIEME ETAPETéléchargez et installez ce patch d'Intel que je laisse à votre disposition qq jours à cette adresse (je ne le trouve pas sur le site d'Intel) puis l'enleverai pour éviter des soucis de copyrighting.http://www.toofiles.com/fr/oip/documents/e...inst_autol.html.S'il ne s'installe pas c'est que votre carte mère n'a pas de chipset Intel, ce qui m'etonnerait beaucoup!! :--)Cette étape n'est pas réversible mais non nuisible, bien au contraire, c'est un "Intel Chipset Device Software installer" qui manque souvent pour rendre les drivers DX10 compatibles.TROISIEME ETAPEVous trouverez en pièces jointes deux dossiers zip.1) Dezippez lez et mettez les au chaud qq part où vous pourrez facilement les retrouver pour plus tard.Ce patch que j'ai crée pour moi fonctionne sans problème et règle les défaillances des drivers Nvidia avec DX10.Ce sont deux fichiers text avec le même nom mais si vous les ouvrez vous verrez que l'un est APPLY et l'autre RESTORE .2) Changez la terminaison ".txt" en ".reg". ils deviennent donc des fichiers REGISTRE, chacun dans un dossier séparé, Apply & Restore.3) Cliquez sur le fichier .reg se trouvant dans le dossier APPLY, acceptez la mise en garde. Le registre de Vista est modifié pour ne plus tenir compte de ce bug graphique.Testez.Si votre problème est règlé, super!Sinon, utilisez le fichier contenu dans RESTORE en cliquant dessus pour revenir à votre etat pré-patch.Il y a beaucoup de chances que l'une de ces 3 étapes règle votre problème.NOTES:S'il s'agissait de la première étape, il vous faudra vider les dossiers "Terrain" A CHAQUE installation de nouveau driver!!Si aucune des 3 étapes ne fonctionne alors recommencez les etapes 1 et 3 mais cette fois sans revenir à l'etat précedent. Ceci voudrait dire que vous avez gagné le gros lot et qu'il fallait patcher Vista, votre CM et FSX ensemble.OK???:--))ATTENTION SVP:J'ai remarqué que certains des "guides" publiés sur ce forum sont copiés, en partie ou en totalité sur d'autres forums. Je n'y vois pas d'inconvénient, bien au contraire, si cela peut aider d'autres simmers. Mais je prie ceux qui le font d'avoir l'amabilité de citer leur source et de mettre un lien vers ce forum. D'avance, merci.David Roch

Share this post


Link to post
Share on other sites

merçi david pour ton aide précieuse.Je teste ça ce soir après le boulot.Je penche plutôt pour une incompatibilité Nvidia, FSX car dans Crysis et Bioshock par exemple.Ils sont tous les deux en DX10 et je n' ai aucun problèmes.De toute manière je suivrai ta manip à la lettre ça ne mange pas de pain.Mon chipset est bien un INTEL.Un X38 en fait.CordialementYves Lefèvre

Share this post


Link to post
Share on other sites

>Bonjour Yves et Gilbert,>>Votre problème peut avoir différentes origines, même si le>résultat est signalé comme une erreur de driver graphique.>Il s'agit d'une incompatibilité connue entre les drivers>Nvidia et soit votre carte mère, soit Vista, soit FSX soit les>deux ou les trois réunis!>Voici ce que je vous propose, faites le par étape, puis testez>pour voir si le problème a disparu.>Si ce n'est pas le cas, passez à l'étape suivante après avoir>remis les choses comme elles etaient avant l'étape>infructueuse.>>PREMIERE ETAPE>1) Allez dans:>C:UsersVOTRE>NOMAppDataLocalMicrosoftFSXShaders10ShadersHLSLTerrain>2) Faites une copie de ce dossier et mettez la bien au chaud>qq part.>3) Effacez le contenu du dossier TERRAIN qui se recréera tout>seul (je dis bien le contenu et non le dossier!)>4) Faites pareil pour:>C:UsersDavidAppDataLocalMicrosoftFSXShadersTerrain.>>Testez. Si votre problème persiste, servez vous de votre>sauvegarde pour remettre les fichiers dans leurs dossiers>respectifs.>>>DEUXIEME ETAPE>Téléchargez et installez ce patch d'Intel que je laisse à>votre disposition qq jours à cette adresse (je ne le trouve>pas sur le site d'Intel) puis l'enleverai pour éviter des>soucis de copyrighting.>http://www.toofiles.com/fr/oip/documents/e...inst_autol.html.>S'il ne s'installe pas c'est que votre carte mère n'a pas de>chipset Intel, ce qui m'etonnerait beaucoup!! :--)>Cette étape n'est pas réversible mais non nuisible, bien au>contraire, c'est un "Intel Chipset Device Software installer">qui manque souvent pour rendre les drivers DX10 compatibles.>>TROISIEME ETAPE>Vous trouverez en pièces jointes deux dossiers zip.>1) Dezippez lez et mettez les au chaud qq part où vous pourrez>facilement les retrouver pour plus tard.>Ce patch que j'ai crée pour moi fonctionne sans problème et>règle les défaillances des drivers Nvidia avec DX10.>Ce sont deux fichiers text avec le même nom mais si vous les>ouvrez vous verrez que l'un est APPLY et l'autre RESTORE .>2) Changez la terminaison ".txt" en ".reg". ils deviennent>donc des fichiers REGISTRE, chacun dans un dossier séparé,>Apply & Restore.>3) Cliquez sur le fichier .reg se trouvant dans le dossier>APPLY, acceptez la mise en garde. Le registre de Vista est>modifié pour ne plus tenir compte de ce bug graphique.>Testez.>Si votre problème est règlé, super!>Sinon, utilisez le fichier contenu dans RESTORE en cliquant>dessus pour revenir à votre etat pré-patch.>>Il y a beaucoup de chances que l'une de ces 3 étapes règle>votre problème.>>NOTES:>S'il s'agissait de la première étape, il vous faudra vider les>dossiers "Terrain" A CHAQUE installation de nouveau driver!!>Si aucune des 3 étapes ne fonctionne alors recommencez les>etapes 1 et 3 mais cette fois sans revenir à l'etat précedent.>Ceci voudrait dire que vous avez gagné le gros lot et qu'il>fallait patcher Vista, votre CM et FSX ensemble.>>OK???>:--))>>>>ATTENTION SVP:>J'ai remarqué que certains des "guides" publiés sur ce forum>sont copiés, en partie ou en totalité sur d'autres forums. Je>n'y vois pas d'inconvénient, bien au contraire, si cela peut>aider d'autres simmers. Mais je prie ceux qui le font d'avoir>l'amabilité de citer leur source et de mettre un lien vers ce>forum. D'avance, merci.>David Roch>>>Voilà malheureusement c'est l' échec.L' étape 2 j' ai pas pu la faire, le chipset X38 n' est pas supporté par ce driver.De toute façon j' ai déjà mis un driver intel pour ce chipset.L' étape 1 ça bloque après +-40 minutes et l' étape 3 ça bloque après 1h08.Il me reste à attendre les nouveaux drivers nvidia et prier.Heureusement que ça fonctionne bien en DX9.Ceux chez qui ça marche, essayez de voler autour de Seattle en densité extrêmement grande.Je fais toujours le même circuit c'est un excellent test de stress et le moins qu'on puisse dire c'est que DX10 chez moi,il ne passe pas le test.Le circuit: décollez de tacoma, dépassez la tour "space needle",dès que vous voyez le stade de l'université de Washington sur la droite,tournez à 90° vers les batiments microsoft puis à nouveau 90° vers l' aéroport de tacoma et on recommence.Si vous réussissez à voler pendant deux heures sur ce circuit sans crash, je serais curieux de connaître vos "settings".Mettez vous en vue extérieure aussi.Ma résolution est 1680*1050*32En ce qui me concerne DX10 c'est terminé sur FSX en tous cas.Il est trop buggé et apporte trop peu pour que j' y consacre toute mon énergie.Encore merçi à david pour son aideYves

Share this post


Link to post
Share on other sites

Bonjour Yves,Nvidia se fichant éperdument de FSX je doute que leurs futurs drivers post-Vista SP1 apportent grand chose autre qu'à Crysis.Et puis ils se consacrent maintenant à leur prochaine gamme de chipsets et apparement n'en ont pas grand chose à carrer des millions de gus qui ont mis plus de 500$ dans leurs série 8xxx.J'ai eu pendant longtemps ce fichu problème avec DX10 c'est pourquoi j'ai écrit ce patch qui fonctionne bien mais à vrai dire je n'ai jamais poussé ma machine sur un circuit aussi ardu que celui que tu proposes. Il risquerait d'abord de me tourner la tête! puis de transformmer mon PC en chauffage d'appoint.Je continue à utiliser DX10, non pas pour les quelques améliorations visuelles mineures, mais parce que chez moi (et là c'est le loto) FS est beaucoup plus fluide qu'en DX9 avec un gain de près de 40% en fps.

Share this post


Link to post
Share on other sites

bonjour David et Yves,DAVID : Deja grand merci de nous accorder autant d'attention.Je pars en voyage jusqu'à mercredi prochain et ne pourrais essayer tes remèdes qu'après.....Chez moi aussi,FsX sous DX10,toune bien plus fluide avec un gros gain de fps....jusqu'au crash !!!!Info:mon chipset carte mère est nVidia (choisi pour une éventuelle extention SLI)YVES : Désolé que tu doive rester Dx9......Je vous tiens au courant dès ma cuisine faite selon les recettes du grand chef David ..........

Share this post


Link to post
Share on other sites

>Bonjour Yves,>Nvidia se fichant éperdument de FSX je doute que leurs futurs>drivers post-Vista SP1 apportent grand chose autre qu'à>Crysis.>Et puis ils se consacrent maintenant à leur prochaine gamme de>chipsets et apparement n'en ont pas grand chose à carrer des>millions de gus qui ont mis plus de 500$ dans leurs série>8xxx.>J'ai eu pendant longtemps ce fichu problème avec DX10 c'est>pourquoi j'ai écrit ce patch qui fonctionne bien mais à vrai>dire je n'ai jamais poussé ma machine sur un circuit aussi>ardu que celui que tu proposes. Il risquerait d'abord de me>tourner la tête! puis de transformmer mon PC en chauffage>d'appoint.>Je continue à utiliser DX10, non pas pour les quelques>améliorations visuelles mineures, mais parce que chez moi (et>là c'est le loto) FS est beaucoup plus fluide qu'en DX9 avec>un gain de près de 40% en fps.>Effectivement,maintenant je connais Seattle comme ma poche.C'est vrai que je lui impose des textures photo-réalistes pendant longtemps.Par contre la température ça va (67°) d' après RivatunerDX10 moi ne me procure aucun gain de fps.Ce serait plutot un drop de 25%.Sauf si je mets le light bloom avec DX10,là je gagne des fps par rapport à DX9 avec light bloom actif.Ca c'est clair.Je vais encore essayer les 174.74 qui sont sortis en Beta hier soir,on verra bien.Cela étant dit,je suis quand même très content des perfs FSX en DX9,donc ne vous en faites pas pour moi.Je suis juste un peu trop perfectionniste parfois.Concernant ton patch David, j' avais trouvé cet article http://www.microsoft.com/whdc/device/displ...dm_timeout.mspxet j'avais déjà modifié cette clé mais je n' avais pas mis toutes les modifs que tu as implémentées.Je garde les tiennes car elle me paraissent effectivement essentielles.Une dernière chose.As-tu fait quelque chose de particulier pour avoir ce boost de perf en DX10?Si tu as un lien ça m'intéresse toujours.Yves

Share this post


Link to post
Share on other sites

Salut Yves,Je n'ai rien fait de plus que ce que j'avais décrit dans le post sur les tweaks de FSX, nHancer, DX etc...Mais en fait je compare DX9 avec bloom et DX10 avec bloom, ce qui peut expliquer la hausse significative de fps :--)Pour ta température, 67° c'est un peu limite pendant plusieurs heures, tu ne penses pas?Il serait plus sain que tu te rapproches des 50° en full charge.Je viens de lire que l'ancien driver 163.75 règlait ton problème sur certaines machines.Tu ne perds rien d'essayer :--)Bon week-end.

Share this post


Link to post
Share on other sites

>Salut Yves,>Je n'ai rien fait de plus que ce que j'avais décrit dans le>post sur les tweaks de FSX, nHancer, DX etc...>Mais en fait je compare DX9 avec bloom et DX10 avec bloom, ce>qui peut expliquer la hausse significative de fps :--)>>Pour ta température, 67° c'est un peu limite pendant plusieurs>heures, tu ne penses pas?>Il serait plus sain que tu te rapproches des 50° en full>charge.>>Je viens de lire que l'ancien driver 163.75 règlait ton>problème sur certaines machines.>Tu ne perds rien d'essayer :--)>>Bon week-end. >J' ai essayé avec rivatuner de monter le Fan à 100%.Le PC fait beaucoup de bruit mais la t° retombe à 57° mais ça change rien.Le driver 174.74.C'est pire encore, les textures aquatiques ne sont pas toutes en DX10 mais bon c'est un driver beta et puis ça prouve peut-etre qu'ils sont en train de faire des changements.(driver 163.75) J' avais lu ça aussi mais je ne sais pas si ce driver fonctionnera bien avec crysis qui lui fonctionne du tonnerre en DX10.Mais je ferai quand même l'essai je pense comme ça je saurai à quoi m' en tenir.A propos une dernière question.Avec la procédure Drive Cleaner Pro, il me dit toujours "cleaning please wait" mais jamais finished même après 30 minutes.Donc je l' ai stoppé.Il a bien effacé des clés dans la registry et puis plus rien.En tous cas t' as raison ça nettoie bien.Parce que là je chipote beaucoup avec les drivers et c'est très facile de mettre le bocson.Yves

Share this post


Link to post
Share on other sites

IL FAUT attendre la fin du nettoyage qui met sur mon PC environ 35 minutes.Tu verras qu'un dernier fichier registre se rajoute à la fin du process. Un message t'annonce "Driver cleaned!"Avec Vista, le nettoyage des drivers doit vraiment être fait parfaitement sinon c'est une série de problèmes.

Share this post


Link to post
Share on other sites

Bonsoir David,Je suis rentré de voyage + tot que prévu.Et je me précipite afin de télécharger tes 2 dossiers .zip (de ta 3ème étape) et la : "The page you requested cannot be displayed.Missing Attachment The attachment you requested is no longer available. It may have been deleted by the forum administrator. If you have any questions, please contact the site administrator. Click here to go back to the previous page."SVP,peux-tu les remettre???Ou sinon Yves ???Merci,et désolé de te faire reperdre du temps.....

Share this post


Link to post
Share on other sites

Bonjour David,Et MERCI,une fois de plus....Because ça MARCHE !!!!!Apres avoir fait tes "étapes 1 et 3" (sans revenir en arrière sur l'étape 1)Mon test : Un vol Nice_Sion sans plantage...Que du bonheur !!!

Share this post


Link to post
Share on other sites