Archived

This topic is now archived and is closed to further replies.

MSW

How About Some Help Here!

Recommended Posts

How about some help for some of us that can't get the newest Tileproxy to work? I realize that this isn't payware and you don't owe us anything but maybe if you could give us suggestions or maybe post some kind of beta hot fix to try, the problem could eventually get solved. There is apparently something that was changed for the worse between Beta 7 and Beta 8 that if found could maybe solve the problem. Or maybe if you would post Beta 7 (minus Google Earth) for download again for those of us that never had it, we could at least use Tileproxy.Tileproxy is too excellent of an application to allow only some people to be able to use it without fixing it.Mike

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Yeah, because demanding something for nothing will always work. If no-one has helped you yet, it is because we don't know how to help you. We need more information. What is your hardware spec? What does your proxyUser.ini file look like? What information is being shown in the Start TileProxy window? Any errors? You have to show that you've at least made an effort, and used all the existing resources before you can ask for some hand-holding.

Share this post


Link to post
Share on other sites
Yeah, because demanding something for nothing will always work. If no-one has helped you yet, it is because we don't know how to help you. We need more information. What is your hardware spec? What does your proxyUser.ini file look like? What information is being shown in the Start TileProxy window? Any errors? You have to show that you've at least made an effort, and used all the existing resources before you can ask for some hand-holding.
Yeah, well, if you would look down about 8 posts you will see "Help, No Joy For Me" where I provided that information, yet no one would respond even after I posted on that one three times asking for help. If the information I provided wasn't enough then someone could have asked in a post to provide more. I also PMed the developer and got no resonse. So I decided to start a new post with a little bit of frustration thrown in to get somebody's attention. So far I have been completely ignored.The proxyuser.ini file is the exact one that the user guide has to down load.So, again, I ask for help.Mike

Share this post


Link to post
Share on other sites

I got TP working real good on my PC. Feel free to try elements from my Proxyuser.ini or the whole thing if you think it might help ... sounds like your asking TP to preload to high of a level to start with? Total guess there, but mine was looking pretty crappy until I figured it out.I have mine set up to only preload 15, but have 17 as the max_level ... might work for ya, http://www.mainecustomdesign.com/tileproxy/ProxyUser.INIscreenshotshttp://www.mainecustomdesign.com/tileproxy/

Share this post


Link to post
Share on other sites

The funny thing is... The only binary file that changed between Beta 7 and 8.0 is libnettile.dll - to disable access to *.google.comBetween beta 8.0 and it's update (8.1?) I just fixed a few minor things in the main program that broke the Color Hack feature.The driver tileproxy.sys hasn't changed a bit. So technically there should be no reason why Beta 7 would have worked and Beta 8 fails.Christian

Share this post


Link to post
Share on other sites
I just fixed a few minor things in the main program that broke the Color Hack feature.
Jeesh am I glad you did that ... my home town area would look like cr*p if it weren't for color hack .... Maybe MSW should do complete uninstall, and verify all files are gone like the libnettile.dll?Then search registry and delete entries for TileProxy and libnettile.dll? Do a scandisk, then defrag, then reinstall TP?

Share this post


Link to post
Share on other sites
Jeesh am I glad you did that ... my home town area would look like cr*p if it weren't for color hack .... Maybe MSW should do complete uninstall, and verify all files are gone like the libnettile.dll?Then search registry and delete entries for TileProxy and libnettile.dll? Do a scandisk, then defrag, then reinstall TP?
Thanks for the help.I have already uninstalled and reinstalled (making sure all files and registry are deleted) several times but with no success.I disabled McAfee anti virus protection, firewall and everything else. I used darrincates proxy user file as shown above. But still the same results.When FSX is loading a flight the Individual Tile Accesses always remains at 0, 0.0 per second. Preloaded is 50,000+, hit 0, miss 0 and messages 193.The elliptical areas fill in but I attribute that to the pre-load. The cache for service 3 has texture tiles so they are being retrieved successfully from the service over the internet.This was at Seattle KSEA and all I see is blurred terrain with random squares of water textures of different types and there is no ocean/bay where it is supposed to be. I saw someone say on an older post that these of the Global Map textures and not the texture tiles from within the cache.My OS is XP Pro with SP3, Does it matter if it is SP3 or SP2?Mike

Share this post


Link to post
Share on other sites

ok, so you can see all the .jpgs starting in the folders in cache.service3 ... does your C:\Program Files\Microsoft Games\TileProxy Photoreal World\0000\SCENERY folders have .BGL and .BGL.on files in them? In FSX under Settings and scenery library, do you see all the new folders at the top of the list? Don't give up, you have ruled out a lot, and maybe this issue can be deduced by keep ruling things out like you have done?

Share this post


Link to post
Share on other sites
ok, so you can see all the .jpgs starting in the folders in cache.service3 ... does your C:\Program Files\Microsoft Games\TileProxy Photoreal World\0000\SCENERY folders have .BGL and .BGL.on files in them? In FSX under Settings and scenery library, do you see all the new folders at the top of the list? Don't give up, you have ruled out a lot, and maybe this issue can be deduced by keep ruling things out like you have done?
My TileProxy Photoreal World is in a separate drive G:\Program Files\Microsoft Games\TileProxy Photoreal World\0000\Scenery and yes the folders have .BGL and .BGL.on in them.And I have changed the address for the cache files in the Proxy user for the services to reflect the address within the G drive.All of the new folders are at the top of the Scenery Library list and are checked. The World_LOD8 is located at the bottom of that list and is checked.Mike

Share this post


Link to post
Share on other sites
Exactly like my problem described here http://forums1.avsim.net/index.php?showtop...p;#entry1537897After trying all suggestions I gave up.
After running TileProxy for a week now, I would gladly Fdisk, reformat and do a clean install of everything if I couldn't get it to work ... heck, I'd buy another computer if I had to just to get TileProxy working ... it really brings FS to a level I've been waiting for since FS first came out ...

Share this post


Link to post
Share on other sites
After running TileProxy for a week now, I would gladly Fdisk, reformat and do a clean install of everything if I couldn't get it to work ... heck, I'd buy another computer if I had to just to get TileProxy working ... it really brings FS to a level I've been waiting for since FS first came out ...
Well, I,m not going to get another computer, but I did do a complete reformat and reinstalled XP Pro with SP2 and FSX with Acceleration. After that I installed Tileproxy with no other addons installed and the same problems exist with the added problem that it would occasionally lock up my computer.I know I'm not the only one with problems getting Tileproxy to work. It appears to me that it needs to be completely reworked so that it is more stable and more universally useable by many different systems.That's it for me until a new reworked version comes out, if ever.Mike

Share this post


Link to post
Share on other sites
I know I'm not the only one with problems getting Tileproxy to work. It appears to me that it needs to be completely reworked so that it is more stable and more universally useable by many different systems.That's it for me until a new reworked version comes out, if ever.
Yes, reworking TP would be an awful lot of work. The whole driver approach is terribly complex - usually hobbyist programmers don't develop kernel mode drivers at all - in particular filesystem related drivers. It's a highly specialized (and highly paid) business.Not sure if a complete rework will ever happen.Christian

Share this post


Link to post
Share on other sites
Yes, reworking TP would be an awful lot of work. The whole driver approach is terribly complex - usually hobbyist programmers don't develop kernel mode drivers at all - in particular filesystem related drivers. It's a highly specialized (and highly paid) business.Not sure if a complete rework will ever happen.Christian
I understand what your're saying. Tileproxy has a lot of potential but for whatever reason it just doesn't like my system. I do appreciate what work has been done on it to date and maybe in the future when I update my system I'll give it another try.Thanks!Mike

Share this post


Link to post
Share on other sites
My TileProxy Photoreal World is in a separate drive G:\Program Files\Microsoft Games\TileProxy Photoreal World\0000\Scenery and yes the folders have .BGL and .BGL.on in them.And I have changed the address for the cache files in the Proxy user for the services to reflect the address within the G drive.All of the new folders are at the top of the Scenery Library list and are checked. The World_LOD8 is located at the bottom of that list and is checked.Mike
If you ask me that's the problem: lots of apps don't like different drives. It's like using embedded sentences with a mentally retarded individual.

Share this post


Link to post
Share on other sites

Hello everyone!First at all, I'll let me to introduce myself. I'm a flightsimmer from Argentina and a grateful user of this wonderful sofware called TileProxy.I was delighted with the very real vision of my dear city from a plane's window.Thank you very, very much Chris for you amazing creation, it brings to flight simulator (FSX in my case) a completely new dimesion of realism.Now I ask for some help with a problem I'm experiencing lately: My FSX freezes for a second or so when using TileProxy. It's a strange behavior because I have a new PC wich is superior to my old one!This was my old PC:CASE: VITSUBA VTB ABSOLUTPOWER SUPPLY: VITSUBA COLOSA COL-55-B-PFC 550 Watts / PFC Active / 120mm Blue NeonMICROPROCESSOR: AMD Athlon 64X2 Dual Core 5200+ 2.61 GHzMOTHERBOARD: Asus M2N4 SLIVIDEO CARD: XFX NVIDIA GeForce 8400 GS Integrated RAMDAC 512 MbRAM: 3 DIMM x 1 Gb KINGSTON DDR2 800 Mhz KVR800D2N5/1G (2 of them assembled in a dual channel array)HARD DISKS: 4 x 500 Gb WESTERN DIGITAL WD5000AAKS-00YGA0 SATA2 (Not chained in RAID array)OPERATING SYSTEM: Microsoft Windows XP SP3VERSION OF FLIGHT SIMULATOR: Microsoft Flight Simulator X SP1And this, is the upgrade I was made to my system:POWER SUPPLY: COOLER MASTER Real Power Pro 650W RS-650-ACAA-A1MICROPROCESSOR: AMD Phenom II X4 940 Black Edition Quad Core 3.01 Ghz.MOTHERBOARD: Asus M3A79-T DeluxeVIDEO CARD: XFX NVIDIA GeForce 9800 GTX+RAM: 3 DIMM x 1 Gb OCZ DDR2 1066 Mhz OCZ2N10662GK (2 of them assembled in a dual channel array)No changes was made in the case, hard disks, operating system flight simulator AND ProxyUser.ini.And here is the ProxyUser.ini I'm using:## Start a line with # to comment it out.# Turn your text editor's Word Wrapping OFF for editing this document.## Read the manual for help with configuration. Do not contact the# author about the configuration for particular services. Thank you.#[TileProxy]# Enable or disable worldwide photographic scenery coverage (Yes/True/On to enable)master_enable=On# Write a logfile to disk. In recommend to only turn this on for debugging purposes.# When using FSX RTM or FS 2004, the logfile will grow VERY fast and affect performance.#logfile="C:\logfile.txt"# If you have concerns about possible copyright violations by caching JPEG and BMP tiles# on your hard drive, this switch is the solution. By enabling diskless mode, Tileproxy# will not store a single tile on your hard drive. Expect higher network usage though.# Note that offline mode will depend on tiles being available in the cache.diskless_mode=Off# Offline Mode - No network access will occur (Yes/True/On to enable)offline_mode=No# Resolution limiter: 17 = 30cm/pixel, 16 = 60cm/pixel, 15 = 1.1m/pixel, 14 = 2.3m/pixel, 13 = 4.75m/pixel# Lower resolutions load faster, but are visually less appealing. The 30cm resolution may only be feasible# if you have at least 2GB of system memory.max_lod=17# The following two settings allow you to tune Tileproxy to not preload specific LOD levels. This can# be used in conjunction with third party scenery products like "FS Altitude" that provides data only# up to a specific resolution. If you place this scenery higher than Tileproxy's world folders in the# scenery library then it will have precedence over Tileproxy for the specific LOD levels that it# contains. You can then instruct Tileproxy to not preload these low resolution LOD circles because# they are not needed anyway.# Lowest LOD ring to automatically preload tiles for. Must not be lower than 8.preload_min_lod=9# Lowest LOD ring to automatically preload tiles for. Must not be higher than 17.preload_max_lod=17# The maximum number of tile contexts that Tileproxy will send to the filter driver. A context# is essentially a very fast buffer for graphics data sitting in kernel memory that delivers# data right into FSX. Each tile context can hold an entire LOD 8...15 tile. Higher values# mean more use of your precious kernel memory though. The maximum number is 512. Lower if# you run out of RAM during flight and the PC starts to use the paging file a lot.max_contexts=512# Generate Water Mask. This brings back shader-rendered water and allows# for the use of planes with floats (Goose, Beaver, etc...). If you turn this# option off, you get the Tileproxy behavior of Beta 5 and earlier versions.water_mask=On# Recommendation: FSX users: Use water_blending=on, water_smoothing=off# to get soft land/water transitions## FS9 users: Use water_blending=off, water_smoothing=on# to get hard land/water transitions which# Tileproxy tries to match pixel-exact against coast-lines## Combining water_smoothing and water_blending is discouraged.# It's slow and gives weird results.# Use blending techniques to create a soft land/water transition with some# transparency effect near the shoreline. Compatible with FSX only.water_blending=On# The distance in meters that you want land/water blending to extend from the# shore line. Larger values require more processing. Large values are now possible,# useful values are up to 2000 meters. Very high values may be detrimental to water# mask resolution. Loading speed however remains mostly unaffected by this setting.blend_distance=500.0# The rate at which terrain is blended into the water color. 1.0 means a linear# blending, values > 1.0 blend faster. Values < 1.0 blend slower. This works# similarly to a Gamma Curve. An exponent of 2 gives a quadratic blend function,# an exponent of 0.5 results in a square root behavior.blend_exponent=1.0# The minimal and maximal transparency of the water. The lower you choose the min value,# the more reflective the deep water will be. The higher the max value is chosen, the less# reflective the water will be directly at the shore line. The reflectiveness transitions# linearly from max to min throughout the distance given by blend_distance from the shore.# Allowed values are between 0 and 1, and alpha_min should be smaller than alpha_max or# things may look weird.# The following alpha_min values will not give you any dithering artifacts on all-water tiles,# so the use of these is recommended. It is multiples of 16/239 (rounded up slighty)# 0.0700, 0.1339, 0.2009, 0.2678, 0.3348, 0.4017, 0.4687# 0.5356, 0.6026, 0.6695, 0.7365, 0.8034, 0.8703, 0.9373alpha_min=0.2678alpha_max=0.7# The water color in hexadecimal RGB notation. Prefix with #. This should be blue# or greenish blue or some shades of brown, depending on your preference.# Values of #000000 are discouraged when using water blending - it will result# in weird behavior at the shorelines.water_rgb=#000D1A# Try to smooth land/water boundaries by trying to match the water mask to the image content.# This is a a somewhat experimental algorithm.water_smoothing=Off# The decision threshold for water/land when water_smoothing is enabled. 0 means everything# will be turned to land, 1 means everything turns to water. Chose some value inbetween.water_threshold=0.33# Maximum number of bytes allocated to BMP graphics tiles in RAM at any time (0 for unlimited)# The value below states 100 MB.cache_bytes_limit=100000000# Maximum number of BMP tiles to cache in RAM at any time (0 for no limit).cache_tiles_limit=100000# The currently active service is configured here. Only ONE active source please.# The other source statements should be commented out.#source=Acme Globe Service#source=Service Example 1source=Service Example 3#source=Service Example 4# The sources you want to be able to switch from the GUI menu.# Separate the list entries with | and enclose in quotes. Make sure the# names specified here are valid services which are defined below.# You may want to rename the services according to your preference,# but make sure you replace all occurences of the strings.menu_sources="Service Example 1|Service Example 2|Service Example 3|Service Example 4"# Experimental API Hooking section. Disable if you see strange crashes and effects.# Currently we only have the DirectX 9 hook. More hooks are planned.enable_hooking=No# The DirectX 9 hook enables the moving map overlay. More features are planned.enable_dx9hook=No# A flag whether to show the moving map overlay initially or not.enable_movingmap=No# Dimensions and overlay colors of the moving map. Positions are percentages of the screen.# Width and Height refer to the full 512x512 pixel texture used for the map. To get a round# map circle, the ratio of width and height should match your screen's aspect ratio (e.g. 4:3)# Radius is given in the map texture's pixels where one pixel represents a LOD 15 tile. A# radius of 0 disables the round stencil and shows the entire 512x512 texture. Color is given# in a hexadecimal ARGB notation. movingmap_alpha=255movingmap_color=#ff000000movingmap_xpos=88movingmap_ypos=15movingmap_width=60movingmap_height=80movingmap_radius=60## Here begin the service specific configurations## This is new when you specify captcha_module## On encountering HTTP 302 redirects the captcha module will send Internet Explorer's cookies# stored for the specified service domain to the web server. It will also display whatever web# page the service redirects you to. This could be a page requiring you to enter a so-called# captcha. After entering the captcha correctly, the resulting session cookie will be stored as# a permanent cookie (expiration 1 day) in your IE Cookies folder and sent to the service on# subsequent requests. You will then be able to use the service as long as you wish, given that# you correctly enter the captcha dialog which may nag you once every 20 minutes or so.# # Explaining the captcha_config arguments:## cookiedomain from captcha_config specifies the domain name for which cookies are stored.# This might be the service name plus a top level domain like ".com"## cookieurl specifies a HTTP url from which an identifying cookie will be retrieved first, if# no existing identifying cookie is found. This may be required sometimes to make the captcha# dialog appear in the first place. This could be the service's front page URL (e.g. a search# engine)[Acme Globe Service]cache_folder=E:\TL Cache\cache.acmenetwork_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://server*.acmeglobe.com|path=/terraintile?pos=%s&v=%v|quad=ABCD|balance=0123|agent=Mozilla/4.0 (compatible; The TileProxy Project)"captcha_module=captchaformcaptcha_config="cookiedomain=acmeglobe.com|cookieurl=http://www.acmeglobe.com"min_level=9max_level=17map_version=1color_hack=Nocolor_level=0bulk_extend=25[service Example 1]cache_folder=E:\TL Cache\cache.service1network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://a*.ortho.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=9max_level=19map_version=244#level_mapping=9,10,11,12,13,14,15,16,17,18,19#level_mapping=9,10,11,12,14,14,15,16,17,18,19 more radius HQ (13->14)level_mapping=9,10,11,14,14,14,15,16,17,18,19 even more radius in HQ (12,13->14)color_hack=Yescolor_level=13bulk_extend=50[service Example 3]cache_folder=E:\TL Cache\cache.service3network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://us.maps3.yimg.com|path=/aerial.maps.yimg.com/img?x=%x&y=%y&z=%z&v=%v&t=a|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=5max_level=19map_version=1.8color_hack=Nocolor_level=0bulk_extend=50[service Example 4]cache_folder=E:\TL Cache\cache.service4network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://mapcache*.ask.com|path=/sat/%Z/%X/%Y?partner=|balance=1234|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=5max_level=19map_version=1color_hack=Yescolor_level=12bulk_extend=50Please, note that my cache folder is in another fisical unit that FSX (E: instead of C:) Both drives are defragmented and my drive (C:) have a new, clean installation of the OS and even the FSX.Well if anyone can help me, I'll sincerely appreciate that.Greetings! And we'll be in touch.

Share this post


Link to post
Share on other sites

Oh, by the way... It's me again :( I forgot to mention an important thing I guess...I'm using a cablemodem Internet connection of 3 Mbps. which was the same in the both cases described above.No modification was made on it.

Share this post


Link to post
Share on other sites

And finally, TileProxy crashes... Here's the output in the DOS window before TileProxy dies:nettile: Transfer #119 received HTTP response 400 (http://us.maps3.yimg.com/aerial.maps.yimg.com/img?x=88501&y=-27055&z=0&v=1.8&t=a)(0) - Done!TileAPI: JPEG decoding problem at level 17 (44245,52008) - 02970000, len=4914!TileAPI: WARNING! Output size of write_extended_bmp looks fishy! (16777290)C:\Archivos de programa\Microsoft Games\Microsoft Flight Simulator X\Tileproxy>pausePresione una tecla para continuar . . . (Press a key to continue) :( Any tips about this? :(

Share this post


Link to post
Share on other sites