Sign in to follow this  
Guest Tim W

Question for Omega Nvidia Driver experts

Recommended Posts

Hello all,I have just installed the latest nvidia_w9x_omega_14345.exe for my GF3 TI-200 from www.omegacorner.com. I extracted the quality and the performance versions to 2 folders and installed the quality version. Then installed DX9.0a. I couldn't get DX9 to install properly (no D3D) under the old 30.82 creative drivers I was using. Anyway all went well except that now I have stuttering during flight. Especially over a high density area/airport. Also frame rates in cockpit drop to less than 15 (20 max set). I never got this with then older drivers. I thought of trying the performance version, Can I just install them over the top of the others using the update driver method and point to the performance folder or do they need to be de-installed?Lastly, When I select properties/settings/advanced and click on the tab for my Geforce 3 TI 200 I get a message "An error occured while windows was working with control panel file C:windowssystemdesk.cpl" And I have to close the panel. Any ideas anyone?Many thanksTim

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I would uninstall the video drivers and re-install the 30.82s to see if all is still well, now that you have DX9 installed..If no problems.. you have a choice: either stay with the 30.82s ("don't fix it if it aint broke") or one more time, install the Omega 43.45s over top of the 30.82s.. this should work just fine. At least on my system, I went straight from the 30.82s to the Omega 43.45s without a hitch.Mind you. I'm still on DX 8.1, but that really should not matter, assuming DX9 is properly installed on your system.. make sure you first run DXdiag and verify that everything is working as intended, including the AGP and acceleration settings.

Share this post


Link to post
Share on other sites

Hey Tim.When you install the omega drivers, go for the performance version.Image quality is nearly as good, and performance is much much better.Try that, and if you can make it run propperly, I dont think you will regret it. Best regards S.Jensen

Share this post


Link to post
Share on other sites

Thanks guys, all is well now thanks to advice from mr Omega himself. He suggested that the old 30.82 drivers were not fully uninstalled and suggested I use a prog called "Driver Cleaner" http://www.driverheaven.net/cleaner/ A very useful little utility which cured the problem.ThanksRegardsTim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this