Archived

This topic is now archived and is closed to further replies.

clum

AI freezing on runway

Recommended Posts

Hi, tried a search for related posts to my problem but cant find anything (probably because "AI" is too short a search parameter for some reason)The problem I'm having is that with radar contact running, everything functions as normal with the AI until I'm approaching the active runway for takeoff. As long as i stay tuned to the ground frequency, all the other traffic will taxi and take off as normal but as soon as i press "1" and start to monitor the tower frequency then the next aircraft ahead of me to enter the runway will freeze in its hold short position.I've tried all sorts to fix this including running ai smooth and running various percentages of traffic. i've rulled out my traffic package as the problem as i've just done a fresh install of fs2004 and the problem persists with the default traffic.any help or suggestions are appreciated as it's getting a bit annoying having to advance the time by one minute every time this happens to cclear the stuck aircraft.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi, tried a search for related posts to my problem but cant find anything (probably because "AI" is too short a search parameter for some reason)The problem I'm having is that with radar contact running, everything functions as normal with the AI until I'm approaching the active runway for takeoff. As long as i stay tuned to the ground frequency, all the other traffic will taxi and take off as normal but as soon as i press "1" and start to monitor the tower frequency then the next aircraft ahead of me to enter the runway will freeze in its hold short position.I've tried all sorts to fix this including running ai smooth and running various percentages of traffic. i've rulled out my traffic package as the problem as i've just done a fresh install of fs2004 and the problem persists with the default traffic.any help or suggestions are appreciated as it's getting a bit annoying having to advance the time by one minute every time this happens to cclear the stuck aircraft.
do you have interact with ai checked on the rc options screen? have you clicked update rc scenery database recently?jd

Share this post


Link to post
Share on other sites
do you have interact with ai checked on the rc options screen? have you clicked update rc scenery database recently?jd
Hi, yes interact with ai is checked and also i have rebuilt the scenery database after every new scenery install.At first i though it may have been a problem with afcads but as i can recreate the issue every time by switching to the tower frequency i can only put it down to a rc problem. very stumped by this one.

Share this post


Link to post
Share on other sites

I'm using RC with FSX Acceleration (Vista 32bit). I have had the exact same issue. I never realized that it was occuring once the frequency change is made. I hand over the radio to the VCP before taxi. Everytime I approach the runway for takeoff the aircraft ahead of me will taxi into position and hold there forever.I disabled "interact with AI" and I allow the default ATC to control AI. No problems. I setup a real plan using Flightsim Commander but I save my MS flightplan as a VFR. That way I can request a departure straight out from the default ATC and they will then give me ground guidance later when I taxi. I also request takeoff permission from default ATC after RC clears me.Because the MS flight is VFR they won't bother me after takeoff. On approach I contact default ATC to request landing and they will issure that no other aircraft enters my pattern or runway. And they provide directions to the gate. So I interact four(4) times with default ATC during an entire flight.Now, I do use "Shoot". Its a freeware voice recognition program the allows me to just speak all my requests and acknowledgements for both RC and MS. The result is NO keyboard usage.So, try turning off "interact with AI" and perhaps some the other tips listed here until RC can be patched.

Share this post


Link to post
Share on other sites
I'm using RC with FSX Acceleration (Vista 32bit). I have had the exact same issue. I never realized that it was occuring once the frequency change is made. I hand over the radio to the VCP before taxi. Everytime I approach the runway for takeoff the aircraft ahead of me will taxi into position and hold there forever.I disabled "interact with AI" and I allow the default ATC to control AI. No problems. I setup a real plan using Flightsim Commander but I save my MS flightplan as a VFR. That way I can request a departure straight out from the default ATC and they will then give me ground guidance later when I taxi. I also request takeoff permission from default ATC after RC clears me.Because the MS flight is VFR they won't bother me after takeoff. On approach I contact default ATC to request landing and they will issure that no other aircraft enters my pattern or runway. And they provide directions to the gate. So I interact four(4) times with default ATC during an entire flight.Now, I do use "Shoot". Its a freeware voice recognition program the allows me to just speak all my requests and acknowledgements for both RC and MS. The result is NO keyboard usage.So, try turning off "interact with AI" and perhaps some the other tips listed here until RC can be patched.
with interact with ai disabled, rc v4.3 will not work. it will do exactly what you are describing. once you enable interact with ai, make a log, instructions pinned at the top of the forum, duplicate the problem, tell me what ai are doing what, and send me the .log.have you done the rc scenery rebuild lately?jd

Share this post


Link to post
Share on other sites
with interact with ai disabled, rc v4.3 will not work. it will do exactly what you are describing. once you enable interact with ai, make a log, instructions pinned at the top of the forum, duplicate the problem, tell me what ai are doing what, and send me the .log.have you done the rc scenery rebuild lately?jd
Sorry have been learning my way around vatsim since i posted this but am still having the issue now im back to RC. Will do a debug tomo and send it off to you. Do you need a whole flight or just up to the point that the problem occurs? One thought is that RC4 was working for my without this issue in vista32 and has only started to appear after i changed to vista64. It seems a likley cause that this could be the problem?

Share this post


Link to post
Share on other sites
Sorry have been learning my way around vatsim since i posted this but am still having the issue now im back to RC. Will do a debug tomo and send it off to you. Do you need a whole flight or just up to the point that the problem occurs? One thought is that RC4 was working for my without this issue in vista32 and has only started to appear after i changed to vista64. It seems a likley cause that this could be the problem?
Update FSUIPC to 3.90 or laterturn on ai chatterTurn off pre-recorded chatterDefine the .flt/.wx path by clicking the .flt/.wx buttonI think you will find everything will work finejd

Share this post


Link to post
Share on other sites

Thanks for the really fast reply! Tried that and you are spot on.....it all works perfectly and I can say for certain now that the problem is caused by having the interact with ai option turned off. to you knowlege is there any way around this as to be honest I hate the sound of the ai voices and much much much prefer to hear the pre recorded chatter? As most people seem to not have this problem and also as I did have it working properly on my last OS then hopefully there's a solution rather than the workaround of sacrificing the pre recorded chatter.Thanks

Share this post


Link to post
Share on other sites
Thanks for the really fast reply! Tried that and you are spot on.....it all works perfectly and I can say for certain now that the problem is caused by having the interact with ai option turned off. to you knowlege is there any way around this as to be honest I hate the sound of the ai voices and much much much prefer to hear the pre recorded chatter? As most people seem to not have this problem and also as I did have it working properly on my last OS then hopefully there's a solution rather than the workaround of sacrificing the pre recorded chatter.Thanks
you can turn the pre-recorded chatter back on.the ai chatter is necessary. without it, the ai is never cleared to takeoff. workaround? not til v5.ori guess there might be a workaround. search the forum, for something called a silent pilot. this is for people who don't want to hear the pilot replying to the rc controllers. john burgess created the wav set i believe. search for his name as well.anyway, it is a pilot set, every wav is like .1 second of silence.find an empy folder for chatter pilots, and copy the silent pilot set into that folder.then disable all the chatter pilots, and enable the silent pilot.i guess that only gets rid of half the problem. rc is still going to talk to the ai, there just won't be a response from them.try it, if that makes a difference.jd

Share this post


Link to post
Share on other sites