Archived

This topic is now archived and is closed to further replies.

RetepB

FSX SP1 ok - FSX Acceleration Not ok

Recommended Posts

Hi All.I'm new to this forum but hope I can find some answers/suggestions to my 'tearing' problem. Running FSX SP1 on my Vista 32bit PC with an Nvidia 8800GTX 768Mb graphics card, I have no problems at all with graphics. (I update to the latest drivers for this card from the Nvidia site as soon as they are released).As soon as I install FSX Acceleration (which includes SP2) the graphics become unstable with quite bad horizontal tearing when panning (I normally use Track IR in the 3D cockpit, but the tearing also shows if I use the joystick hat switch to pan.If I uninstall FSX Acceleration(SP2) and revert back to FSX SP1, all is well again with no graphics tearing problems.I can

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Peter,FSX Acceleration/SP2 changed the way Vsync worked in FSX.If you utilize DX10 Preview you will always have horizontal tearing because Vsync will always be forced off and there is nothing you can do to force it on.However, if you run FSX in DX9 mode you can force Vsync on either in the Nvidia Control Panel or by using nHancer.I recommend that you use nHancer and configure it as per Nick N's guide below:http://www.simforums.com/forums/forum_post...D=156769#156769I also recommend that you read Nick's guide on the overall setup and configuration of FSX which can be found at:http://www.simforums.com/forums/forum_posts.asp?TID=29041

Share this post


Link to post
Share on other sites
Peter,FSX Acceleration/SP2 changed the way Vsync worked in FSX.If you utilize DX10 Preview you will always have horizontal tearing because Vsync will always be forced off and there is nothing you can do to force it on.However, if you run FSX in DX9 mode you can force Vsync on either in the Nvidia Control Panel or by using nHancer.I recommend that you use nHancer and configure it as per Nick N's guide below:http://www.simforums.com/forums/forum_post...D=156769#156769I also recommend that you read Nick's guide on the overall setup and configuration of FSX which can be found at:http://www.simforums.com/forums/forum_posts.asp?TID=29041
Thanks very much 'sargeski' for your reply. Great to know I should be able to solve my tearing problem. Could I just check that when you say "However, if you run FSX in DX9 mode you can force Vsync on either in the Nvidia Control Panel or by using nHancer", you mean using FSX Acceleration in DX9 mode by unchecking the DX10 box, and then using nHancer ?Nick's nHancer guide looks a bit daunting, but if thats the way forward then so be it !! Just a thought, but when I revert back to FSX SP1, which I assume uses DX9, (where I don't get the tearing) why don't I need to use nHancer to force vsync on then ?? Sorry about more questions but I just need to understand fully why SP1 is OK and SP1 + SP2 is not OK.Thanks Peter

Share this post


Link to post
Share on other sites
you mean using FSX Acceleration in DX9 mode by unchecking the DX10 box, and then using nHancer ?Nick's nHancer guide looks a bit daunting, but if thats the way forward then so be it !! Just a thought, but when I revert back to FSX SP1, which I assume uses DX9, (where I don't get the tearing) why don't I need to use nHancer to force vsync on then ?? Sorry about more questions but I just need to understand fully why SP1 is OK and SP1 + SP2 is not OK.Thanks Peter
Peter,Yes uncheck the DX10 preview box (you will ALWAYS get tearing in this mode) and there is nothing you can do to force Vsync on in this mode. If you want the best image quality possible use DX9 mode. SP1 is DX9 mode only. Sp2 can be run in DX10 Preview or DX9 mode.There were changes made between SP1 and SP2 which affected Vsync. FSX had Vsync ON in SP1 and basically it was shut OFF for some unkown reason in SP2 (hence why you need to force it on). You want to be using SP2 as it has many performance enhancements for FSX (you'll just need to force your Vsync on). SP2 is OK. It's just different than SP1.Regards,Bob

Share this post


Link to post
Share on other sites

Thanks Bob, understand now, so I will reinstall FSX Acceleration, uncheck the DX10 box and then set up and configure nHancer as per Nick N's guide.I think Nick's guide also said that nHancer will need to be set up each time you update the graghics card driver. so I should become very conversant with nHancer !! Regards,Peter

Share this post


Link to post
Share on other sites
Peter,Yes uncheck the DX10 preview box (you will ALWAYS get tearing in this mode) and there is nothing you can do to force Vsync on in this mode. If you want the best image quality possible use DX9 mode. SP1 is DX9 mode only. Sp2 can be run in DX10 Preview or DX9 mode.There were changes made between SP1 and SP2 which affected Vsync. FSX had Vsync ON in SP1 and basically it was shut OFF for some unkown reason in SP2 (hence why you need to force it on). You want to be using SP2 as it has many performance enhancements for FSX (you'll just need to force your Vsync on). SP2 is OK. It's just different than SP1.Regards,Bob
Hi Bob,Just to let you know I have at last solved my graphics tearing problem when running FSX Acceleration. As you suggested, I forced Vsync ON using the Nvidia Control Panel and thankfully this did the job. I did try using nHancer first but for reasons I'm still trying to find out, that didn't work. I assume that would have done the same thing.Hopes this helps others with graphic tearing problems using FSX Acceleration.Peter

Share this post


Link to post
Share on other sites