Sign in to follow this  
Dark Moment

CH Rudder USB Brake Problem

Recommended Posts

Despite many fine pieces of advice, I'm still having problems with locked brakes with my CH Products rudder pedals USB. I'm running Win98 SE at 1 GHz and 640 MB SDRAM, GeForce 3 card. I've reversed the toe brake axes and set the sensitivities all the way left as recommended (see attached screenshots), yet the brakes remain locked.Help!http://rg.travelocity.com.edgesuite.net/lo...ologo_35x35.gifAlex ChristoffN562ZBaltimore, MDhttp://forums.avsim.com/user_files/19225.jpghttp://forums.avsim.com/user_files/19226.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The first time I used my pedals they worked fine. Later I decided to calibrate them. From that point on the brakes where locked "on" all the time. My cure was to go back to the control panel, open Game Controllers, and REMOVE the pedales. Then unplug the USB connector and plug it back in and bypassed the calibration. That cured my brake problem.Good LuckJim

Share this post


Link to post
Share on other sites

I agree. Uninstall and resintall usually fixes problems with these tempermental rudder pedals.

Share this post


Link to post
Share on other sites

Alex,I have the same pedals but I'm running Windows XP Pro and have had some issues in the past but not the same as your's. Everything is great here now.I think the advice you've been given to set the sensitivity all the way to the left is wrong. I'm of the belief (could be wrong) that that is like turning them off. I have mine all the way to the right and it works fine. The axes do have to be reversed though.Since taking onboard someone's suggestion in your original thread to install the latest Control Manager software, I've got the brakes working the best they've ever been. Previously I had a small spike around the "brakes off" position of the left pedal which is now gone.One thing to check is that there is no other axis on another controller, your joystick/yoke for example, also assigned to the brakes that might be overiding the pedals. I'm not even sure that's possible but it wouldn't hurt to check.To sum up what I've done:1. Installed Control Manager software.2. Calibrated pedals in Control Panel (despite someone's suggestion not to do this).3. Set both brake axes to reverse in FS2002.4. Set Sensitivity of brake axes to full right and a small amount of Null Zone in FS2002.5. DON'T calibrate the brakes in FSUIPC (which is what I used to do). I find that I lose any proportionality if I do that (ie fully on or fully off, no in between).Hope this is of some help to you.RegardsAdrian

Share this post


Link to post
Share on other sites

>Thank you all for your advice, but Adrian, your meticulous>step-by step proved to be the winner and resolved the braking>problem flawlessly. You're a god, thank you oh-so-much.Glad I could help Alex. I've gained lots of help and ideas from reading this forum so it's good to give something back when I can.RegardsAdrian

Share this post


Link to post
Share on other sites

Just been there, done that, all over again. Identified the problem (for me, at least, running Win XP) as FSUIPC. Once I cleared the brake settings under this module, and set my CH Pedals to default in FS2002, all was well again. Took a while to go through all the flipping options though .... Mark "Dark Moment" Beaumonthttp://www.swiremariners.com/newlogo.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this