Archived

This topic is now archived and is closed to further replies.

Guest tomascubero

Cylcing Views on FS2004 9.1 and Windows 7 x86

Recommended Posts

Hey Guys,I have just installed FS2004 on my system after installing a fresh copy of Windows 7 Ultimate x86 (32-bits). Everything was going smoothly until I got into the cockpit in 2D mode and the panel would not cycle. If I pressed S, you could hear the sound changes depening on what view you had selected but the screen would just stay static on the 2D panel.If I started off with lets say VC view from the beggining, I can cycle all the way up to the 2D and then the view would freeze again on the 2D panel. I've tried most reccomendations and the only one that seems to work is to Disable Desktop Composition under Compability for the FS9.exe but I don't like this because it sets my PC to Windows Basic color scheme while using FS9. Before Windows 7 I had Vista Ultimate SP2 and it gave no trouble like this. I also have the latest Nvidia drivers.The problem must be somehow related to the video drivers for Windows 7 and FS2004, hopefully someone can help me out.Thanks in advance,Tomas.PS: I know there is a Windows 7 dedicated forum but not many people active there and I guess this issue also afected some Vista users when it first came out too.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I've tried most reccomendations and the only one that seems to work is to Disable Desktop Composition under Compability for the FS9.exe but I don't like this because it sets my PC to Windows Basic color scheme while using FS9.
You have to do exactly that, "Disable desktop composition" because the Aero Desktop and FS9 are conflicting. No way around it that I know of and FWIW I had to do the same not only in Windows 7 x64 but also in Vista x64. You do know when you exit FS9 it will automatically return to the Aero desktop setting?Also if you are running FS9 in windowed mode and you can still see the taskbar (which it sounds like you can) if any portion of the FS9 window touches the Start Button your FPS will drop significantly. You need to make the FS9 window smaller or in Windows 7 select the option to Auto Hide the taskbar while running FS9.Todd

Share this post


Link to post
Share on other sites

Hi Gents,Ran into the same problem with a fresh load of Vista 64 (thank you M$ auto update - :( grrrrrrr!). Except, the suggestions have not resolved my view change problems yet. Neither the keyboard or the Saitek X52 believe that the 'S'' key should do anything, yet both work properly in FSX. Ticked 'Disable Visual Themes', 'Disable Disktop Composition' and tried to run as XP - SP2, all to no avail. The only way to change view is to go to menu with the mouse and select the view (PAIN). Any further suggestions would be appreciated. Oh, for info, FS9 on Vista 64 was running great before I had to do the 'forced' all application reload. Without tick marks on any of the above too. Yes, it would tell me that Aero was being caged while FS9 was running, but it ran. All of this started with the auto-download a month ago. Thanks,Al_FR-53

Share this post


Link to post
Share on other sites

Just as hunch, as I don't have Win 7 or Vista, but have you tried 'Shift+S' from the main keyboard keys (and not some USB keyboard, or controler key)? Might work. It will cycle backwards, but what the hey, it's the cycling that counts.Chuck BNapamule

Share this post


Link to post
Share on other sites
have you tried 'Shift+S' from the main keyboard keys Chuck BNapamule
Yes I have Chuck and no it don't work. Like Tomas said earlier, the sound changes but the view does not. UPDATE: Went in and turned off Aero and went back to Vista Basic colors. Now I can use the Shift S and go backwards, but the 'S' key alone still does not work. - - - It worked for awhile, now is back to no function at all 'S' or 'Shift + S'. If it helps, I have also noticed that the GPS will freeze as does the ground textures at times; a problem not previously seen. If you go to views and select cockpit again, or even select cancel, everything resumes like nothing happened. Really makes for an interesting landing if you are on final. In Vista Help, it indicates that Aero may have something to do with the freezing as well. Al_FR153

Share this post


Link to post
Share on other sites

Sounds like there is something else going on then just Windows 7 or Vista. I had this issue with FSX on my Vista desktop. I was using a nVidia 8800GT.But now I'm running on an ATI HD3525 Mobility (think i got the number wrong) and I have no problem with Aero and FS9. I can resize the window on the fly, go maximize to full screen, and even Snap it with no problems. I bet it's a video card driver issue or something related to your GPU and not Windows. What brand of cards are people experiencing this issue with nVidia or ATI?

Share this post


Link to post
Share on other sites