Archived

This topic is now archived and is closed to further replies.

Guest vmthiede

MD-11 (OOM) Out of Memory Fix!

Recommended Posts

PMDG MD-11 is a great plane to fly but unless I was flying over water FSX would run out of memory and CTD within about 90 minutes of departing. Very Frustrating! Updating the video card and deleting the FSX.CFG file and letting it rebuild did not fix anything. Lowering the sliders did not do anything but the following two steps did the trick. I can now fly LAX to RIO (over 10 hours) with no issues.Step #1 (Need to set the 3G switch) Open a command prompt with Administration rights. You find it under "Programs->Accessories->Command prompt" click right and select "run as administrator".Enter "bcdedit /set IncreaseUserVA 3072" (without quotes) in the command windowand press enter. After that reboot your machine.Step #2 (Need to enable FSX.exe to use the 3G switch). There is an easy program to download that does the work for you. Go to:http://www.ntcore.com/4gb_patch.phpDownload the 4gb Patch program on the download link.Run the program. A File Manager window will open. Go to your Microsoft Flight Simulator X Directory and select the FSX.exe file. Press Open and the patch will run and finish with "Executable successfully patched!You're now good to go. Enjoy flying the MD-11 for long hauls around the world. It would have been nice if PMDG simply enabled both the 3G switch and the patch for the FSX.exe during the MD-11 install but I guess that's asking too much

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

PMDG MD-11 is a great plane to fly but unless I was flying over water FSX would run out of memory and CTD within about 90 minutes of departing. Very Frustrating! Updating the video card and deleting the FSX.CFG file and letting it rebuild did not fix anything. Lowering the sliders did not do anything but the following two steps did the trick. I can now fly LAX to RIO (over 10 hours) with no issues.Step #1 (Need to set the 3G switch) Open a command prompt with Administration rights. You find it under "Programs->Accessories->Command prompt" click right and select "run as administrator".Enter "bcdedit /set IncreaseUserVA 3072" (without quotes) in the command windowand press enter. After that reboot your machine.Step #2 (Need to enable FSX.exe to use the 3G switch). There is an easy program to download that does the work for you. Go to:http://www.ntcore.com/4gb_patch.phpDownload the 4gb Patch program on the download link.Run the program. A File Manager window will open. Go to your Microsoft Flight Simulator X Directory and select the FSX.exe file. Press Open and the patch will run and finish with "Executable successfully patched!You're now good to go. Enjoy flying the MD-11 for long hauls around the world. It would have been nice if PMDG simply enabled both the 3G switch and the patch for the FSX.exe during the MD-11 install but I guess that's asking too much
Thanks for this tip,but somehow when I open the Command prompt and type in what you have suggested doing,I end up with error messages.And I don't have the rightclick "run as administrator" option.I fly the MD-11 in FS2004,and agree with you,it is a great plane to fly,and I too get out of memory CTDs when on a long flight despite moving my Page File to another partition and having 3Gb on an XP Pro SP3 dual GPU set-up,albeit at single core.Despite having a more than adequate amount of system RAM,it really frustrates me that Microsoft could not have designed their OS and the simulation software to take advantage of the extra RAM instead of being stuck in the ancient 640k RAM ceiling of the old DOS days!

Share this post


Link to post
Share on other sites
PMDG MD-11 is a great plane to fly but unless I was flying over water FSX would run out of memory and CTD within about 90 minutes of departing. Very Frustrating! Updating the video card and deleting the FSX.CFG file and letting it rebuild did not fix anything. Lowering the sliders did not do anything but the following two steps did the trick. I can now fly LAX to RIO (over 10 hours) with no issues.Step #1 (Need to set the 3G switch) Open a command prompt with Administration rights. You find it under "Programs->Accessories->Command prompt" click right and select "run as administrator".Enter "bcdedit /set IncreaseUserVA 3072" (without quotes) in the command windowand press enter. After that reboot your machine.Step #2 (Need to enable FSX.exe to use the 3G switch). There is an easy program to download that does the work for you. Go to:http://www.ntcore.com/4gb_patch.phpDownload the 4gb Patch program on the download link.Run the program. A File Manager window will open. Go to your Microsoft Flight Simulator X Directory and select the FSX.exe file. Press Open and the patch will run and finish with "Executable successfully patched!You're now good to go. Enjoy flying the MD-11 for long hauls around the world. It would have been nice if PMDG simply enabled both the 3G switch and the patch for the FSX.exe during the MD-11 install but I guess that's asking too much
OOM errors in 32-bit systems and 3GB/Switch is as old as the hills and posted many times in this and many other forums.The bcedit command only applies to W7 or vista users.3072 is the maximum and could cause problems for some. A better option is to use 2560 the real issue is the 32-bit system and I would recommend using a 64-bit system as that is the real fix.FSX with SP2 or Acceleration does not require the ntcore mod. FSX with SP2 or acceleration already has the large address aware flag set. Fs9 users should use the ntcore mod if using the 3GB switch or a 64-bit system.No add-on or manufacturer of any kind of program, could ever make any alteration to the operating system including a 3GB switch. System security would never allow it and even if it did the risk and liability would be too tremendous to even make an attempt at it.

Share this post


Link to post
Share on other sites
Thanks for this tip,but somehow when I open the Command prompt and type in what you have suggested doing,I end up with error messages.And I don't have the rightclick "run as administrator" option.frustrates me that Microsoft could not have designed their OS and the simulation software to take advantage of the extra RAM instead of being stuck in the ancient 640k RAM ceiling of the old DOS days!
They did it's called a 64-bit OS. Despite whatever nonsense you read that told you to put your swap file elsewhere...your swap file should always be on the same drive as your OS for best FS performance.

Share this post


Link to post
Share on other sites

You beat me to it Gary. You shouldn't be moving your swap file. It will only create a new one if that's your goal here, but the same can be achieved by renaming it or deleting it. Anywho, as Gary stated, and others,,, it is due to your 32 bit OS.

Share this post


Link to post
Share on other sites