Sign in to follow this  
Guest byoung

CH Products Yoke and Pedals FS 2004

Recommended Posts

Now that FS 2004 is out, I really want to spend some time tweaking my yoke and pedals so they respond properly.Prior to installing FS 2004, I formatted my hard drive and reloaded XP Pro and FS 2004, and of course the Video Drivers.I am using the native CH drivers in XP. What I would like to do is start with the Beech King Air, get it dialed in and then move on to other aircraft. I still have a lot of slop in the controls. Can someone post their sensitivity settings for the Beech King Air using the USB CH Yoke and Pedals?The first question is:Use Control Manager?? My understanding is, if you don't need to program the buttons, you don't need it. It creates virtual devices, is there any advantage to doing this? Would like to hear some feedback on this.I have only been marginally happy with the way the CH Products USB Yoke and Pedals respond. I really want to spend some time and get this refined as much as possible. Here is my system. I do not have the VIA chipset. Motherboard Intel D845.Processor : P4 2.5 GHZMemory: 768 MBVideo GEF 4 TI 4200 w/ 128MB60 GB Hard Drive Thanks!Barry

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I highly recommend you download the latest CH Control Manager software and use it to calibrate your equipment. That was the only way I was able to get them to work well in FS9.After calibration, I went into the sim and reset all controller defaults. I then had to reassign the propeller and mixture controls, but once that was done it all worked perfectly.KP

Share this post


Link to post
Share on other sites

Thanks Ken,I have to remove the native ones first with their utility first.... I'll give that a shot.Appreciate your help..Barry

Share this post


Link to post
Share on other sites

I went to download the Control Manager from the CH Products site they have a problem on their site...Anyone know another way to get the latest Control Manager?And the CHDelete?Thanks!Barry

Share this post


Link to post
Share on other sites

Thanks,It must have been a temporary problem. Got the files and I am all set!Barry

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this