Sign in to follow this  
Guest CargoMun

Nvdia 45.20 drivers rave for FS2004!

Recommended Posts

Hey everyone just thought i'd pass this info along. I know that not all drivers work the same on everyone's computer but ever since I got FS2004 I've been wrestling with 3d clouds impacting my FPS pretty badly. I've installed these new drivers and turned off anti aliasing and anistropic filtering and reduced my AGP to 1X and Im getting MUCH more fluid FPS in FS even with heavy clouds, I have the 3D clouds now set on the "ultra high" setting and I'm getting very fluid response through the clouds.Just thought I'd pass that along hope it helps someone else, this really is a great sim just gotta tweak it to get it smooth. Those damn clouds are killer!!! The price you pay for beauty lol

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'd have to agree with you, they are very good drivers. Have given me ALOT better FPS with clouds around in FS9 then with the past drivers i used (omega 44.03).They (the clouds) still bang and chop of the sound of the game when flying thru them but cant have everything I guess :)

Share this post


Link to post
Share on other sites

If you are using a Soundblaster PCI card, try entering your computer's BIOS setup and setting the PCI latency to 128.

Share this post


Link to post
Share on other sites

Dave, Can you explain how to do that in a sorta,"BIOS adjustments for dummies" type of way? I am clueless on how to do that.

Share this post


Link to post
Share on other sites

I cant emagine why you would put it on agp 1x.. there is no way in hell that will make more performance for you..

Share this post


Link to post
Share on other sites

Which OS are you using? I use W98 and I got the latest drivers for Win98/Me fron Nvidia. They crashed almost every game except FS2002 and I had to roll back to 43.35.

Share this post


Link to post
Share on other sites

I'm using Windows XP, i think they're only for XP not positivecheck www.guru3d.com

Share this post


Link to post
Share on other sites

I'm using XP as well. I also am running with AGP texture acceleration OFF in directx 9.0b and it seemed to help also.Concerning the sound, I have a crappy onboard motherboard sound (newly updated with VIA drivers) not a seperate PCI soundcard. I have nowhere in my BIOS to adjust the kind of option you mention - only graphics aperture size wich is 128 already.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this