Sign in to follow this  
Guest GamePlayer

Autogen causes abnormally slow frame rates

Recommended Posts

In FS2004 if I fly after a few minutes or slew around when I have autogen at dense then the frame rate becomes too slow. These slow downs happen at any autogen setting but at the dense setting it becomes too slow and I have to keep autogen disabled. Didn't happen in FS2002. Weird thing is that once I get the abnormal slow downs, if I go to the menu and increase the autogen setting from dense to extremely dense the frame rate goes up significantly, for example 13 fps to 27 fps. If I go back to dense the frame rate hits my locked 30 fps whereas it was 13 fps before. So why the abnormal slow downs and the increase in performance if I go to the menu and increase the autogen or decrease the autogen.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm curious too...Try this: FS2004 has a "refresh scenery" option which bypasses the menus. By default, there's no key assigned to it. Go to assignments, and assign a key sequence to it (I use Ctrl/Shift/S). Next time the slowdown, do the key sequence, and see if that alone speeds things up. It just may be your lock is too high, and the sim is struggling to keep up with the Autogen. Also, I only use autogen away from the big cities--given my system, It'd bring it to its knees...-John

Share this post


Link to post
Share on other sites

I believe this is the third person to notice this. I also noticed it in FS2002 btw.

Share this post


Link to post
Share on other sites

Okay, I locked my frame rate at 10 and I still have that slow down problem. Went down to 5.5 fps at extremely dense autogen then I lowered autogen to very dense and got 10 fps then increased the autogen to extremely dense again and got 10 fps.

Share this post


Link to post
Share on other sites

"Looks like Normal in FS2004 is more than Dense in FS2002.Ulisses"Well visually it looks more dense, but I had the autogen maxed in FS2002 and the same in FS9 and I get better performance than FS2002, go figure.Regards, Michaelhttp://mysite.verizon.net/res052cd/mybannercva1.jpgCalVirAir International VAwww.calvirair.comCougar Mountain Helicopters & Aviationwww.cgrmtnhelos.com

Share this post


Link to post
Share on other sites

I think I might have an explanation for this. I was out flying once, and was getting fairly good FPS (around 30). Then, after about 30 or 40 miles, I turned around and flew in the opposite direction. The FPS took a dive, down to around 12 - 14 FPS!! After playing around with it, I have come to this conclusion : certain autogen elements stay visible for much longer than they are supposed to, once you pass by them. I think it is buildings that do it the most - trees seem to disappear like they're supposed to after passing over them.This affect is most noticeable over very flat terrain, and when flying over autogen that has lots of buildings. I found that when doing my 180 turn, I could actually see many many tiny specks way in the distance, which I surmised were autogen buildings still being displayed.That would explain why when you went into the menu to increase autogen percent, FPS actually increased - because it refreshed the scenery and stopped displaying all those autogen elements in the distance.If my theory is correct, it would seem to indicate some kind of bug in FS. Like John said, manually refreshing the scenery would be a way to deal with this.Russel Dirks

Share this post


Link to post
Share on other sites

I tried that command to refresh the scenery and it did refresh the scenery but my frame rate didn't go back up. I had to go to the menu and change the autogen setting for the frame rate to go back up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this