Sign in to follow this  
Guest GPan

ELITE MULTI ENGINE THROTTLE QUANDRANT AND FS9?

Recommended Posts

I cant get it to work does anyone know how and will it work if I get FSUIPC for fs2004 with I know believe is payware, even though the elite drivers are for fs2002 ???

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Greetings Sebastian!Somewhere else, either on AVSIM or on "the other site", somebody posted about this issue. It seems that Elite is not even considering making their hardware compatible with FS2004. In fact they asked that guy, after he emailed them about the issue: "What on earth gave you the idea that we would make our stuff compatible with FS2004?"Although it's a rather unpleasant way of reacting to a question by a paying customer, in a way they have a point: the Elite hardware was/is made and intended to cooperate with the Elite software... it was never made, nor meant, for MSFS anyway. Fair enough... but I for one will VERY certainly wait for GoFlight to come out with their throttle units!Jaap Verduijn.

Share this post


Link to post
Share on other sites

Hello Sebastian,My Elite King Air Power Quadrant has worked with FS2K4 since day one. In fact it even worked before my GoFlight modules as I had to wait for GoFlight to issue their FS2K4 update.Here is what I did: I copied all the EliteFS files and folder from FS2K2 modules folder into FS2K4 modules folder. I think I did not copy the EliteFS.ini file and let Elite build it the first time I used it in FS2K4. Then I added the following lines in my FS9.cfg file (you'll find it in document and settings/"your user folder"/application data/microsoft/fs9:[OLDMODULES]EliteFS.dll=1By now, Elite's TQ is working fine together with my GoFlight console.JAAP,Do you happen to have a clue for the other thread you were mentioning. I might be able to help this guy with my solution.Cheers to both of you.J.J.JJ StruyfBraine-L'AlleudBelgiumhttp://jdtllc.com/images/RCsupporter.jpg

Share this post


Link to post
Share on other sites

THANKS ALLOT FOR THE HELP I WILL TRY THIS TODAY!!!

Share this post


Link to post
Share on other sites

Hi JayJay!Actually I don't even remember if it was here, or on "the other site". I hop from here to there, and from there to here, y'know (grin)!However, that guy has kind of had it with Elite, on account of their ill-mannered and contemptious reactions to his email for help. At least that's what he said - I haven't seen their reactions with my own eyes, so I wouldn't truly know.Be well!Jaap Verduijn.

Share this post


Link to post
Share on other sites

how come when I start fs9 it says i need fsuipcs 29.92 or newer version installed when I have 30.40 installed????

Share this post


Link to post
Share on other sites

Sebastian,Did you add the following to your FS9.cfg file:[OLDMODULES]EliteFS.dll=1It also did happen to me (after a Windows Update session -I'm using Windows XP) that it did not recognize my FSUIPC 3. What I did is to temporarily remove the Elite files, delete the EliteFS.ini file, sart FS2K4, leave FS2K4, reinstall the Elite files in the modules folder and restart FS2K4 which then recognized the Elite Throttle quadrant.Which version of Windows do you use?J.J.JJ StruyfBraine-L'AlleudBelgiumhttp://jdtllc.com/images/RCsupporter.jpg

Share this post


Link to post
Share on other sites

I tried what you said but it dont work , and also I am runing win XP.

Share this post


Link to post
Share on other sites

I received a different response from Elite, their tech support e-mailed me saying that it would be a couple of weeks before an update to make the king air throttle compatible w/ FS2004 is available. In the mean time I have followed the work around in this thread but am getting the same error message regarding the outdated version of fsuipc. However, the throttle is recognized and can be calibrated within the elite configuration menus; it just will not operate the throttle, prop & condition levers in the aircraft, which makes me think it may have something to do with fsuipc. Is there a work around to get it to recognize version 3 of fsuipc?

Share this post


Link to post
Share on other sites

HEY GPAN THAT IS THE SAME EXACT PROBLEM THAT I AM HAVING.

Share this post


Link to post
Share on other sites

Are you using the serial or usb throttle quad? I am using the serial quad (serial driver also)with the Universal Control Interface 5 and fsuipc 3.0.4. Maybe that has something to do with the problem?

Share this post


Link to post
Share on other sites

Can I ask which version of the KA throttle are you using (serial or usb)? Also, I have UCI 5 & the serial throttle, but can not get them to work even after following your work around. I keep getting an error message saying my fsuipc is an old version, even though I upgraded it to version 3.0.4 payware. The throttle is functioning in the elite config menus and can be calibrated, but it does not effect the throttle, prop & condition in the sim.Anyway, I'm glad to hear that you got it working, even if I have to wait a while for the "official" fix from elite! Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this