Sign in to follow this  
Guest

My FS9 Odessy Continues -- Interesting Revelation

Recommended Posts

Any of you reading my posts and answers to posts know that I've had mega problems running FS9 on my PC. I've reduced/eliminated almost every slider and checkbox in an effort to get the sim to run and I still had 1-2 second hesitations every few seconds while on take off. The sim has been unflyable.As an experiment, before I completely remove FS9 and reload it, I tried to set everything to max. Yup, I set all the sliders full right and checked all of the boxes except Render as Texture. I set the frame rate target to 44 fps. I set my FFX MD82 up at Seattle and went for a spin. Know what? The pauses weren't as bad as when I had everyghing minimized. :-hmmm I had realworld weather enabled and there were lots of clouds is Seattle today.The hesitations happened up until I was about 5,000 ft agl and then gradually went away. I've attached a picture to show Seattle out the MadDog's window. Anyone know what would cause Win98 to pause to reload that much that early in the flight? Keep on truckin'..........

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Yep, know where you are coming from. I am playing with drivers and let me tell you there is nothing consistant when changing them around. I am baffled. The other nite after F...in with them I thought I had it beat. I was CYYZ at nite all sliders about 2/3 except for the clouds..I was getting 15- 20 taxing to the dep rwy. I was satisfied because on previous attempts, it was a slide show..1-2 4-5 fps.Now this aft I left Barbados to CYYZ. It was smooth going leaving TBPB an of course al was right on smooth as I reached alt. the clouds were great, you could see the islands in the far distance.Great, I love this sim. But On decent to cyyz at about Buffalo..she started to sttutter.The landing at 33r was a slide show and a total dissappaopintment Grrrrr, and I do not want to waste my money on ram..not yet.My buddy who intalled the latest card..knows nothing about FS9 said the program must have a leak cause on the resource meter ,it was laborin steady and pretty high on the scale, unlike other shootemup games he has loaded. He showed me on the scale where the draw is when loadinfg most gsmes.He said the opening page of fs9 used all resources at one point..he thinks this may not be normal.Said RAM may help..But was not sureAnyway..my 2 cents

Share this post


Link to post
Share on other sites

I seem to be getting the stutters upon rotation. As soon as the ground is out of sight it's run for 2-3 seconds, pause for 2 seconds; run for 3-4 seconds, pause for 3 seconds; run for 2-3 seconds, pause for 2 seconds. This stops at around 3-4,000 ft.If I can get rid of the stutters, this sim can be stunning. See attached .jpg (Seattle departure - Tower view).....I'm thinking that since my GeForce4200Ti isn't DX9 compliant maybe a new GeForce FX 5200 would be a fix......??? Seems like most of the folks having problems have either Ti4200/4600 DX8 cards and/or Win98/ME.....

Share this post


Link to post
Share on other sites

dont think its ya card Steve Im runnin a 2.5 BARTON AND ti4200 128 and it runs ok

Share this post


Link to post
Share on other sites

STeve....I'm running the Ti4200 128mg and have no problems at all. It is really weird the way your machine runs better the more "load" you put on it. A video card not being compliant with DX9 is not a problem. There is something else screwin' ya up...and I wish I could put a finger on it!!!! One thing to take note, when you rotate in the aircraft all the ground scenery is now being drawn at 45 degree angles to your monitor. I have noticed in the past that FS graphics work the best when at 90 degree angles to the scenery and terrain. Graphics tend to labour a bit when in a turn....again the graphics are at a 45 degree angle(or there abouts) to the monitor. This could be compounding your stutters on rotation until you get "out of the graphical intense" range. Does this make sense? More computations for the comp perhaps if it involves any angle except 0, 90, 180, 270?You aren't running a soundblaster by any chance? Do things get better when sound is off? Your computer is wasting it's energy on something.....but what......Harry

Share this post


Link to post
Share on other sites

I had a similar problem but not as bad as yours appears to be. I made a few changes as follows:I have the soundblaster PCI128 card and removed the drivers (using the uninstall utility that came with the driver (located in the Programs folder under dreative.) I reinstalled the drivers.I downloaded the VIA latency patch - it was mentioned here in another tthread a few days ago.I opened Win sys ini and added the following:under VCACHE:MinFileCache=474288MaxFileCache=512000Chunksize=1024Under the 386enh added:PageBuffers=32ConservativeSwapfileUsage=1The above was also suggested in another thread.The combination of these has made a world of difference for my comuter. Asus XP2000512 MB ramABIT KRYA-133 MOBOCreative PCI 128 sound cardSound is now better, less stutter to sim while ATC chatteringHigher slider placement for for all sliders but with reflections off, no water effects, and virtual cockpit quality set to low.Have FPS Max at 20 and runs at 19.8 all the time.Minor hiccup if ATC chatter occurs during a steep angle bank turn.I keep clouds layer to one layer most of the time if I am flying in metro areas.I am now enjoying this sim.Dave

Share this post


Link to post
Share on other sites

Oh, forgot to add, I am running WIN98SE. I have order XP and have an additional 256 mb ram waiting in the box. I don't know if I will upgrade right away, as I am happy with my FS9 performance now. Scared to go thru the gut wrenching upgrade scenario if I don't have to.Dave

Share this post


Link to post
Share on other sites

Harry, I've got a Soundblaster Live 5.1 Card. Wonder if I can disable it and run my tests...... :-hmmm

Share this post


Link to post
Share on other sites

Two notes from tests tonight.1) Disabling my SoundBlaster Live card caused FS9 to exit upon choosing an aircraft in the menu. It just closed evidently because I had no audio. Enabling the onboard AC97 audio would have required me to choose a driver off the set up disk but I chose not to do so. I went back to the SoundBlaster.2) Upon rotation, the freezes have not stopped no matter what settings I use in FS9 or on my nVidia set up. It's still run for 2 seconds, freeze for two, etc, etc. I haven't seen anyone else having this problem. It's really weird. It starts as soon as I rotate and ends at around 3,000 ft..... My PC fan (variable speed) is working really hard during this time indicating the P4 chip is getting hot. Anyone have any other ideas? I've tried everything except removing FS9 and reinstalling it. I think I'll do that tomorrow night. If that doesn't improve things, then it's on with the upgrade to XP.

Share this post


Link to post
Share on other sites

your card is definitely DX9 compatible and so is Windows98 (or rather DX9 is Windows98 compatible :-)). Now, whether the combination is I don't know (could be the Windows98 drivers are not DX9 compatible, in fact they likely are not as they are older drivers written for older cards I think. Windows98 is out of support with both NVidia and Microsoft).Stutters are usually caused by delays loading and/or displaying a lot of textures and objects and as you seem to have them mainly low to the ground I'd look for a reason there. How much RAM does your machine have, and what type of RAM? If you have little or very slow RAM that could well be the reason.

Share this post


Link to post
Share on other sites

I have 512 Mb of DDR333 SDRAM which is supported by my Mother Board. Could be that my Mother Board/RAM combination doesn't like Win98. I'm going to order Win XP Home from newegg.com today and do a full Win XP install and reload everything. I already have a second 512Mb stick of DDR333 to boost me to 1Gb of RAM. That should do it I hope.

Share this post


Link to post
Share on other sites

You know what? I have that problem on turning as well. But, I can start a flight right now, and for maybe an hour it will be fine, and then,stutters. But not always. I was showing a friend the sim the other day and it stuttered like mad. This morning, same flight,nothing! The part that kills me is my system is powerful. I put it together myself and it is maximized for performance. All latest drivers. I'm gonna go out on a limb here. "There is a problem with this game. It may not affect everyone but that may be because the game is compatable with certain system combinations."Win XP Pro sp1(w/framerate fix)P4 3.0 Ghz 800fsbAsusP4C800 DeluxeRadeon 9800 Pro 1281GB twin Corsair ramSamsung 191T 17"Delta 1010 AudioSeagate ATA 120 GB hardriveCH usb YokeGravis Gamepad usb (on center of yoke for ATC)

Share this post


Link to post
Share on other sites

Ouch! :-eek If you're getting the stutters with your system specs and Windows XP Pro something is definitely amiss with the Sim. Right now, however, I could live with the stutters. It's the freezes I'm experiencing on rotation at take off and the freezes I get upon decending to the arrival runway. I think that it's a Win98/RAM issue and by upgrading to XP (Home) I hope the freezes go away. I have a couple of spare 20Gb Hard Drives and maybe I'll install XP on one first and try it before removing all my good stuff from my main 80Gb HD. At least then, I'll know if FS9 will work for me.Question: Can you boot up a brand new HD with the Windows XP full install CD and do a NTFS format and install??? If so, then I'll try that first.

Share this post


Link to post
Share on other sites

I have found that external software is much more likely to cause stutters than FS9 settings. I see many here are using ASUS boards. In that case; exit asus-probe before starting FS9, it causes major stutters. I've also found stutters to appear when framerates go up. That explains why heavier loads and lower framerates seems to improve the experience. If you takeoff, on rotation, there's more sky and less ground to display on your screen, and therefore the framerates go up temporarily. This may be the cause of the stutters. So once more, check your background tasks. Kill asusprobe, extra mouse drivers and distributed computing clients.

Share this post


Link to post
Share on other sites

In Win98Se I close out everything except Systray, Explorer, and Rundll. Nothing else is running. I wonder if Rundll is the culprit, though. When I first began using FS9 I did not have the heavy stutters on take off but then I didn't have Rundll in my .ini start up. After I upgraded my video drivers, it appeared in the start up list and I never took it off before starting up FS9. I'll try that tonight as a last resort, starting FS9 with only Systray and Explorer running......

Share this post


Link to post
Share on other sites

Captain Lewis: Yes, you can do a clean xp-pro install on to a clean hard drive. Make sure your bios is set to look for the cd-rom to boot from. The boot sequence should look something like: 1) Floppy, 2) cd-rom, 3) HD. (2) and (3) can be switched if the HD is not bootable, i.e. no OS on it. Then, have xp do an NTFS format when it asks if it can make a partition for you. Then, right after xp comes up after configuring it, do Windows update for all the 'criticals' BEFORE loading any s/w, including FS9. I would even get xp up to date before loading h/w drivers for video, sound, etc., but that's your call. There's nothing like a clean install of xp-pro to temporarily fix computer glitches!For anyone out there (here) thinking of loading xp-home...fogetaboutit!! Get xp-pro.Good luck,sj

Share this post


Link to post
Share on other sites

fwiw,though i'm running fs2k2 still,i DID have major problems with win98se and that Rundll...i could not fly,it would freeze on loading,and when ctr-alt-deleting i would see rundll inthere...now,i only run systray and itesmart,it works great when flying.ever since i disabled Rundll i haven't had a problem...luckily,i didn't(and don't) have a clue as to what rundll function is ;-)

Share this post


Link to post
Share on other sites

Hello, It's the GPS that is causing this problem for me. I can load a flight and fly as smooth as silk for hours as long as I don't turn on the GPS. As soon as I do-goodbye. Stutters. This is even after it is minimized. If I save the flight, end the flight and then restart without the gps-SMOOTH.:( Might be worth a try to eliminate some culprits to your problem.Todd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this