Sign in to follow this  
Guest jkramer51

Is This A Memory Leak ?

Recommended Posts

I received a warning during FS2004 that my Page File was low and that it was being expanded. I was curious so I brought up the Windows XP Task Manager display to monitor memory and page file usage. What I saw was a continual slow drain of memory and and a coressponding increase in the paging file. It was slow enough to not be an issue on short VFR flights but I left the system unattended during a flight for awhile and thus the error. The memory usage climbed to 374mb (have 512mb installed). I never recall more than 350mb in FS2002.Turning off various options and reducing sliders did not reveal any pattern. It seemed that once the memory drain began it just continued.Others may have this issue but not notice it due to page file allocations, or duration of flights. Dick KLBEamd 1ghz, 512mb, mx400 64kb

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Which area where you flying in and which aircraft did you use?Wolfgang

Share this post


Link to post
Share on other sites

Airport is KLBE 30 miles East of Pittsburgh. Tried both Cessna 172 and Bill Lyons Swift. I have no idea if this occurs in other Windows OSs. Need to re-boot to see if it re-occurs. Just wanted to see if anyone else was having a similar problem...Dick KLBE

Share this post


Link to post
Share on other sites

this has been a problem with a bunhch of people.. I did a flight from calgary to toronto in the default 737I checked my mem useage all the time.. was between 200-250 and stayed there..Its gota be some form of addon thats cauzing a leak.

Share this post


Link to post
Share on other sites

Hi Dick,If you have some Landclass installed, you must remove the empty texture folder from the directory.A Landclass scenery needs only a scenery folder. If an empty texture folder is there, FS9 look for a texture again and again and do not free the memory...I had this problem some weeks ago, I removed the empty texture folder and now it works perfectly for me .

Share this post


Link to post
Share on other sites

My fix was moving the FSGenesis landclass BGL to the scenery folder under the Base folder. No texture folder there. Originally I had it in the common Addon folder.Dick KLBE

Share this post


Link to post
Share on other sites

I have ME and in the default 737 with fsmeteo my resources fell below 20%. I thought it might be fsmeteo, so I restarted and resources were at 80%. Then checked and it went down to 38%. Then restarted fsmeteo and it stayed at 28% the rest of the flight. It would every 15 to 20 mins do this pausing and jerking for 1 to 2 mins. Then be back to normal. The cessna is never a problem.JohnAMD +1900512mgs ramfx 5200 ultra 128 video20 gig, 80 gig hd fs on the 80sb live value soundecs K7S5A MBWin ME

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this