Jump to content

Archived

This topic is now archived and is closed to further replies.

Gaiiden

Need light shed on some AI behavior quirks

Recommended Posts

Some of this may apply to UT2, some to the default ATC AI, some to my AFCAD design. This is just one stop on my path for answers so if I can't find them all here no worries. I'm working on my first custom AFCAD (using ADE) and just finished laying out all the AI paths around the taxiways and runways and to parking. After sitting back and watching traffic flow in and out of the airport (KEWR, if you're wondering - with crosswind runway activated) for about 2 hours, while tuned to Newark Ground, here are some things I noticed.BacktrackingI believe this is simply due to how I connected the taxi paths to the runway paths, but I noticed a couple aircraft swing almost off the runway to turn around and exit via a taxiway they already passed. I've shifted around node connections where I noticed this but was wondering if there could be anything else at play here. Again, I suspect it's largely based upon the aircraft picking the closest node to it once it enters taxi mode from landing, even if that node is behind it.Double ParkingSome arriving aircraft were assigned gates that were already occupied! Two or three occurrences at the high-volume Continental Terminal C I noticed happened and the aircraft simply slid into the parked one. I did not see any of them depart in the time I was watching. Bug in UT2?Double SpawningI didn't see it happen, but all the sudden I noticed two aircraft at the same spot, but not aligned like the previous problem where they parked atop each other. So I guess it spawned there? Neither of them departed in the time I watched. Here's an image. (I just noticed now upon looking closer that the aircraft below the offset double parked is a perfect example of two parked atop each other after the second one taxied in!)No Parking RequestA couple of planes would just taxi straight off the runway and to a gate without calling Ground for parking instructions. This was odd to me since some did - and I can't figure out what the difference is in behavior. Do some aircraft simply arrive with predetermined gate assignments?No Taxi DirectionsFor roughly 1/3 of the aircraft that landed and did ask for taxi instructions to the gate, Ground would say something like "Continental 245, taxi to Gate Charlie87 ." and then the aircraft would disappear off the taxiway. Pay careful attention there to the quote however, because I typed it out exactly as it appears in the ATC Window. Note the space after the gate and before the period which tells you the text containing the taxi instructions is being appended as "" - or NULL. My first guess was my AI paths aren't attached to the parking, but then after one aircraft was given empty taxi instructions to Gate C132, another arriving aircraft was given proper taxi instructions to that same gate. I've double-checked all my paths in ADE and so far haven't spotted a break. I myself asked for both taxi to GA parking and to the gate and no matter where I was on the airport, Ground failed to give me complete taxi instructions. No GA craft that landed were given taxi direction to the GA ramp. It was all just "Cessna 7EchoFoxtrot, taxi to General Aviation parking ."A lot of heavy stacking and wave offsI was surprised to see so many aircraft stacked up - for every 2-3 airplanes that landed one had to abort and go around while a second landed only about 15 seconds behind it. Perhaps I need to work my taxi to runway connections to get aircraft clear of the runway faster? One time an aircraft landed on a runway as another was backtracking to taxi off.On the bright side - departures were perfectDespite all the arrival fiascoes, not a single aircraft had trouble departing the airport. From gate/parking to the runway, they all taxied fine and held short and never took the runway while another plane was landing or taxiing off and all took off without a problem. Which makes all the arrival issues even more bizarre to me tongue.gif Especially the taxi instructions issue when no aircraft had a problem getting from whatever gate/parking they started at to the runway.

Share this post


Link to post
Share on other sites

With regards to the airport taxi instructions, it turns out that FSX's handling of stacked nodes and links is once again to blame :/ Similar to when I discovered that placing two unconnected link nodes directly atop each other would result in FSX drawing a fillet anyways, placing link nodes for two different networks (AI pathing and taxiway lines) too close to each other will create a break in the AI path. That's the only thing I can think of after deleting all my taxi line paths and watching every incoming craft get successful gate instructions, as well as me getting proper GA parking/Fuel taxi instructions no matter where I was on the tarmac.This is too bad, since now I have to draw my AI paths as taxi lines and deal with fillets. In this particular case KEWR does not use fillets at all in real life, so I was hoping to better model the taxiways.In a last-ditch effort I tried assigning the taxi line paths along one route from runway to parking I was testing the proper taxiway designations, hoping that FSX was just jumping to a Blank link (one of the taxi path lines atop the AI path line) but that didn't make a difference either.There's just one thing I still don't get: How come I've never seen the AI balk at giving out takeoff taxi instructions from the gate/parking, but can't seem to use the same network to get planes from the runway to gate/parking??For example, I slewed my plane to the start of Taxiway Z off Runway 11 to the GA parking side of the runway. I radio ground for taxi to parking and they tell me to just "taxi to General Aviation parking ." Now, I've changed the wind so Runway 11 is the active runway. A minute or so later a call comes in from the GA parking area I'm trying to get to from a Cessna requesting taxi to the active. Ground dutifully says "taxi to Runway 11 via taxiways S, Z". Ground just gave out directions to my location! I sat back and watched as the Cessna, and then a Learjet, successfully taxied from parking onto the runway and took off. Having moved aside to let them by, I slewed back to my position on the taxiway and again radioed ground for taxi to parking. Their response: "taxi to General Aviation parking ."And in case you're thinking it has something to do with a break right before the parking spaces, you're wrong. From the same spot, I deleted a number of taxi line links/nodes that curved the line from the straight taxiway around the corner to the runway. Guess what? Proper taxi to parking instructions! So the break appears to be right before the runway, yet planes have no trouble getting there, but do have trouble getting from there.:Confused:If anyone wants to take a gander for themselves, here's the AFCAD. I'm being really stubborn about this, I know. I really wouldn't mind giving up my nice clean taxi lines too much, but I have it half working and would like to see if I can get it the last 50%!!

Share this post


Link to post
Share on other sites

I think you have asked this over ar FS Developer and there is a big thread developing there.

Share this post


Link to post
Share on other sites

I have a few helpful responses over at the UT2 support forums as well

Share this post


Link to post
Share on other sites

×
×
  • Create New...