Archived

This topic is now archived and is closed to further replies.

ZachLW

780i W/ Intel SSD

Recommended Posts

Hello all. I recently purchased an x25-M 80GB SSD for the system drive. It's installed and working properly--almost. I'm hoping someone in the forum stumbles across this with the same configuration as I.Upon running Intel SSD Toolbox, I can't select my SSD. When I do, the drives just refresh and the optimization options are greyed out. I know this is mostly due to the fact I'm on an Nvidia chipset which everyone else has had issues with, but I found a workaround. The workaround being to replace the Nforce IDE controller drivers with Microsoft's own. This has not helped me though... :Thinking: I'm thinking that because Intel Toolbox isn't able to use the drive, Trim isn't working properly. Anyone have any clues?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just a general type of comment: I would start by making sure the SSD has the latest FirmWare installed.Cheers,- jahman.

Share this post


Link to post
Share on other sites

A wild stab in the dark...do you have AHCI set in the bios. This either needed to be set prior to installing the OS otherwise you need Google how to enable per your OS. If you were on W7 and did have AHCI set I would have expected W7 to manage Trim without need for Intel software.If you do not get any clearer information, O&O Defrag version 14 provides trim support; as well an excellent defrag program.

Share this post


Link to post
Share on other sites

Thank you all for the fast replies. I have installed the latest firmware.Unfortunately the Nforce MBs notoriously do not support AHCI. That does not mean Trim is not working... (I'm just not sure if it actually is or not)

Share this post


Link to post
Share on other sites

Check out O&O Defrag. It has trim support implemented and should be able to tell you if it is active or not.

Share this post


Link to post
Share on other sites

AHCI is not needed for trim functionality on the Intel SSDs.What OS are you using? If Win 7, Trim is already built-in.The Intel SSD utility only works with their 32nm second-gen SSDs, because the first-generation 50nm ones do not have Trim capability and can't be made to do so. They have a "G1" in the drive ID...although the only way you should be seeing one of those is if you bought it used or from some cut-rate clearance outfit like TigerDirect.RegardsBob ScottColonel, USAF (ret)ATP IMEL Gulfstream II-III-IV-VColorado Springs, CO

Share this post


Link to post
Share on other sites
AHCI is not needed for trim functionality on the Intel SSDs.What OS are you using? If Win 7, Trim is already built-in.The Intel SSD utility only works with their 32nm second-gen SSDs, because the first-generation 50nm ones do not have Trim capability and can't be made to do so. They have a "G1" in the drive ID...although the only way you should be seeing one of those is if you bought it used or from some cut-rate clearance outfit like TigerDirect.RegardsBob ScottColonel, USAF (ret)ATP IMEL Gulfstream II-III-IV-VColorado Springs, CO
Yeah, like I said in my original reply, I know I don't need AHCI in order to have Trim BUT the Trim command cannot be sent through Nforce drivers (hence me switching to Windows default). It's indeed a G2 and I'm on Win7. As my OP states, I'm mostly bothered as to why Intel SSD Toolbox can't be used on my system. Guess I'll leave things alone until my next build. :rolleyes:

Share this post


Link to post
Share on other sites

If youre on Win 7, just leave it alone and dont worry about it, as many have said already, 7 has inbuilt TRIM support. It's doing its job silently in the background.

Share this post


Link to post
Share on other sites
If youre on Win 7, just leave it alone and dont worry about it, as many have said already, 7 has inbuilt TRIM support. It's doing its job silently in the background.
Thanks Alex. Too bad there's no way to check if it's actually receiving the command. :Nerd: Also I had to manually enable Trim with the "fsutil behavior set disabledeletenotify 0" command line as when I queried it was disabled. (Just a note for those reading this post in the future looking for answers)

Share this post


Link to post
Share on other sites