Jump to content

Archived

This topic is now archived and is closed to further replies.

Adrian West

Problem configuring Saitek Pro Flight TQ with FSUIPC

Recommended Posts

I have just bought a Saitek Pro Flight Throttle Quadrant to go along with my CH Products Yoke and Pedals. Based on many online recommendations I have decided to assign axes and calibrate all 3 controllers through FSUIPC. I have managed to sort out my yoke and pedals, but I am having a few issues with the TQ. If it's of any use to anybody, I have FSUIPC 3.98 registered version for FS9. I have successfully configured the throttle, such that the axis runs from 0% to 100%, and I have also assigned button command "Throttle Decr" for the reverse thrust, and have "Control to repeat while held" checked and "Throttle cut" for when the button is released. This seems to work fine. However I cannot get the same success with the other two levers:1. The prop lever. The range of movement across the axis is correct from 0% to 100% in line with the markings on the TQ. I need to assign a button command for feathering the props. The only command in the list that seems to apply is "Prop Pitch Decr". Again I have the repeat box checked, and I have "Prop Pitch Lo" selected for when the button is released. But this won't work. When I try to feather the props I can hear the engine pitch change, but the lever will not go back into the feathered range. Then when I return the lever to 0% the lever on the FS aircraft goes straight to 100%. If I then move my TQ prop lever forward out of 0%, the corresponding FS lever drops back quickly to 0% and then moves forward. What commands should I be choosing to get the feathering to work, and how do I stop the FS lever shooting up to 100% incorrectly?2. The mixture/condition lever. The range of movement across this axis is completely wrong. When I have my TQ mixture lever at 0% the equivalent FS lever is at 50%. 100% on the TQ lever however does correspond correctly to 100% in FS. The values on this axis in FSUIPC run from -16384 to 16383. This corresponds to the same figures for the prop lever, but interestingly the figures for the throttle run from 0 to 16383. This leads me to wonder which values should be correct and whether they should be the same for all 3 axes? In other words, should my prop and mixture levers also run from 0 to 16383? Or on the other hand should my throttle run from -16384?? Very confusing.... I need to be able to have my mixture at 0% when the TQ lever is at 0%. How can I fix this? As regards the button command for fuel cut off I have selected "Mixture Decr", checked the repeat box and selected "Mixture Lean" for when the button is released. The FS lever moves correctly to fuel cut off, but when I advance the TQ lever back to 0% the FS lever stays at cut off.I would be very grateful if somebody coulod give me some advice on these problems. Thanks.

Share this post


Link to post
Share on other sites

hi,Read thishttp://www.tropicairvirtual.com/company/misc/utility/tutorial/fsuipc-guide-v1.pdfIt is valid for the saitek stuff. Don't install the saitek drivers, they are useless.I have the same hardware as you except that I have 3 quadrands (1 for, gear, flaps, spoiler, 2 for throttles, pitch, mixture) and it works fine. It seems to me that you have 2 levers for the same function. Sometimes the FSX control panel is confusing and you think that you have disabled a lever and it is not the case.

Share this post


Link to post
Share on other sites

×
×
  • Create New...