Jump to content

Archived

This topic is now archived and is closed to further replies.

gfusc

maps.geoportal.gov.pl

Recommended Posts

Hey simmers! maps.geoportal.gov.pl - it is map service with high quality aerial maps of Poland. Im trying to get it working with TP. Everything seems to be OK, TP console windows shows no errors, LOD eggs fill up with star symbols but eventually terrain in my FS2004 get black. I know there is a problem with correct syntax, coordinates section needs to be accurate. This is an example of correct geoportal's address:

http://ars.geoportal.gov.pl/ARS/getTile.aspx?service=ORTOFOTO&cs=EPSG2180&fileIDX=L6X4727Y7243.jpg&DateStamp=20080901

And this is what i get back from TP window:

http://ars.geoportal.gov.pl/ARS/getTile.aspx?service=ORTO_SAT&cs=EPSG2180&fileIDX=L6X432Y-1483.jpg&DateStamp=20080901

Looks like geoportal uses mathematical coordinates system (as it covers the Poland only) instead of lat and long.... Am I correct? Can we do something with that? The service section in .ini file:

[service Example 4]cache_folder=F:\FS.TProxy\Cache\cache.service4network_module=libnettilemodule_config="conn=5|rate=0.25|verbose=1|server=http://ars.geoportal.gov.pl|path=/ARS/getTile.aspx?service=ORTOFOTO&cs=EPSG2180&fileIDX=L%ZX%XY%Y.jpg&DateStamp=%v|balance=1234|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=9max_level=15#level_mapping=9,10,11,12,13,14,15map_version=20080901color_hack=Nocolor_level=12bulk_extend=50

Thank you in advance

Share this post


Link to post
Share on other sites

The numbering of the tiles looks more like a LOD13 dan a 6. But the picture is of a much higher LOD.http://ars.geoportal.gov.pl/ARS/getTile.aspx?service=ORTOFOTO&cs=EPSG2180&fileIDX=L1X99Y84.jpg&DateStamp=20080901 is the first picture. I think that this is a local gridsystem.

Share this post


Link to post
Share on other sites

×
×
  • Create New...