Archived

This topic is now archived and is closed to further replies.

Victor Postica

ILS problem in FS9

Recommended Posts

I am having problems when turning on the ILS before landing. Just as I'm cleared to land, I turn on the NAV button, the aircraft turns and lines up with the runway, but it doesnt descent anymore, I have to do it either on the ALT with the AP, either manually. It used to descent to the runway before, than in the last 100 meters I turn off the AP and land it manually.Can anyone help me with the issue ?Thank You

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Victor, Welcome aboard !!! I don't think the plane will ever decend in "NAV" mode... I don't know what plane you are flying but your autopilot should have an "APP" for "Approach" mode...Regards,Scott

Share this post


Link to post
Share on other sites

Hi Victor,there are many questions open. So i try to split them up and try to answer.Why do you push NAV Button?? ----> For ILS Landing you have to push the APP(roach) Button.[your words]Just as I'm cleared to land? why so late?? You have to activate it when you enter the Glidestrope in a 30degrees Angel about 12-15nm away from threshold, at this point you have to have the altitude which is shown in the ILS Chart.So my tip for you take some Information for an ILS Approach and in your plane. So your effort will be there and you will have fun.God luck Arvid

Share this post


Link to post
Share on other sites

Thx for the reply, I use all kinds of planes, Airbus and Boeing mostly, I just remember how I watched these youtube videos on how to land with ILS, most of them dont require to push the Approach mode. Should you press the NAV along with the APP ?Arvid : Yes, sorry about that, I usually put in the airport frequency in the NAV1 and I press the NAV before the ATC gives me clearence to land.I'ts just that before I got my PC fixed it used to work on every airplane and I didnt had any problems :( they were all decending after just pressing the NAV button, I was just decending the aircraft only the lowest ATC would command me.

Share this post


Link to post
Share on other sites

NAV will only follow the localiser beam. Once established you should be below the glide slope. Then you can select APP and the a/c will capture it.Of course you can select APP at first but it's proper practice to select NAV first.vololiberista

Share this post


Link to post
Share on other sites

Hi Victor, Again - to the best of my knowlegde - "NAV" is only for lateral navigation - it will never do anything in the vertical... In fact ion some airliners it's actually labeled "LNAV"... "NAV" will align you to the localizer - however - as you mentioned you would blow through your glideslope... I think "APP" should do it on the simple airliners... If you are runinng some of the complicated airliners with an FMC - that may or may not be different... GA planes are my forte - maybe I am missing something... Are you sure you are intercepting the glideslope properly ??? Good luck...Regards,Scott

Share this post


Link to post
Share on other sites

I have followed your sugestions on turning on the NAV first and than I pushed the APP button and it Worked :) Thank you VERY much guys, now my landings are smooth again haha

Share this post


Link to post
Share on other sites