Jump to content

Archived

This topic is now archived and is closed to further replies.

VS0

After landing CTD, gutted

Recommended Posts

For the last week or so I have been flying around in the PMDG J41 doing reasonably long flights (1.5-3) hours. I land roll off the runway and begin my taxi back to the gate. I exit RC4 through the on screen pop up in fsx and all is ok. About 10-15 seconds later "FSX has stopped working" the message does not state the specific nature of the problem so I am not sure where to look for help. I have not tried with other aircraft but have completed a successful flight with the PMDG bae two days ago. Whether I fly in an ORBX area or not the error still happens. I have not tried a flight without exiting RC4 after landing but I am trying now and will post back my results. Anybody got any ideas?My specs are below and I am running Windows 7 64. My fsx is Sp2 with Acceleration and I have tried the UiAutomation fix a couple of days ago and the first flight after that everything was ok but the second flight (and all other flights since then) the CTD has happened.Any help would be very much appreciated.ThanksRich

Share this post


Link to post
Share on other sites
Guest jahman

Post the CTD info so we can take a look.Cheers,- jahman.

Share this post


Link to post
Share on other sites

How exactly do I do that? Sorry I haven't had a CTD in years, I've been lucky up until now.I did just try a flight without exiting Radar Contact 4 at the end and all was ok so I will do another test later today.ThanksRich

Share this post


Link to post
Share on other sites

After experiencing the crash again I looked at the details and it gave me this:Problem signature: Problem Event Name: APPCRASH Application Name: fsx.exe Application Version: 10.0.61637.0 Application Timestamp: 46fadb14 Fault Module Name: ntdll.dll Fault Module Version: 6.1.7601.17514 Fault Module Timestamp: 4ce7ba58 Exception Code: c0000005 Exception Offset: 0002e02e OS Version: 6.1.7601.2.1.0.768.3 Locale ID: 2057 Additional Information 1: e8ad Additional Information 2: e8adce1c2b9e7be834b4063ac3c53863 Additional Information 3: e8ad Additional Information 4: e8adce1c2b9e7be834b4063ac3c53863Read our privacy statement online: http://go.microsoft....88&clcid=0x0409If the online privacy statement is not available, please read our privacy statement offline: C:Windowssystem32en-USerofflps.txtI know now the problem is ntdll.dll but there doesn't seem to be too much info on this. I have noticed my paging file size was 3 times less than the recommended so I have increased this in hope it fixes my issue. Today's flight was using the same aircraft in the same ORBX addon area but today it crashed whereas with yesterdays flight it did not. Only difference was today I flew to Armidale and yesterday it was Brisbane. Nothing seems to be directly triggering it. (crash today was in the air for the first time, 5 minutes from landing)Rich

Share this post


Link to post
Share on other sites
Guest jahman

Unfortunately this is one of the CTDs where the crash analysis yields little info besides the fact that FSX "APPCRASHed". NTDLL.dll is not the cuplrit as NTDLL.dll is simply tyhe NT (Win XP/Vista/7) kernel.Next step is to activate Windows Update and make sure all your MSVC and .NET runtimes are up to date (this is a general type recommendation). Also make sure your sound card driver is up to date as they have been know to cause CTDs (check with Asus). <-- A quick test you can do is to disable the soundcard and try your flight without it, using your MBs built-in sound capabilities.Cheers,- jahman.

Share this post


Link to post
Share on other sites

Just downloaded new sound drivers, ran the windows update (and installed updates) and increased my page file size to just over the recommended. 2 minutes after take-off the program crashed with the same error details. Could anything I have done made things worse? Also how would I go about disabling the sound card?I appreciate the help.Rich

Share this post


Link to post
Share on other sites
Guest firehawk44
Just downloaded new sound drivers, ran the windows update (and installed updates) and increased my page file size to just over the recommended. 2 minutes after take-off the program crashed with the same error details. Could anything I have done made things worse? Also how would I go about disabling the sound card?I appreciate the help.Rich
I have seen issues with FSX working properly if one sets their own page file size. Change your virtual memory setting to "System Managed Size" and see if that fixes the issue. You can disable your sound card temporarily by going into the Device Manager, clicking on the sound card, selecting properties, and select disable. Best regards,Jim

Share this post


Link to post
Share on other sites
I have seen issues with FSX working properly if one sets their own page file size. Change your virtual memory setting to "System Managed Size" and see if that fixes the issue. You can disable your sound card temporarily by going into the Device Manager, clicking on the sound card, selecting properties, and select disable.Best regards,Jim
Ok got the card disabled and have chosen the "system managed size". On my old rig I used to choose the page file size myself and never ran into problems but hey I have a new OS now and a new rig so maybe things are different. I won't have a chance to do another flight until tomorrow but I'll post back then with my results. Thanks for the help guys I really do appreciate it.Rich

Share this post


Link to post
Share on other sites

Just tried a test flight and all was ok until I got to cruise and changed to windowed mode. the aircraft then became invisible in windowed mode whilst in full screen I got weird looking grpahics problems. I did let the sim build a new fsx cfg flight for this flight where previously I have been using a cfg that has been tweaked using the tweaker at the venetubo website. I have now tweaked the cfg using the tool and will attempt another flight soon to see if some of the tweaks are helping prevent graphics errors which i suspect they might be (Highmemfix?)I have posted a shot of the full screen view and also my temperatures.Rich

Share this post


Link to post
Share on other sites
Guest firehawk44
I have now tweaked the cfg using the tool and will attempt another flight soon to see if some of the tweaks are helping prevent graphics errors which i suspect they might be (Highmemfix?)I have posted a shot of the full screen view and also my temperatures.Rich
The highmemfix=1 will resolve ghosting or disappearing aircraft. Are those temps from AFTER a FSX flight? The left-hand photo shows major issues with rendering graphics. The only known solution is moving sliders to the left until it goes away.Best regards,Jim

Share this post


Link to post
Share on other sites

Hi guys, I decided to use the cfg tweaker again (which added the highmemfix) to see if it would help my graphics issues. Like I said in my previous post I also disabled the sound card and allowed windows to decided the page file size. Completed a test flight using the same ORBX scenery and PMDG aircraft as before (albeit to different airports) but everthing ran perfectly. Hopefully thisz is my problem solved but I will complete a few more flights in the coming days to see if the issue really is resolved. But for the time being I would like to say a massive thank you for the help you've given me with this issue.ThanksRich

Share this post


Link to post
Share on other sites

Just letting everyone know who helped me out here that I have now been flying for a week after I tried the suggestions mentioned above and all is going well. I haven't had any crashes and FSX is looking fantastic.I really do appreciate all the help.ThanksRich

Share this post


Link to post
Share on other sites

×
×
  • Create New...