Jump to content

Archived

This topic is now archived and is closed to further replies.

jturie

CH Pedals Brakes Always On

Recommended Posts

I have flown 4 or 5 flights with the NGX 800 with no issues. All of a sudden my CH Pedals are not working right. ONce I hit the brakes, they always stay on. The only way to remove the brake indicator is to hit the parking brake, which works poorly when one is taxiing. Also, I no longer can taxi straight. I get on the taxi centerline, get off the pedals, and the plane starts swerving to the right.This has happened to my pedals before. I returned them to CH and they supposedly fixed them, but I suspect that they just gave me a new set of pedals. Now this has happened again, and I'm convinced that it is a software/driver issue.I googled this, and there seems to be a bunch of supposedly successful fixed, but none work for me. It's not limited to the PMDG NGX--all of my planes experience this. I've tried calibrating in CH Control Manager, tried messing with the settings in FSX, but no joy.Note that I recently installed REX2 and EZ-DOK.Another funny thing.....the period keyboard key no longer applies the brakes, nor do the Num * and Num - keys.Anybody have any ideas? Do you think that biting the bullet and buying full FSUIPC would help?


Jack Urie

Share this post


Link to post

Well did you turn down the sensitivity of the pedal brakes? Did that with mine and it worked like a charm.


Steven Penninck

Share this post


Link to post

Actually, I ended up solving the problem via a post I find on the CH Hangar forum. There's a free utility called Clear Calibrate on the Logitech WingManTeam website that goes through the registry and removes any controller calibration entries. Evidently this problem can occur if both FSX and the CH calibration tool are used--they cause conflicting entries. Ran the tool, blew out about 10 regentries, and all is well. Didn't even screw up my EZ-DOK assignments.


Jack Urie

Share this post


Link to post

I regulated the problem by reversing the axes of braking in the parametres of Fsx

Share this post


Link to post
I regulated the problem by reversing the axes of braking in the parametres of Fsx
That was one of the many fixes mentioned in the various forums (fora?). Didn't work for me, nor did turning up the sensitivity all the way. That utility cleared it right up. I only use the CH Yoke and Pedals, yet this utility found 12 joystick calibration entries in my registry! I just did a complete flight in the NGX last night and my pedals worked like a charm, and all of my EZ-DOK yoke settings were untouched.

Jack Urie

Share this post


Link to post
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    42%
    $10,670.00 of $25,000.00 Donate Now
×
×
  • Create New...