Jump to content

Archived

This topic is now archived and is closed to further replies.

denver69

Assigning other than mouse weel for rapid MCP changes

Recommended Posts

Untill I get track IR, I do not know if I will yet. I like to use my mouse weel for zooming with EZCA and this is a conflict for rapid changes of MCP and Baro settings knobs. Instead of sitting there for a long time trying to set coarse or heading on the MCP is there anyway to use an alternate means of making this go faster. I miss the longer it takes the faster it goes effect. Although this has it's drawbacks as well.

 

Thanks

Share this post


Link to post
Share on other sites

I'd like to know a way to do this as well. I'm mainly interested in speeding up the baro minimums knob.

Share this post


Link to post
Share on other sites

The only way I found was to get an actual MCP. I got the one from CPFlight. I strongly recommend it if you have the $.

Share this post


Link to post
Share on other sites

Or just use key strokes mapped with FSUIPC

Share this post


Link to post
Share on other sites

I use a Logitech Cordless Optical Trackman mouse ( trackball style about $40 on Ebay ) and set it next to the number pad on the keyboard. In FSX controls I set Mouse-View Direction (0n) to the + on the number pad. This way I can always keep my hand on the mouse and toggle between changing the view, zooming in or out and operating switches ect by just reaching over with my thumb and hitting the + key ( a very large key and hard to miss). I never need to move my hand or the mouse. Not perfect by any means but after after a short time it becomes second nature. I don't have EZCA but I would think you could set it up the same way.

Share this post


Link to post
Share on other sites

The only way I found was to get an actual MCP. I got the one from CPFlight. I strongly recommend it if you have the $.

 

Chris,

 

I have the MCP-EL and matching EFIS-EL. Love it.

 

BUT, there is something not right with the MINS and BARO setting knob functions on the EFIS. Instead of the values changing smoothly in the sim, like all the other functions on the EFIS & MCP, they change inconsistently and with short "jerks", and even sometimes start to change in the opposite direction, from that expected given the direction you are turning the knob. In other words, I may be turning the knob clockwise, and the value decrements!

 

It is as if the EFIS control panel is by error sending alternately a Rotate RIGHT (increase value) and occasionally a Rotate LEFT (decrease value) command, while I am only turning the knob to the clockwise, to the right. Of course, it should then ONLY be sending a Rotate RIGHT (increase value) command.

 

Do you see this behavior? This is with the latest driver. I thought it might be a driver fault, but I am now wondering if this is a hardware flaw in my unit?

 

Really appreciate if you could let me know if you see this??!!

 

* Orest

Share this post


Link to post
Share on other sites

Chris,

 

I have the MCP-EL and matching EFIS-EL. Love it.

 

BUT, there is something not right with the MINS and BARO setting knob functions on the EFIS. Instead of the values changing smoothly in the sim, like all the other functions on the EFIS & MCP, they change inconsistently and with short "jerks", and even sometimes start to change in the opposite direction, from that expected given the direction you are turning the knob. In other words, I may be turning the knob clockwise, and the value decrements!

 

It is as if the EFIS control panel is by error sending alternately a Rotate RIGHT (increase value) and occasionally a Rotate LEFT (decrease value) command, while I am only turning the knob to the clockwise, to the right. Of course, it should then ONLY be sending a Rotate RIGHT (increase value) command.

 

Do you see this behavior? This is with the latest driver. I thought it might be a driver fault, but I am now wondering if this is a hardware flaw in my unit?

 

Really appreciate if you could let me know if you see this??!!

 

* Orest

 

 

HI Orest,

 

So far I have no problems what so ever with the equipment. My EFIS is working as it should. I have the older RS232 version. I think your problem could be related with the SDK (reverse action) or the actual port you are using. My best advice would be to contact CPFlight support (the guy is awsome!). Maybe he would be able to help you out a bit more. Once I got my port issue resolved, everything fell into place.

 

Chris

Share this post


Link to post
Share on other sites

×
×
  • Create New...