Jump to content

Archived

This topic is now archived and is closed to further replies.

ric243

Saitek throttles. Ack!

Recommended Posts

Hi all,

 

I see this is a problem with quite a few users. Anyone got any solutions yet?

I just cannot get my Saitek throttles to calibrate! When my Saitek throttles are at 100% (control panel value of 65280), the throttles in the airplane are at 77%. When my throttles are at 25% which is value 15104 on the control panel, the throttles in the airplane are at 0%. I have tried typing in the values I want in the control panel, and then I click 'Apply' but nothing happens. I then reload the aircraft, close the control panel but there has been no changes.

Just how am I supposed to properly calibrate my Saitek Throttles?

Many thanks.

Richard

 

Share this post


Link to post
Share on other sites

Hi Richard

try it his way it worked for me.

Move Saitek left engine throttle to where it says 25 on the Saitek throttle.copy the numbers from the Power Lever Left position input box into the IDLE box.Apply and reload aircraft.

Then move the Saitek left Engine throttle to where it says 75 on the Saitek throttle.copy the numbers from the Power Lever Left position input box into the DETENTE box.

APPLY and reload aircraft.

now move Saitek throttle lever all the way up and copy those numbers into the Max box.

Now all the way down to the small detente at the bottom of the Saitek throttle and copy those numbers into the DISC box.Dont go past the detente on the Saitek throttle.

Apply and reload aircraft.

Repeat this for the Right Saitek throttle lever.

Apply and reload aircraft.

Once you get into the swing of it ,it's easy and worked for me.

 

  steve

Share this post


Link to post
Share on other sites

Thanks Steve,

 

regretfully this did not work for me :( What values are you putting in to the 'reverse' box?

 

At the moment 100% on the Saitek throttles takes it to the detent, and 50% takes it to flight idle. This really is very annoying, but hopefully the majestic guys will be on the case!

 

Cheers,

 

Richard

Share this post


Link to post
Share on other sites

I'm having the exact same problem as the op, Everytime I try to input values its as if it dowsn't matter.

Share this post


Link to post
Share on other sites

Found my problem. You have to have throttles in fsuipc set as axis throttle 1 and axis throttle 2, I just used the throttle setting before. After I changed them the method above set them correctly. Thanks for the help.

Share this post


Link to post
Share on other sites

hi

I set reverse in Fsuipc.

It sees the area under the detentes on your Saitek throttles as a button.

So in the buttons section of Fsuipc.Move your left engine lever down below the detente and select Fscontrol.then scroll down until you see Throttle 1 decr and select that and put a tick in Repeat while held.

same for throttle 2.

Once in FSX when you push your two levers below the detentes it will now give you reverse thrust on both engines'

 

richard

you dont pull the Saitek throttles back  Past the 25 position...that is the IDLE position.

it's different from any other Aircraft ive had.

 

   steve

Share this post


Link to post
Share on other sites

×
×
  • Create New...