Archived

This topic is now archived and is closed to further replies.

thecanarian

Struggling with Networking ASE

Recommended Posts

Hi,

I've worked through the detailed instructions in the ASE documentation but the networked  ASE (on client PC) doesn't seem to be talking to my  FSX (server PC). Checking through the outputs from the loading screen when ASE is fired up, the server folder locations are correctly identified (or do I need to write the full path instead of the P2P network path) and simconnect states it is initiated. I have all my "User" files in a separate partition H: on the server PC, and configured such that Win 7 will default to this. I'm also using Bullguard but am pretty sure I've punched a hole in the firewall, similarly with the Win 7 firewall. I can access and change (read/write) files on the server PC from the client PC. I'm now wondering if I've made errors in the simconnect.ini/cfg files. I have little or no experience with .xml files so does anybody have real life copies that I can plagiarise? With ip addresses removed of course.

 

Thanks.

 

Peter

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Peter,

 

Have you run the AI Traffic.exe on the client to establish if simconnect is functional? If it is not functional then:

 

Use static IP's on both server and client.

 

The configuration files should reference the server IP address:

 

SimConnect.cfg

 

[simConnect]
Protocol=IPv4
Address=192.168.1.102 ( SET YOUR SERVER ADDRESS )
Port=500
MaxReceiveSize=4096
DisableNagle=0
 
 
SimConnect.xml
 
<?xml version="1.0" encoding="Windows-1252"?>
 
<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>192.168.1.102</Address>  ( SET YOUR SERVER ADDRESS )
    <MaxClients>64</MaxClients>
    <Port>500</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>Auto</Protocol>
    <Scope>local</Scope>
  </SimConnect.Comm>
</SimBase.Document>

 

Share this post


Link to post
Share on other sites

Thanks for the info. I did need to modify the two files a bit, but it still leaves the simconnect.ini file I have as a suspect now. I've re-started and it still isn't talking to my FSX. The three paths I have are :

FSX Path Value=\\PETER-PC\Microsoft Games\Microsoft Flight Simulator X\

FSX My AppData Path Value=\\PETER-PC\Users2\Peter\AppData\Roaming\Microsoft\FSX\

FSX My Docs Path Value=\\PETER-PC\Users2\Peter\Documents\Flight Simulator X Files\

 

Once ASE has been fully activated on the client should the Start FSX button still be greyed out or its normal blue?

 

Thanks again for help so far

Peter

Share this post


Link to post
Share on other sites

What was the result of the AI Traffic.exe test Peter, its listed in the manual how to go about it.

Share this post


Link to post
Share on other sites

Hi, I ran AI Traffic.exe in the folder on my server  from my "client" PC. It replied:

 

Connected to Flight Simulator!

Received:2

 

So I guess that simconnect is loaded correctly, though it doesn't actually state in the documentation if you're supposed to copy the AI Traffic.exe file directly onto the client PC. 

Share this post


Link to post
Share on other sites

Hi,

 

The Start FSX button should be grey.

 

What happens if you start FS, manually select a weather theme and then start AS? Does the theme get changed to User Defined?

Share this post


Link to post
Share on other sites

Hi,

I've just completed a flight (into Montreal) and I started with ASE running on my server PC. I then fired up the ASE on the client and when I refreshed the AI from the client it refreshed FSX on the server. So I shut down the server ASE and finished the flight with ASE running on the client machine. So we've made a lot of progress but ASE doesn't seem to tell you that all is OK and working when you start up ... or am I missing something?

 

Thanks for your help so far.

 

Peter

Share this post


Link to post
Share on other sites

FS Mode FSX changes from Red to Green when connection established.

 

You'll see entries like this on the Main screen:

 

17:19 - FSX connection established!
17:19 - Clear FS weather sent to queue...
17:19 - Clearing Wx for FSX
17:19 - ASE initial weather depiction complete!
17:19 - Re-enforcing initial depiction...
17:19 - Beginning constant DWC depiction updates...

Share this post


Link to post
Share on other sites

Peter,

 

AS should not be installed on the server(FSX) computer.

 

1. Start AS on the client. Let it download and process the weather data.

 

2. Start FSX.

 

3. You should get messages in AS like Mr. Cooke posted above.

Share this post


Link to post
Share on other sites

Hi,

I only had it both PCs temporarily so I could still have an operable system if it all went fubar. I've now taken a few flights, it is performing well, so I've just uninstalled ASE from my server PC.

 

Thanks for all your help

Share this post


Link to post
Share on other sites