Archived

This topic is now archived and is closed to further replies.

Guest

Missing Alphas and MipMaps

Recommended Posts

After reading through the Avsim FSX guide I decided to check out the Alpha Channels and MipMaps in FSX. However, I am rather (or completely) lost when it comes to how to fix this... I know I should use ConvImX for this, but I have no clue at ALL which settings to use... and if I should repair these files anyway or not. Maybe someone here who has some experience with this all can help me out?

 

Here are the files that have things missing: should I fix them or not? If yes, what settings should I use?

 

Alpha:

 

9415166228_dda6c32320_o.jpg

 

MipMaps:

 

9415166124_4d47ec7d0c_o.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Jeroen, if I understand your problem correctly, search for a tool called DXTFIX by Peter Nyman in the AVSIM Lib.

It checks for bmp files with missing alpha channels and corrects them if you want.

 

First you run it and it gives you an overview of faulty files, then you run it again and it fixes it. I gained some FP's doing so as even some UTX files miss the alpha channels.

Share this post


Link to post
Share on other sites

Thanks, I will do that, but DXTFIX doesn't look at or fixes mipmaps. No idea though if the few files that have 'errors' actually give me problems, though: there are just a few files with errors...

Share this post


Link to post
Share on other sites

For me it was only some Ultimate Traffic 2 files not having mipmaps. The Alpha channel missing was a bit wider spread, and indeed also some UTX files. I fixed them all and all still works, but I didn't notice any difference to be honest.

 

I think you can safely do these things, but just to make sure, back those files up first. I'm no expert, so if you aren't feeling lucky, I would make a back-up.

 

Now tell me, do you feel lucky, punk? B)

Share this post


Link to post
Share on other sites

In UTX, to my surprise, some of the road texture had missing alpha channels hence I can imagine fixing those takes care of some stutters.

At least I feel it does.

Share this post


Link to post
Share on other sites

Hm, funny thing is that I have UTX Europe but the program doesn't find any UTX textures with errors...?

Share this post


Link to post
Share on other sites