Sign in to follow this  
Pe11e

FPS drops on approaches

Recommended Posts

I usually fly POSKY 737 with FSND upgraded cockpit + FTXG + SceneryTech + PFE (ATC) + FSGRW + MyTraffic at 35%. I'm not currently using any addon airport (only default). On takeoffs FPS is around 45-50, durong cruise ~60fps, but on approches, especially on finals, fps is ~20-30, no matter what airport. I've tried to set AI to 0%, and FPS is better by couple of frames. Closed FSGRW, fps is the same, so it is not the culprit. Then on the last approach, I lowered autogen from dense to normal and fps was ~35-40. After that I set autogen back to dense, and fps is 42fps! Clearly it is an autogen problem, but I'm clueless why. I don't have guts to flush scenery indexes in FTX Central, or I could try to delete scenery indexes in c:\ProgramData\Microsoft\FSX\SceneryIndexes\, but that's all I can think of.

 

CFG tweaks:

 

[JOBSCHEDULER]
AffinityMask=14

 

HIGHMEMFIX=1

 

TEXTURE_BANDWIDTH_MULT=30

 

FIBER_FRAME_TIME_FRACTION=0.15

 

 

I appreciate any help and suggestions.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I don't understand. :) To reload a scenery (ctrl + shift + R) or to restart FSX? I can't reload FSX on approach, I'm using FSCaptain, I will cancel the flight that way. But I tested that already earlier, I was getting at least 40fps in front of that airport when I load up FSX.

Share this post


Link to post
Share on other sites

I don't understand. :) To reload a scenery (ctrl + shift + R) or to restart FSX? I can't reload FSX on approach, I'm using FSCaptain, I will cancel the flight that way. But I tested that already earlier, I was getting at least 40fps in front of that airport when I load up FSX.

I have been saving the flight on approach calling it "appDCA" or something, closing FS X, then immediately relaunching FS X and it seems the frame rate jumps right back up to normal. I do not reboot the computer.

Share this post


Link to post
Share on other sites

Yeah, but I can't do that with FSCaptain. :(

 

Anyway, I tested it again, reloaded FSX and fps on approach is 60fps! Not 40 as I was claiming. So FPS drops at least 50% on approaches after the whole flight. Weird. I can solve this problem with simple autogen density change, but it still annoys me ,because I know that something is wrong here.

 

EDIT: soon as I unpause the sim, fps is 40, so I was claiming good. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this