Sign in to follow this  
flying engineer

Gremlins have struck FSX/MCE sound setup

Recommended Posts

Had everything working very well thanks to FS++ crew help.

Now, for some unknown reason, the ATC and ATIS sounds are coming through the speakers instead of the headphone.

Have checked Windows 7 Control Panel/Sound settings and all still the same.

Playback = Speakers Creative SB X-Fi as default device

Recording = Microphone   2-USB Audio Device as default

 

FSX sound set up is the same as before. Have cycled back and forth here but no help.

 

Have gone through the MCE Assign Sound Device again. The Speech Application Programming Interface (SAPI) does it's thing as always.

Have also gone through the APP Wizard again.

 

Not sure what to look for now.

 

Would really like to get back to all Radio sounds through headphones and aircraft etc sounds through speakers.

 

Any ideas out there?

 

Edwin Brown Keremeos BC Canada

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Not sure I can help much, but I find that sometimes when I start a flight, FSX changes the sound settings back to default for no apparent reason. I have to go to Menu/Options/Settings/Sound to set them correctly.

 

If this is happening to you, then it would certainly explain why your ATC voices are coming through your speakers (your default playback device).

 

But you say your FSX sound settings are 'the same as before'. By which I assume you mean that if you are in game and check your settings via Menu/Options/Settings/Sound, you still see your Voice sounds set explicitly to the headset ?  

 

Also - does this happen even if you run FSX without MCE ?

Share this post


Link to post
Share on other sites

Have lost track of how many times I've uninstalled and reinstalled MCE version 2.5.7.8.

Last installation, for whatever reason, cleared up the voice sounds problem I had.

 

Now having that same old problem of no recognition when transmitting to ATC for landing instructions and no recognition from Ground Control for taxi instructions. Even though I use the same words that come up when I finally give up and just use voice command to select whatever ATC number I need.

Have been making the same flight every time and have copied down the words.

 

Have tried the new FS++ crew suggested "vGaAtcCtrlFsx.cfg" but makes no difference that I can see.

 

Have run out of ideas and patience.

 

Thanks for the reply. (I still remember the "Dick is here" help you gave me some time ago.

Share this post


Link to post
Share on other sites

I feel a bit like the Genie in Aladdin. Mention DickIsHere and he magically appears. Not sure I can work magic though !

 

You don't say whether everything was working on 2.5.7.8 previously or whether it was an older version. The reason I ask is that I have been working with the FS++ folks over the past couple months to resolve some PTT issues which seemed to creep in some time after 2.5.5.0. Ironically, it seems they mainly showed up when the DickIsHere option is set ! So I would NOT recommend setting that option for 2.5.7.8. But in the course of fixing these, I know they also made a number of general improvements to the PTT processing which has made it a lot more reliable. So I would suggest trying the latest version 2.5.8.2. as a basis for moving forward.

 

It's also possible that you have reset some setting you used to have when you did the new instal. One that springs to mind is the option that tells MCE not to insist on an accurate callsign. Can't recall exactly where that is, but it's in the GUI somewhere.

 

Although a new installation of MCE picks up most of your old settings (from mce.ini in Users\<<yourId>>\Appdata\Roaming\Multi Crew Experience), I've noticed that I still have to make some settings manually after a re-install.

 

The settings also get reset if you run the MCE application wizard.

 

Hope this helps a bit. Good luck !

Share this post


Link to post
Share on other sites

FS++ Crew sent me the link for version 2.5.8.2 on December 15 2013 and that is what I've been using.

After the last uninstall I went through my entire computer system and removed anything to do with MCE.

All folders on any drive, and every thing in the registry.

All I left was the main folder for MCE with my license code.

The last install cured the mic/speaker sound problem ???????

I have not put in the "Dick is here" nor altered anything in the mce.ini file.

I have everything set up in the GUI for what I want, including not to insist on an accurate call sign.

 

My two favorite aircraft are the RealAir Scout and the Quest Kodiak but I use the FSX default Skyhawk for testing out MCE. Not that I think any particular aircraft is the problem.

 

Am going to take up an FSX default twin, with a fully functional default GUI, and that pesky co-pilot to see if he can have more luck communicating.

 

Thanks again for the help.

Share this post


Link to post
Share on other sites

In that case, the best I can suggest is to work with the FS++ support team via email. They are very responsive.

Share this post


Link to post
Share on other sites

Glad to report MCE works much better in  the "big iron" and the co-pilot, for the most part, does his thing OK.

 

My problem still happens when flying the singles between non-towered strips.

No co-pilot aboard of course.

MCE ATC communications still very unpredictable -- works OK sometime through entire leg and then, for whatever reason, doesn't get through at some point of the leg and I have to resort to voice command selections of the ATC options.

The frustrating part is that the exact same phrases I am using are then coming up when I make the voice command selection.

 

Am still enjoying FSX though. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this