Archived

This topic is now archived and is closed to further replies.

jimh

Can I air a Controller problem here?

Recommended Posts

If this question is out of order here, please tell me.  I don't want a smack for posting in the wrong forum!

 

I'm running FSX, exclusively in DX 10.  My new CH Pro Throttle has developed a problem.

 

When running at or near full throttle, it intermittently jumps down to around half, and when at idle, it jumps up to half throttle without warning.

 

The latter problem can make it impossible to land a helicopter, while the former, while flying the Real Air Lancair Legacy, reduces the setting from around 25 manifold pressure to 14.  The tiniest movement of the throttle restores the setting, only for the problem to repeat.

 

The throttle is activated in FSX, and I've now tried calibrating it in FSUIPC.  I've moved the connection to three different usb ports, two on a powered hub, and one on the motherboard.  The problem persists!

 

I'd be grateful for any suggestions.

 

Best, Jim

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Take it back to the supplier, Jim. This sounds exactly like an intermittent throttle pot - or the wire connecting to the one side of the pot is partially disconnected, and could be held there by the silicone strain relief "stuff". You could try spraying it with a contact cleaner - but it's new - and you shouldn't have to.

 

All the Best, 

 

pj

Share this post


Link to post

Hi Paul,

 

Thanks for the advice.  I think I'll take it!

 

Background:

My trusty Pro Throttle started to misbehave after I had been on a long boring flight, and had been in and out of FSX to look at other things while in flight.  I blamed myself for fooling around.

 

I tried everything I could think of, software wise, to no avail.

 

I took the Throttle apart, as I had done before with my Eclipse Yoke, firmed up the spade terminals, and gave them a spray.  Full of hope, I fired up FSX, but the throttle was all over the place.

 

The problem seemed to be a hardware one, so I appealed to Santa, and having been a good boy (aren't I always?), he brought me a new one.

 

This is the one I'm now talking about, and if I'm at full throttle (for example) it kicks back to half at regular intervals.

 

Since I got your reply, and being so scared of having done something stupid in FSX which would affect the new throttle, I've installed FS9 in my second computer, and the Throttle behaves exactly the same there.

 

I think it's now proved beyond reasonable doubt, that the new one must go back as faulty.  I'm not blaming Santa, since I believe he only took care of delivery!

 

Best, Jim

Share this post


Link to post

If you're a handyman, Jim (i.e a use hammer and a saw) you can easily build your own stick and throttle/mixture/prop assembly with the USB board, connectors, slider pots, etc., from Desktop Aviator. It takes a bit of thought, but it's not difficult at all.

 

All the Best - Prosperous New Year!

 

pj

Share this post


Link to post

The Very Best New Year, to you too, Paul.

 

I've actually got my old Throttle working, but not with a full range.  I took it apart again, blew cleaner inside the pot, wiggled the lever, and blew any excess out with compressed air.

 

Desktop Aviator looks interesting.  I can solder, but have no electronic knowledge at all.

 

A trim wheel would make a nice addition, but I'd need to study any instructions available, to see if they are reasonably fool proof.

 

Best, Jim

Share this post


Link to post