Sign in to follow this  
SEGAR

small things to fix

Recommended Posts

Hi,

 

after flying and testing a bit I think this need some fixing, please correct if i'm wrong :

 

- wingstab switch has no clicksound

- pressurization switch has no clicksound

- strobe lights... is this the real thing ? Carenado said it's done after the real thing and they do not flash simultaneous. (new type Phenom ?) I think they should flash simultaneous on/off just as the  red beacon and not a 3 way flash unsynchronized.

- stall protection button test -> not working

-  fire button test -> not working

- manual speed dialing is slow

- pressing yaw demper on and off again -> stays on on the MFD

- aircraft feels underpowerd certainly at takeoff

 

 

kind regards

Fabrice

 

 

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

See I thought that too reference takeoff power but I think the trick is to build up speed and then it seems to climb at 2000-2500 fpm with half load under the CLB hash mark on the power levers.

 

So pitch for 10 deg up and let the speed build first.

Share this post


Link to post
Share on other sites

Get air born level off at about 10 feet off the runway suck the gear up build up speed (200 or above) and start a shallow climb.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this