Sign in to follow this  
RobWhightNZ

Can only see "default" aircraft textures ?

Recommended Posts

Hi all,

 

I'm running Perpar3D and have installed Level D's 767. All good, works fine etc. I've run into some trouble though in trying to use other textures beyond the ones that have the "Level D" livery. They install fine but, when I select, say a United Airlines liveried aircraft, I still see the default "Level D" textures. Textures were installed with the livery manager.

 

I've looked at the aircraft.cfg file and all looks well. I've had a look in the texture folder of the other liveries and often there are significantly more files there, either .bmp or .dds, but this doesn't seem to matter. I suspect that Prepar3D is failing to read the textures and is then referring to the texture.cfg file where it provides "fall back" alternatives. I just can't figure out why it is doing this.

 

If I were to have installed the PMDG 747-400 ("Allegedly" :( ), I might (!?) have the same issue.

 

Can anyone shed any lighton this ?

 

Cheers,

Rob

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Is this a P3D v2.1 certified add-on? How did you install it if not certified and how did you install the paintings?

Spirit

Share this post


Link to post

I know the PMDG certainly isn't, not sure about Level-D. Partly beside the point though - I'm not seeking 'manufacturer support' because I accept they haven't tested in the P3D environment and so aren't claiming that my purchase should be able to work there. I've seen YouTube videos from others who have got them working and I'm wondering what I'm doing wrong.

 

I find it interesting that it doesn't and, whilst I can get FSX and P3D to do most things, this one is baffling me. So an opportunity to learn something that may open up other doors.

 

 

Cheers,

Rob

 

 

Sent from my iPad using Tapatalk

Share this post


Link to post

Maybe it is the same problem I had with importing the stock FSX aircraft.

It seems Prepar3D didn't like that the default texture was referenced in the aircraft.cfg directly (with 'texture=' or 'texture=""').

When choosing a variant from the list often only the default texture was shown (and also loaded later), it seemed kinda random, sometimes it worked, most times not.

 

The solution was adding a texture.0 directory only with a texture.cfg with the following:

[fltsim]

fallback.1=..\texture
fallback.2=..\..\..\..\Scenery\Global\texture

and I also copied the thumbnail.jpg from the default folder into this (maybe optional).

 

Then in the aircraft.cfg I changed 'texture=' or 'texture=""' to 'texture=0'.

That solved all my problems with showing/loading textures of the stock FSX planes.

 

Kinda weird though as I have other planes that also directly point to the default texture without a problem...

Cheers,
Jan

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this