Sign in to follow this  
dva238

Jammed spoiler handle

Recommended Posts

It seems after completing a flight  I can't get the spoiler handle back to the up position, instead staying at the 50% position.  It's been happening regularly.  What should I do?  None of the Saitek controls are assigned to the speed brake.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Go into your FSX controls settings, calibrate your throttle quadrant...is there a smooth motion there or not?

If it is not smooth, you need to open the quadrant and clean the contacts. There is a video on Youtube that will help you with that.

I recently did it and its smooth as butter now.

 

Do you use FSUIPC?

 

Best regards,

Rene

Share this post


Link to post
Share on other sites

The spoiler handle is no longer assigned to the throttle quadrant.  However, when I put the throttle forward, the handle moved back to the up position.

Share this post


Link to post
Share on other sites

The fact that FSX is responding, even if incorrectly, shows that the quadrant is still assigned somewhere in your FSX. You should go through even the key assisgnments and joystick assisgnments to eliminate the culprit. I had it myself where all of a sudden the quadrant was assigned to something under FSX controls and I had to remove it.

 

Do you use FSUIPC?

 

Best regards,

Rene

Share this post


Link to post
Share on other sites

It moved when the throttle quadrant was moved.  However, the spoiler control on the left side was already unassigned in FSUIPC.  Moving it does not change the throttle, but the throttle movements move the spoiler.  The spoiler won't go all the way back when I move the handle.

Share this post


Link to post
Share on other sites

Please go through this and the other videos...this might resolve the issue for you or put you on the right track:

 

 

Best regards,

Rene

 

This is probably obvious to you as a FSUIPC user...but first calibrate the quadrant through FSX -> Controls -> Calibrate...this will bring up windows calibration.

 

 

Then do the assigning of the devices in FSUIPC followed by calibration.

Share this post


Link to post
Share on other sites

Update, I fixed the controls so the gear handle won't activate when thrust reverse selected.  However, if I move the spoilers down, they get stuck at 50% and there isn't an FSUPIC or FS axis assigned to them. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this