Sign in to follow this  
nemokin

Runtime error 5 when selecting FSX flight plan

Recommended Posts

When I selected FSX flight plan, I got runtime error 5 which forced RC4 to shut itself down.

Any idea why and how to correct this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

RT Error 5 means that an item is badly formatted or beyond the acceptable range of what RC expects.

 

Is this your first use of RC? Is it just this one plan or all.

 

You need to make sure sure that Win and FS are set up to use decimal points, not commas, to indicate decimal values.

 

Be sure your Win language is set to US/English.

 

If a gate number is in the plan or set in RC there should be no space between the letter and number.

 

If you set a cruise level in RC's controller tab be sure you do not enter the last two zeroes which RC already adds.

 

Copy the .pln file text and paste it in a reply here.

 

You also need to insure fsuipc and makerwys are current (see pinned topic) and that you have run the scenery rebuild correctly. Be sure you entered the correct path to FS when RC requested it.

 

Did you edit manually any of RC's .csv files? If you used a spreadsheet or database program, not a text editor, it will have corrupted the file for RC's purposes.

Share this post


Link to post
Share on other sites

ronzie, thank you for your response.

 

This is my first RC use and I have tried only 1 plan so far.

The plan I tried was for an IFR flight with NGX, created using PFPX.

I have not designated any gate numbers to the plan.

 

As for the decimal setting in WIN, I do not know about this.

I am just an average user, so I actually have no idea what this is all about.

 

My OS language is Japanese Win7 Ultimate but I have it set to display in

English. File directory construction is in Japanese however.

Obviously, PFPX and RC4 are English versions, same for my FSX.

 

I have not set anything within RC4 since I have not been able to

open the flight plan to make any adjustments for that flight.

My FSUIPC and makerwys should be current (what is the most current

version of makerwys?)

 

Below is the copy-paste of the plan that is not opening.

(Again made using PFPX)

 

<?xml version="1.0" encoding="UTF-8"?>

 

<SimBase.Document Type="AceXML" version="1,0">

<Descr>AceXML Document</Descr>

<FlightPlan.FlightPlan>

<Title>LEBL to LOWW</Title>

<FPType>IFR</FPType>

<RouteType>HighAlt</RouteType>

<CruisingAlt>38000</CruisingAlt>

<DepartureID>LEBL</DepartureID>

<DepartureLLA>N41* 17' 49.00",E2* 4' 42.00",+000014.00</DepartureLLA>

<DestinationID>LOWW</DestinationID>

<DestinationLLA>N48* 6' 37.00",E16* 34' 11.00",+000600.00</DestinationLLA>

<Descr>LEBL to LOWW created by PFPX - Professional Flight Planner X (http://www.flightsimsoft.com/pfpx)</Descr>

<DeparturePosition>25L</DeparturePosition>

<DepartureName>BARCELONA/EL PRAT</DepartureName>

<DestinationName>VIENNA/SCHWECHAT</DestinationName>

<AppVersion>

<AppVersionMajor>10</AppVersionMajor>

<AppVersionBuild>61637</AppVersionBuild>

</AppVersion>

<ATCWaypoint id="LEBL">

<ATCWaypointType>Airport</ATCWaypointType>

<WorldPosition>N41* 17' 49.00",E2* 4' 42.00",+000014.00</WorldPosition>

<ICAO>

<ICAOIdent>LEBL</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="DALIN">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N41* 44' 1.64",E3* 21' 28.40",+000000.00</WorldPosition>

<ICAO>

<ICAOIdent>DALIN</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="PIVUS">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N41* 55' 26.06",E3* 56' 1.50",+000000.00</WorldPosition>

<ATCAirway>UN870</ATCAirway>

<ICAO>

<ICAOIdent>PIVUS</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="DIBER">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N42* 4' 47.00",E4* 24' 54.00",+000000.00</WorldPosition>

<ATCAirway>UN870</ATCAirway>

<ICAO>

<ICAOIdent>DIBER</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="SOSUR">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N42* 33' 36.99",E4* 59' 51.00",+000000.00</WorldPosition>

<ATCAirway>UN870</ATCAirway>

<ICAO>

<ICAOIdent>SOSUR</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="ROTIS">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N42* 58' 0.00",E5* 30' 0.00",+000000.00</WorldPosition>

<ATCAirway>UN870</ATCAirway>

<ICAO>

<ICAOIdent>ROTIS</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="ADITA">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N43* 13' 43.00",E5* 49' 44.00",+000000.00</WorldPosition>

<ATCAirway>UN870</ATCAirway>

<ICAO>

<ICAOIdent>ADITA</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="TURIL">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N43* 13' 36.00",E6* 1' 26.00",+000000.00</WorldPosition>

<ATCAirway>UL127</ATCAirway>

<ICAO>

<ICAOIdent>TURIL</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="STP">

<ATCWaypointType>VOR</ATCWaypointType>

<WorldPosition>N43* 13' 10.10",E6* 36' 6.50",+000000.00</WorldPosition>

<ATCAirway>UL127</ATCAirway>

<ICAO>

<ICAOIdent>STP</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="TIXIT">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N43* 20' 46.00",E6* 50' 30.00",+000000.00</WorldPosition>

<ATCAirway>UM985</ATCAirway>

<ICAO>

<ICAOIdent>TIXIT</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="RAPED">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N43* 22' 24.00",E6* 53' 36.00",+000000.00</WorldPosition>

<ATCAirway>UM985</ATCAirway>

<ICAO>

<ICAOIdent>RAPED</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="NARTI">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N43* 32' 57.00",E7* 13' 48.00",+000000.00</WorldPosition>

<ATCAirway>UM985</ATCAirway>

<ICAO>

<ICAOIdent>NARTI</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="PIGOS">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N43* 37' 20.00",E7* 22' 16.00",+000000.00</WorldPosition>

<ATCAirway>UM985</ATCAirway>

<ICAO>

<ICAOIdent>PIGOS</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="EKSID">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N43* 45' 24.99",E7* 37' 58.00",+000000.00</WorldPosition>

<ATCAirway>UM985</ATCAirway>

<ICAO>

<ICAOIdent>EKSID</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="NOSTA">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N43* 49' 9.99",E7* 45' 19.00",+000000.00</WorldPosition>

<ATCAirway>UM985</ATCAirway>

<ICAO>

<ICAOIdent>NOSTA</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="ABN">

<ATCWaypointType>NDB</ATCWaypointType>

<WorldPosition>N44* 3' 21.50",E8* 13' 15.60",+000000.00</WorldPosition>

<ATCAirway>UM985</ATCAirway>

<ICAO>

<ICAOIdent>ABN</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="MALUG">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N46* 42' 22.00",E12* 35' 51.00",+000000.00</WorldPosition>

<ATCAirway>UQ985</ATCAirway>

<ICAO>

<ICAOIdent>MALUG</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="ELKAT">

<ATCWaypointType>Intersection</ATCWaypointType>

<WorldPosition>N46* 59' 27.62",E13* 54' 19.82",+000000.00</WorldPosition>

<ATCAirway>UM985</ATCAirway>

<ICAO>

<ICAOIdent>ELKAT</ICAOIdent>

</ICAO>

</ATCWaypoint>

<ATCWaypoint id="LOWW">

<ATCWaypointType>Airport</ATCWaypointType>

<WorldPosition>N48* 6' 37.00",E16* 34' 11.00",+000600.00</WorldPosition>

<ICAO>

<ICAOIdent>LOWW</ICAOIdent>

</ICAO>

</ATCWaypoint>

</FlightPlan.FlightPlan>

</SimBase.Document>

Share this post


Link to post
Share on other sites

Further trial with an error.

 

I have yet to resolve my PFPX created plan ending with the runtime error 5

when selecting the plan.

 

I tried a RC4 tutorial flight which loaded successfully.

Now the problem is that after RC4 launches within the FSX

and I select one of the choices (getting learance delivery)

I get a ding with an error saying Runtime error 5

Radar Contact FSUIPC.rc4 message. Hmm...

 

One error after another...

 

Also, my RC4 voice is terrible.

Verty staticky and almost unable to understand what he/she is saying.

Share this post


Link to post
Share on other sites

The sticky voice might be your sound card settings. Try setting it to stereo, not 7.1 or 5.1 in the Win mixer settings. The RC voices are mono but play OK in two channel mode.

 

Go into your regional and language settings applet in the control panel. On the regional tab for now select English - US. Click details. Be sure the decimal symbol is set to a period. Allow two digits after the decimal point. Set thousands separator to , . Set the List Separator to comma. Click the languages tab. Click details. Set the default to English US. Click the Advanced tab. In the top dropdown select Engish-UK. In the bottom dropdown place a checkmark on item 10000 MAC-Roman and 20127 US (ASCII).

 

See if any helps. The last advanced setting is the most important.

 

Now another Asian user had this problem and solved it. Here is the thread:

 

http://forum.avsim.net/topic/434382-cant-get-rc4-to-work-help-please/?hl=%2Berror#entry2924549

Share this post


Link to post
Share on other sites

ronzie,

 

Reporting back.

 

My stereo setting was already "stereo" to begin with and not 7.1 or 5.1

I tested RC4 voice again, and it still sounds very bad.

Also, when I choose some voices, it comes back with Runtime error 6.

 

May be because my OS is Win7 64-bit Ultimate, but the "regional and language"

settings applet maybe a little different from your set up.

I was able to check for the decimal symbols, thousands separator, and digits issue

but all of these have been applied as you mentioned before I even looked at them.

I was unable to find the item 10000 MAC-Roman and 20127 US item.

 

My RC4 still cannot load the FSX flight plan, same runtime error 5.

Share this post


Link to post
Share on other sites

Did you read the thread I referred to?

 

Also please fill out your hardware and software profiles so they show up under your avatar as do mine.

Share this post


Link to post
Share on other sites

Yes, I did read the thread, a Chinese user.

He seems to have the same error issues, but I couldn't find any

clear indications that he found a working solution - did I miss it some where?

 

I will add the specs as you recommend.

Let me see if this will show my specs. I updated them on my profile page.

Share this post


Link to post
Share on other sites

Shall I email JD with my problem as was recommended in the thread?

Shall I email JD with my problem as was recommended in the thread?

By the way, today I tried to fly default B58 from add-on Buffalo to default Rochester in VFR.

When loading the flight plan into RC4, it shuts itself after giving me runtime error 5 as before.

So this problem isn't only related to my PFPX generated plan. Hmm...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this