Sign in to follow this  
brucek

EZCA in P3D v2.4

Recommended Posts

I'm a little screwed up with my P3D v2.4 and EZCA. I have Windows 8.1, with FSX installed (before any version of P3D). EZCA worked fine with FSX. When I started P3D 2.0 (around the end of last year), I recall I downloaded shortly after an EXCA .exe file that would work with P3D... this replaced EZCA.exe v1.7, as I recall.

 

I have upgraded P3D v2.x through all of it's versions, in each case a clean install, other than v2.4 where I patched v2.3. Maybe that's the issue, patching rather than a clean install...... since patching to v2.4, as P3D starts, I get the error:

 

FSX Process not found. FSX_handle: 0.

 

EZCA still starts and runs OK, if I ignore this error message and click on the P3D startup screen, the error goes into the background. All of my pre-configured aircraft work fine- but if I quit the error message EZCA quits too.

 

 

However, if I go to configure a new plane, when I bring up the EZCA screen through the Add-on menu, the error screen is now in the foreground and the EXCA configuration behind it, which maks it inaccessible.. until I kill the error screen, which then kills EZCA.

 

I have tried quitting the error message on P3D startup, which kills P3D, then trying to manually start EZCA while P3D us running, but the error scren returns with the same issues.

 

I've read some threads here about the error that I am experiencing- one use was able to get EZCA to run by quitting and restarting while P3D is running, but that doesn't work for me I(see above). I have checked my exe.xml file and all seems to be OK. I've tried running the migration tool before running P3D and that doesn't work.

 

I'm sure I am missing something very basic... any hints / suggestions most welcome.

 

Thanks, Bruce.

PS.Sorry to add a new EZCA thread here... seems this issue of P3D compatibility has been aroind for a while....

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Bruce,

 

It seems to be a bit of a bugaboo, doesn't it? I don't have issues with EZCA, other than the fact that it takes a bit of time to wake up occasionally. This is what I did. Maybe check to see if we're on the same page. I should point out that I only have P3D 2.4 installed. I uninstalled FSX.

 

-installed latest official version of EZCA using the Estonia Migration Tool set with Virtual FSX enabled.

-downloaded EZCA 1.17 beta exe, modified for P3D (sort of). Copied into EZCA folder and said yes to overwriting the existing file.

-ran configurator using Estonia Migrator Tool with Virtual FSX enabled

-checked to ensure that EZCA camera definition 202 was in cameras.cfg and definition 201 was in all aircraft config files. Also made sure there were no conflicts with other camera definitions. Where there were conflicts, I renumbered the definitions native to the aircraft (not EZCA). Also checked for conflicting hotkey assignments

 

I noticed in the EMT help pdf, that you cannot run P3D with Virtual FSX mode enabled, if FSX is installed. If no FSX, it doesn't matter. I don't run P3D with Virtual FSX enabled. I enable when I have to install or configure an application that doesn't understand P3D, then disable when done.

 

If I've just made the water murkier, apologies. But that's my take,

 

Graham

Share this post


Link to post

Hi Graham,

 

Thanks for the reply, much appreciated.

 

I believe I have it fixed, at least 3 out of 3 times.... I copied the EZCA.exe over itself rom my original download earlier in rthe year, don't ask me how that makes any difference.. :)

 

Thanks again, Bruce.

Share this post


Link to post

Bruce,

 

Whatever works....eh? There seems to be so many ways to make something work, sorta work, kinda work, maybe work, also work.....

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this